XPerf - The parameter is incorrect RRS feed

  • Question

  • Using Windows 8.1 with 64 bit.

    Running these commands as admin. What is wrong with the third command?

    xperf -on DiagEasy
    xperf -d foo.etl
    xperf foo.etl
    xperf: error: foo.etl:  The parameter is incorrect. (0x80070057).

    The foo.etl file is created and has size of 35 MB.

    Wednesday, March 26, 2014 9:15 AM

All replies

  • you need to zip and upload "foo.etl" file in order to investigate this issue

    • Edited by britishdhez Wednesday, March 26, 2014 9:38 AM
    • Marked as answer by kelvin_hsu Monday, April 7, 2014 1:56 AM
    • Unmarked as answer by kelvin_hsu Monday, April 7, 2014 1:56 AM
    Wednesday, March 26, 2014 9:38 AM
  • http://www.uploadmb.com/dw.php?id=1395903989
    Thursday, March 27, 2014 7:07 AM
  • Hi,

    It seems that xperf <trace file> is no longer support to display graphical analyze tool.

    And the replacement is: wpa <trace file>

    Kate Li
    TechNet Community Support

    Tuesday, April 8, 2014 6:05 AM
  • Hi, I have a similar issue, any chance you would know the solution? 

    My audio is usually perfect when I'm browsing the web, watching netflix, listening to music etc.. As soon as I open up a game the audio starts to crackle, some games less some more. I ran the DPC latency test and some was hitting 8k. I'm running W10 and have the performance toolkit installed. I had ran the first line of code, opened up a game, listened to youtube, the audio crackled so I ran the second line (giving about 3-5mins log time) the second line executed, but when I went to run the 3rd line. I got this error:

    xperf: error: C:\Users\Jason\Desktop\trace.etl: The parameter is incorrect. (0x80070057)

    Any ideas?

    Wednesday, December 27, 2017 1:59 AM