locked
Bug with "All Programs" menu? RRS feed

  • Question

  • I am running Windows 7 Professional Service Pack 1 in my computer. I copied the directory "C:\Program Files (x86)\PuTTY" and pasted it to "C:\ProgramData\Microsoft\Windows\Start Menu\Programs" in order to add the "PuTTY" folder to the "All Programs" menu in the Start menu. The "PuTTY" folder showed up with the "putty.exe" program in that folder as it normally should in the "All Programs" menu in the Start menu. Then, I changed my mind and decided to cut the directory "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\PuTTY" and paste it to "C:\Users\bhlee\AppData\Roaming\Microsoft\Windows\Start Menu\Programs". However, after doing this, the "PuTTY" folder showed up as it is shown in the following:

    The top "PuTTY" folder is supposedly located in "C:\ProgramData\Microsoft\Windows\Start Menu\Programs", as its containing "putty.exe" program is supposedly located in "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\PuTTY". However, the "PuTTY" folder does not exist, as shown in the error message below after right-clicking on the "PuTTY" folder and left-clicking on "Open":

    Right clicking on "putty.exe" and then left-clicking on "Open" shows another error message that is similar to the one shown above. The bottom "PuTTY" folder is supposedly linked to a non-existent folder ("C:\Users\bhlee\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\PuTTY\PuTTY"), as referenced in another error message that is popped up after right-clicking on the "PuTTY" folder and left-clicking "Open". The error message is almost the same as the one shown above. Is the scenario that I present to you a bug? Thank you.


    • Edited by CatGuy90 Wednesday, December 4, 2013 8:03 PM
    Wednesday, December 4, 2013 8:00 PM

Answers

  • ... Is the scenario that I present to you a bug? ...

    Hi,

        

    You have copied the Putty folder into ProgramData folder, and later decided to move it into a user profile folder.

             

    You may refer to this link for better understanding between copy and move command:

    How permissions are handled when you copy and move files and folders

        

    An extract from the link:

    By default, an object inherits permissions from its parent object, either at the time of creation or when it is copied or moved to its parent folder. The only exception to this rule occurs when you move an object to a different folder on the same volume. In this case, the original permissions are retained.

      

    Follow these steps to resolve the problem:

    • Right click C:\Users\bhlee\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\PuTTY and click on Properties.
    • Click the Security tab.
    • Click the Advanced button.
    • Click the Change Permission... button.
    • Check the Replace all child object permissions with inheritable permissions from this object checkbox.
    • Click the Apply button.
    • Click on Yes button when prompted.

        

    Hope that helps.

        

    Cheers,


    Tas Chew

    • Marked as answer by ZigZag3143x Saturday, December 7, 2013 9:12 PM
    Thursday, December 5, 2013 10:56 AM

All replies

  • ... Is the scenario that I present to you a bug? ...

    Hi,

        

    You have copied the Putty folder into ProgramData folder, and later decided to move it into a user profile folder.

             

    You may refer to this link for better understanding between copy and move command:

    How permissions are handled when you copy and move files and folders

        

    An extract from the link:

    By default, an object inherits permissions from its parent object, either at the time of creation or when it is copied or moved to its parent folder. The only exception to this rule occurs when you move an object to a different folder on the same volume. In this case, the original permissions are retained.

      

    Follow these steps to resolve the problem:

    • Right click C:\Users\bhlee\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\PuTTY and click on Properties.
    • Click the Security tab.
    • Click the Advanced button.
    • Click the Change Permission... button.
    • Check the Replace all child object permissions with inheritable permissions from this object checkbox.
    • Click the Apply button.
    • Click on Yes button when prompted.

        

    Hope that helps.

        

    Cheers,


    Tas Chew

    • Marked as answer by ZigZag3143x Saturday, December 7, 2013 9:12 PM
    Thursday, December 5, 2013 10:56 AM
  • Your proposed solution works. Before I tried out your solution, I shut down my computer and started it up again. It turns out that the child folder "PuTTY" took over automatically! What this means is that the child folder with its containing "putty.exe" file moved up in the hierarchy. This time, Windows 7 Professional recognized that the child folder had the "putty.exe" file instead of no file at all, unlike last time. Was this supposed to happen? I would like for you to decide whether to respond or not. Then, I tried out your solution, and it worked on a different folder. Thank you!
    • Edited by CatGuy90 Saturday, December 7, 2013 9:23 PM
    Saturday, December 7, 2013 8:40 PM