none
Issue backing up vm's using DPM online backup mode RRS feed

  • Question

  • I have started to have an issue backing up some of my Hyper-V virtual servers using DPM online backup.

    Server scenario - VM host running Hyper-V server 2008 R2 - Guest running windows server 2003 R2 VM + Exchange 2007 + SQL 2005

    DPM backs this servers up using the online mode "\Back up using child partition snapshot" but is failing after approx 30 minutes.

    DPM error is a transient error - Windows logs on both HOST and Guest show nothing more than a services stopped because of idle timeout

    DPM is protecting all other data sources correctly including 1) other vm's on same host (using offline mode "\Backup using saved state") 2) data on/in this guest server mentioned - all vss writers advise stable state (host + guest) - servers (host + guest) restarted to reset writers and still issue present.

    Any ideas anyone

    Friday, November 25, 2011 3:43 PM

All replies

  • Hi,

    Firts of, are you running a host level backup (Virtual Server) at the same time your running a gest-level backup (DPM Agent inside the virtual server)? This could cause some errors with time out.

    Is your Hyper-V enviroment in a cluster? If so, are you using hardware (snapshot at SAN level) or software VSS? If you're using software, have you configured your backup for using seriell backups?

     


    Best Regards

    Robert Hedblom

    MVP DPM


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Monday, November 28, 2011 12:32 PM
    Moderator
  • Hi Robert,

    I am running a host and guest backup simultaneously.

    Exchange and sql are synchronised every 30 minutes in the guest.

    Hyper-V host in not clustered and runs on its own raid hds.

    The dpm backup will be using the hyper-V vss software.

     

    This was never a problem though

    Monday, November 28, 2011 1:24 PM
  • Hi Dexter,

    I have run into similar problem with one of my customers. Chaning the time of the host-level backup (entire VM) from another time than the guest-level backup solved my problem. In my case this was due to poor resources on the Hyper-V hardware, so the VSS didn't get enough resources to operate.

    How often do you preform a backup of the virtual machine?


    Best Regards

    Robert Hedblom

    MVP DPM


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Monday, November 28, 2011 8:45 PM
    Moderator
  • Hi Robert,

    The problem appears to be more than just backup.

    After your previous post I cancelled all sync and backup jobs for one of the machines to give me a 4 hour window - The sync job failed again after 30 minutes.

    Other info:

    The spare HD space on the host is low (12gb), but it has plenty of everything else. SAS 6GB controllers + drives and 8 gb ram after guest assignment.

    I can not even complete a synchronisation of any of the problem servers.

    I have removed a few VM (vhd files) form the host to free 75 gb and return some more ram to host but still not working.

    I have installed the latest March 2011 DPM patch. - x.7077.07

    I have deleted some retention data from DPM as well to free up backup space and still no luck.

    I found some info on the net that advised a few possible causes - IP chimney - so changed as advised.

    Other possible issue is a mountvol issue on the Hyper-V host which appears to think someone has added a 2gb HD which can not be initialised through comp manager as not there - so will look into this today.

    Another thought is to increase the vss writer idle timeout from 30 mins to 60 mins and see what happens - Do you know if this can be done?

    Thanks for your points/help with this

    Tuesday, November 29, 2011 9:27 AM
  • I came across this same issue recently where we started to require backup of VHD in an environment where previously this was not required. This is what resolved it for me - may be a different issue but worth mentioning if anyone else comes across this post.

    The SAN we are using in this case is an iSCSI SAN with a hardware VSS writer installed on each Hyper-V cluster node. The symptoms are exactly how you've described above. We noticed errors in the application event log showing login failing to iSCSI targets - originally these didn't look like VSS errors but were classified as VSS on closer scrutiny.

    Because we had CHAP authentication on the iSCSI network enabled in conjunction with IP security, when we attempted to create a backup of a VHD the hardware VSS writer was being called as the preferred writer and failing. We could not find a way to provide CHAP credentials when DPM called access to the SAN LUN from the host (is the host software supposed to provide this?) and I cannot see in TechNet documentation anything about a hardware provider with CHAP auth.

    To work around the issue we have two options - disable the hardware VSS writer and use the software VSS writer or disabling CHAP authentication and reverting to IP authentication on the iSCSI initiator and target volumes configuration.

    This worked for us and resolved the issue - we are now able to protect virtual machines on this Hyper-V cluster.

    Tuesday, July 31, 2012 5:56 AM