none
How to stop IE from caching WPAD RRS feed

  • Question

  • Hello, first of all - I've looked at this article which unfortunately has not worked for us. Even once performing the Reg change and rebooting, WPAD files are still being cached. http://support.microsoft.com/kb/271361

    I'm trying to prevent WPAD from caching because our hosted web security solution requires that our users all connect from a range of known IP addresses. This is fine for our office workers, but when our roaming users try to connect - they're unable to access the internet as their session cannot authenticate.

    This is a problem/limitation of our hosted solution - but to work around this we use WPAD. WPAD, or 'automatically detect settings' should search for WPAD and use that if found, otherwise allow direct access to the internet.

    Our wpad.dat file lives on an internal webserver with a DNS CNAME of wpad - so when out of the office, this should be unreachable (we've blocked firewall access to this webserver if using a VPN connection too).

    IE8 however is caching the WPAD file locally, which means that until the user deletes the wpad[1].dat file in their temporary internet settings - they're unable to authenticate with our proxy service and are hence blocked.

    All attempts to prevent this cache have failed, so I can only think I'm either missing something - or something is overriding the registry command and is causing this to cache regardless.

    Any help would be much appreciated.

    Alternatively, I've been made aware of a WPAD function called 'myIPAddress()'. Could this be used to specify a return 'DIRECT' address if the users' IP address is NOT part of the corperate range?
    Friday, August 19, 2011 1:16 PM

Answers

  • Hi TownendK,

    It seems the current user is caching WPAD location for IE.

    Try to delete the following registry key to check if it works. (Note: Export and take a backup before modify the registry in case of any risks.)

    Locate: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections

    Clear these two on right pane:  DefaultConnectionSettings, SavedLegacySettings

    Regards,

    Miya
     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 23, 2011 5:56 AM
    Moderator
  • Hi TownendK,

    I think you can use a script to automatically clear the cache.

    This is for your reference: http://blogs.isaserver.org/pouseele/2007/11/09/clearing-the-cached-wpad-script/

    (Note: Since the site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.)

    Regards,

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, August 25, 2011 3:33 AM
    Moderator

All replies

  • are you using both "automatically detect settings" *AND* "use automatic configuration script" ?
    Don
    Friday, August 19, 2011 11:39 PM
  • are you using both "automatically detect settings" *AND* "use automatic configuration script" ?
    Don


    No, just 'Automatically Detect Settings'.

     

    Regards

    Monday, August 22, 2011 7:56 AM
  • we've had mixed success over the years with WPAD, across w2k/wxp/win7, with various IE versions.
    we found that setting both of those settings works most reliably, and i've not yet seen issues with wpad applying when not needed.

    (we are using wpad specified as a proxy.pac, rather than wpad.dat, but from my reading, that should not matter)


    Don
    Monday, August 22, 2011 9:39 PM
  • Hi TownendK,

    It seems the current user is caching WPAD location for IE.

    Try to delete the following registry key to check if it works. (Note: Export and take a backup before modify the registry in case of any risks.)

    Locate: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections

    Clear these two on right pane:  DefaultConnectionSettings, SavedLegacySettings

    Regards,

    Miya
     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, August 23, 2011 5:56 AM
    Moderator
  • Hi TownendK,

    It seems the current user is caching WPAD location for IE.

    Try to delete the following registry key to check if it works. (Note: Export and take a backup before modify the registry in case of any risks.)

    Locate: HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections

    Clear these two on right pane:  DefaultConnectionSettings, SavedLegacySettings

    Regards,

    Miya
     


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.


    Hi Miya, I've found those two entries and you're right - the settings are cached there.

    We need to figure out how to prevent them from caching there in the first place though, as they simply are repopulated during the next IE session if deleted.

    Wednesday, August 24, 2011 9:04 AM
  • Hi TownendK,

    I think you can use a script to automatically clear the cache.

    This is for your reference: http://blogs.isaserver.org/pouseele/2007/11/09/clearing-the-cached-wpad-script/

    (Note: Since the site is not hosted by Microsoft, the link may change without notice. Microsoft does not guarantee the accuracy of this information.)

    Regards,

    Miya


    This posting is provided "AS IS" with no warranties, and confers no rights. | Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Thursday, August 25, 2011 3:33 AM
    Moderator