locked
Sharepoint AAM issue RRS feed

  • Question

  • Hi,

    I would like to have some help in order to publish properly my Sharepoint 2010 over the Internet.

    Here is my configuration:
    - Sharepoint 2010
    - published with TMG 2010
    - internal url : srvshpt.domain.GRP:800 (used in my TMG web listener)
    - external/public url: shpt.domain.COM:800

    Current configuration of AAM:
    - srvshpt.domain.GRP:800 / default / srvshpt.domain.GRP:800
    - shpt.domain.COM:800 / Intranet / shpt.domain.COM:800
    - shpt.domain.COM:800 / Internet / shpt.domain.COM:800

    I can connect successfully from the Internet to the following link: shpt.domain.COM:800/sites/... - I am also able to read any documents.

    I'm encountering an issue when I try to bring some modifications on my libraries, documents,...: Internet Explorer cannot display the webpage.
    When I check the URL, I can see that IE is automatically redirected to the internal URL: srvshpt.domain.GRP:800, instead of using the public url: shpt.domain.COM:800

    Do you have any idea in order to help me to solve this issue?

    Thanks by advance for your help!

    Thursday, May 31, 2012 8:00 AM

Answers

  • Hi,

    I added the intranet zone because my previous configuration failed with only "default" and "Internet".

    But finally my error is not related to this option and I found the issue: when I created my publishing rule on TMG, AAM was not yet properly configured. And since I updated my Sharepoint configuration I never applied any modification on my TMG.

    So, the solution was to modify my TMG publishing rule at the following screen: "Alternate Access Mapping Configuration" -> choose "Sharepoint AAM is already configured on the Sharepoint Server".

    Now I'm able to create/modify any document/libraries without beeing disconnected from the website.


    My next challenge: use only the username and password to authenticate because actually I need to use "domain\user" or user@domain credentials and that's soooo boring.. but I will open a new thread for that.

    Thanks for your help Daniel and the link you provided to me, that's helped me so much!




    • Edited by B-ni Thursday, May 31, 2012 12:14 PM
    • Marked as answer by B-ni Thursday, May 31, 2012 12:34 PM
    Thursday, May 31, 2012 12:11 PM

All replies

  • Hi,

    try to remove the intranet zone.

    Check this link for more information about publishing SharePoint using TMG:

    http://www.isaserver.org/tutorials/Publishing-Microsoft-SharePoint-2010-Forefront-TMG-different-authentication-options-Part2.html

    Cheers,


    Daniel Bugday
    Microsoft Community Contributor, Member of Microsoft Extended Expert Team, MCT, MCTS/MCPD SharePoint 2007/2010, SQL MCDBA, MCSE

    Blog: SharePoint By Bugday
    Twitter: Follow me on Twitter
    Technet: My Ask The Expert Area On Technet
    Founder of SharePoint Forum


    • Edited by Daniel Bugday Thursday, May 31, 2012 8:33 AM added ilnk
    Thursday, May 31, 2012 8:31 AM
  • Hi,

    I added the intranet zone because my previous configuration failed with only "default" and "Internet".

    But finally my error is not related to this option and I found the issue: when I created my publishing rule on TMG, AAM was not yet properly configured. And since I updated my Sharepoint configuration I never applied any modification on my TMG.

    So, the solution was to modify my TMG publishing rule at the following screen: "Alternate Access Mapping Configuration" -> choose "Sharepoint AAM is already configured on the Sharepoint Server".

    Now I'm able to create/modify any document/libraries without beeing disconnected from the website.


    My next challenge: use only the username and password to authenticate because actually I need to use "domain\user" or user@domain credentials and that's soooo boring.. but I will open a new thread for that.

    Thanks for your help Daniel and the link you provided to me, that's helped me so much!




    • Edited by B-ni Thursday, May 31, 2012 12:14 PM
    • Marked as answer by B-ni Thursday, May 31, 2012 12:34 PM
    Thursday, May 31, 2012 12:11 PM