USB Hardrive security access "Denied" on every folder RRS feed

  • Question

  • OK, I know some one going to direct me to existing answear but! I CAN NOT DO A FREAKING; TAKING OWNERSHIP OF ALL FOLDER FROM ROOT FOLDER. I have to click on each folder and every file to take ownership. Every other technique i tried it fails with "ACCESS DENIED" I am logged in as ADMIN, i also tried to turn off UAC, got same retarded message.

    Took ownership of device already.

    All of this started after a single windows update, Even my Visual Studio had no permision to change files on my usb HDD's. Unless i ran it as Administrator. everything i try to access requiers administraitor access, and everything worked fine bcs i work with the files o daily basis, It contains my clientts Data from Graphic to multimedia files, and offcourse webfiles.


    Update i received was a critical update that rebooted my machine, Dont remmember exact day, but i probably can find a post when my Visual Studio stoped working properly.

    My Windows:
    windows 7 Home Premium

    Friday, February 11, 2011 3:15 AM


  • Hi,


    Since the issue occurred after installing an update, you can perform a System Restore.


    If the issue persists, how about other USB drive? If the issue only occurred on one USB drive, I suspect it infected by the viruses. Please scan for your USB drive to ensure it is clean.


    If the issue persists, you can use command line to take ownership of the folder.



    Best Regards,


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Vivian Xing Friday, February 18, 2011 9:35 AM
    Monday, February 14, 2011 10:00 AM