Appverifier error while installing Windows Software Logo Tool Kit V1.0.7112.140 on Windows 7 system RRS feed

All replies

  • HI

    While installing the tool kit, a user Access Control pop up asking whether to change the settings in windows or not. If "Yes" is clicked then the tool is throwing the above error. If "No" is selected then it is getting installed.

    But dont know whether the tool installed in this manner works correctly or not.

    Sowjanya Ashok
    Friday, October 30, 2009 3:18 PM
  • Hi Slankadasu ,

    Indeed, it fails here as well, I will see if I can find what is going wrong.
    The .exe is a compressed self extracting archive that you can extract using your favorite archiving software.
    In there are two MSI files that you can use the install the products by hand.

    Windows Software Logo Kit.msi

    Hope this helps solving your issue.


    Friday, October 30, 2009 3:58 PM
  • HI

    Thanks for the answer Daniel. 

    Sorry but the tool which i have downlaoded from the Microsoft site is not a Zip file.

    That is an EXE file of the latest version of windows tool kit which i have donwlaoded from here.

    And as mentioned above, when i select "No" in the User Access Control pop up only the tool is getting installed but not "App verifier". 

    Sowjanya Ashok
    Thursday, November 5, 2009 9:55 AM
  • Hi Sowjanya,

    Indeed it is an EXE, as I stated. It a self extracting EXE that you also can extract using  your favorite compression tool.


    Thursday, November 5, 2009 7:51 PM
  • Hi! I have the same problem.

    But before the error pops up, another window shows. It show the command informations für Windows Installer 5.

    Extracting the exe file do not work. How can I extract an exe file??
    Monday, November 30, 2009 4:28 PM
  • Install a compression tool like 7-zip , right click on the self extracting exe, select [7-zip] -> Extract to:
    Extract the files to a convenient location.
    Monday, November 30, 2009 4:34 PM
  • I am seeing this issue as well. I extracted the two MSIs from the exe and tried installing them separately. The Windows Software Logo Kit install succeeded but the ApplicationVerifier installation failed. Is there a known working version of ApplicationVerifier for Windows 7 Ultimate x64 somewhere?
    Tuesday, February 2, 2010 3:16 PM
  • Same issue with Windows 7 (32-bit), tried installing on Ultimate and getting very same error. Is there a solution to this problem yet?
    Thursday, August 12, 2010 4:19 PM
  • I had the same issue, "There was an error installing Application verifier. Exiting...". Not very informative. I tried from an elevated command prompt as well, but still the same. Finally I extracted the .exe file manually using WinRAR (WinZIP would probably have worked as well). That gives three files: ApplicationVerifier.msi, Windows Software Logo Kit.msi and wslkSetup.exe

    Now when trying to install ApplicationVerifier.msi separately, it tells me what the real error is: A newer version of AppVerifier is already installed :-o Turns out I already have 4.0 on my machine (it’s in System32 and in SystemWOW64. Installed with VS2010?) and the toolkit tries to install an older version (probably 3.3, but there seems to be no way to read that from the properties of the MSI).

    Does the toolkit support AppVerifer 4.0 or do I need to uninstall 4.0 to and re-install the toolkit with the older version of AppVerifier?

    Ps. Quite frankly, I didn’t know if should laugh or cry when noticing that the tool that verifies if my home made application can install and behave properly (among other things) on Windows 7 was unable to install itself :-o


    Thursday, October 7, 2010 6:49 AM
  • Thanks Daniel, I had the same problem and solved it by following your instructions.

    First, extract the msi files from "Windows7SoftwareLogoToolkitSetup-x64.exe", I did with the free program 7-Zip 9.20, and I created a folder with the following,

    - ApplicationVerifier.msi
    - Windows Software Logo Kit.msi
    - wslkSetup.exe

      and then executed by order "ApplicationVerifier.msi"and then "Windows Software Logo Kit.msi"
    and it worked without any problem

    Sorry for my English which is a bit poor.


    Best regards

    Ignacio Martín

    Ignacio Martín Microsoft MVP for Project TEL: 34 913149977 MOV: 34 609156333
    • Proposed as answer by DaveMatn Wednesday, August 31, 2011 4:51 PM
    • Unproposed as answer by DaveMatn Wednesday, August 31, 2011 4:51 PM
    Monday, December 20, 2010 12:04 AM
  • Did the Windows 7 Software Logo Toolkip pass its own testing?

    Wednesday, August 31, 2011 4:51 PM
  • same problem here, extracted with win zip found 2 separate files. Tried to run App verifier and it says this ver can't be run on x64 architecture (although Im using 32bit Win 7 on x64). Please download the x64 ver which runs on both. Now i downloaded x64 ver and it is working fine. I think the initial error should have been more descriptive. And I agree with 
    DaveMatn what he said :)
    Tuesday, September 13, 2011 2:05 PM
  • I had similar issues and the error message did not help. I am not sure how and when I had installed the "Application Verifier". But I had to uninstall the Application verifier before executing Windows7SoftwareLogoToolkitSetup-x64.exe.
    Tuesday, October 11, 2011 3:24 PM