locked
my icons are messed up RRS feed

  • Question

  • when i was opening a program i was given the option to choose a default program in which to always open this program with and i chose notepad . now whenever i click on any icon to open a program notepad always opens instead of the program i intended to open . how can i return my icons to their former state the way their supposed to be please ? thanks .                            i have tried all given suggestions to resolve this issue and so far nothing has worked . i have tried a lot of different things on my own and still nothing . system restore gives a error message . so i can't use restore either . this issue is very annoying .  maybe i should just reformat my computer . as much as i hate to have to do that . thank you all for your help .
    • Edited by luke_777 Tuesday, December 29, 2009 5:45 PM
    Sunday, December 27, 2009 3:18 AM

Answers

  • You may try to find the file association in the following Registry branch.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    Find the branch for the correspond file extension, and then delete the “UserChoice” branch. Then reboot and check the result. 


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, January 25, 2010 7:11 AM
    Wednesday, December 30, 2009 7:00 AM

All replies

  • Its not your icons you messed up, its your program association you've dorked up. Windows didn't know what the association was is why it asked you to choose. Now if you changed the extension assocation then it would probably be easier to just do a repair since we don't know what exactly you've done. Have you performed a backup from before the mess up? If so, just restore it to the way it was.
    MCSE, MCSA, MCDST [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Sunday, December 27, 2009 3:35 AM
  • You may try to find the file association in the following Registry branch.

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\

    Find the branch for the correspond file extension, and then delete the “UserChoice” branch. Then reboot and check the result. 


    Arthur Xie - MSFT
    • Marked as answer by Arthur Xie Monday, January 25, 2010 7:11 AM
    Wednesday, December 30, 2009 7:00 AM