locked
Windows 7 Right to Left Date on Notepad RRS feed

  • General discussion

  • Hi,

    In Arabic environments we type the date in the (year-month-day) format, this was OK with XP

    the following image from notepad on XP

    But on windows 7 (Enrprise), the date is not shown correctly, although we are typing in the same format order

    and happenes also with Office products in Win7.

    We need an solution to fix this bug in right to left applications

    Thursday, July 12, 2012 10:41 AM

All replies

  • Hi,

    We may check the settings in Region and Language.

    1. Click Start, Control Panel, and Region and Language.

    2. Change the format to Arabic.

    3. Click “Additional settings…”

    4. Choose or type in the date format which you wanted.


    Kim Zhou

    TechNet Community Support

    Friday, July 13, 2012 8:29 AM
  • Thank you Kim

    This issue is not related to date type, it is related to written numbers in the begining of a text line.

    numbers included special charecters (- . ,) cause the problem on Windows 7

    example

    124.22.43888

    will revised to

    43888.22.124

    i think it is related to right to left language property on Windows 7. it is not supported as Windows XP

    Friday, July 13, 2012 11:05 AM
  • Hi,


    Based the current situation, you may post your problem on the local support team or forum. Caused I have limited knowledge about Arabic.


    Thank you for your understanding.


    Kim Zhou

    TechNet Community Support

    Friday, July 20, 2012 3:28 AM