locked
Upgrade from Exchange 2010 to 2016 Failure Forcing Disaster Recovery RRS feed

  • Question

  • I have an organization with an existing Exchange 2010 server. I created a New Hyper-V Vm with Server 2016. I installed the Exchange Prerequisites and ran Exchange 2016 CU5 Setup. During a reboot of the machine required by the installation, the machine would not start and windows could not recover it. I decided to start over by reformatting the machine with a fresh copy of Windows Server 2016 and restart the process. At this point when I ran Exchange 2016 CU5 setup, I received the error "The Exchange Server is in an inconsistent state. Only disaster recovery mode is available. Please use Setup /m:RecoverServer to recover this Exchange server." Even though it was a fresh install on the machine. I'm assuming something in Active Directory was telling Setup that the machine already existed as an Exchange Server. I ran setup in Disaster Recovery mode, and it got as far as installing the Hub Transport role and failed with the error: "[ERROR] Couldn't find the parent object for  on domain controller DC.domain.local. Check that HTTP exists and that the domain controller belongs to domain domain.local.
    [ERROR] The Active Directory object for virtual directory 'IIS://EXCHANGE2016.domain.local/W3SVC/1/ROOT/PowerShell' on 'EXCHANGE 2016' could not be created. This might be because the object already exists in Active Directory. Remove the object from Active Directory, then re-create it." I then in-joined the EXCHANGE 2016 server from AD and deleted the object for it from AD Users and Computers. I re-joined the Exchange 2016 server to AD and let it create a new computer object in AD. I then tried to re-run setup. I still was prompted to use disaster recovery mode. This time setup fails at the prerequisite analysis and gives me this error: "A Setup failure previously occurred while installing the HubTransportRole role. Either run Setup again for just this role, or remove the role using Control Panel." If I try uninstalling from control panel I'm told I need to run setup using the original installation media.  If I try running setup.exe /mode:Uninstall /IAcceptExchangeServerLicenseTerms I am given the following error: "Setup previously failed while performing the action "DisasterRecovery".  You can't resume setup by performing the action "Uninstall"." Any suggestions on how to proceed would be appreciated.
    Friday, April 7, 2017 1:35 PM