locked
Win7 automatic update taking a long time RRS feed

  • Question

  • Windows 7 automatic update taking a long time. I shut down my computer and an automatic update started. This has often worked before. Started 20 Apr 2011 at 2 pm showing message: “Please do not power off or unplug machine, installing update 1 of 23”. Double dots after the “23” are moving and a circular shape is spinning. No apparent progress at 10 pm after 8 hours. What do I do?

    A similar problem occurred once before on 14/10/2010.  That time I left the computer running for 24 hours and it seems the update finally completed.

    Win7 home premium, 64 bit, Automatic update on, ESET antivirus

    Wednesday, April 20, 2011 1:41 PM

Answers

  • HI

    You can do Windows 7 updates manually . Even if you have automatic updates turned on !!!

    which will reduce the time ! and u can select what ever updated you need like drivers or additional Windows components and security updates!! which ever you dont want to get updated just uncheck it!!

    for more details click on this link and and click play button.

    http://www.top-windows-tutorials.com/windows-7-updates-manual.html

     

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Juke Chou Tuesday, April 26, 2011 5:01 AM
    Wednesday, April 20, 2011 9:16 PM