locked
Skype on premises and Skype directory search failing RRS feed

  • Question

  • We have SfB and SfB edge.  Everything working.

    We went to the Microsoft provisioning page for Skype federation and got the confirmation back.

    It shows our Access Edge Server FQDN as sip.ourdomain.co.nz (changed from the real one for privacy purposes). 

    On our SfB front end server we deleted the CsPublicProvider and created a new one.  It now shows 

    In out topology under edge pool we see

    Everything seems to be OK, but when we do a Skype search in the SfB client, we get An error has occurred.

    In the SfB front end server we see an error logged each time in the Lync Server log, error 62044

    Skype search request failed.

    Exception information : Fault occurred while attempting to proxy WCF message.
    Exception type: CommunicationException
    Additional Data:
    Source: Microsoft.Rtc.Server.WebInfrastructure

    ...

    Cause: A configuration or network connectivity issue might be causing failure to access the Skype search service.
    Resolution:
    Check the Skype search proxy and network configuration.

    When we run test-CfFederationPartner we get this (changed for privacy, real domain gives exact same response)

    What does 'No matching cluster found in topology' mean?

    Our firewall does not show any deny packets from either the edge or front end server, and we believe our firewall is not the issue.

    Any ideas?  What else can I check?

    Thanks, Neal 

    Sunday, November 5, 2017 10:25 PM

All replies

  • Hi HotAir3.1,

    Based on my research, you could try the following

    Disable Skype federation on edge server in topology, publish. Run Setup on edge server.

    Re-enable Skype federation on edge server in topology, publish. Run Setup on edge server.

    For details, please refer to
    https://ucsorted.com/2017/07/31/skype-federation-search-stops-working-event-id-62044/

    Note: Microsoft is providing this information as a convenience to you. The sites are not controlled by Microsoft. Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. Please make sure that you completely understand the risk before retrieving any suggestions from the above link.


    Regards,

    Alice Wang


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, November 6, 2017 7:55 AM
  • Thanks for the reply.  I tried it, didn't help.  There has to be a clue in the test-CfFederationPartner.  Any idea what that result I got means?

    I have someone coming in to check the reverse proxy configuration tomorrow.  It seems to be set correctly, but we will ask the expert to check anyway.

    Thanks, Neal 

    Tuesday, November 7, 2017 3:27 AM
  • Deleted
    • Proposed as answer by Alice-Wang Wednesday, November 8, 2017 8:48 AM
    Tuesday, November 7, 2017 1:41 PM
  • Thanks Shankar That is such a simple test!  Why is that not in all the TechNet articles?

    We ran the test, and it worked, but still no skype directory search.  I left the problem for a couple of hours to do something else, and it started working!  No idea why, no one changed the firewall or anything, but we can now search the skype public directory.  

    Crazy, I don't know why but we can search.  However, can't talk to anyone so working on that now.

    And I also figured out what was wrong with the Test-CsFederatedPartner.  I don't know why they called it the targetFQDN, it should be called the Skype Edge pool internal FQDN.  

    So I changed it to test-CsFederatedPartner -targetFqdn skypeedge.ourdomain.local -domain msn.com -verbose and the test works.

    But I get an error, so I'll try and figure out why now. ...

    PS C:\Users\chch administrator> test-CsFederatedPartner -targetFqdn skypeedge.ourdomain.local -domain msn.com -verbose
    VERBOSE: Reading access proxy port from topology process started.
    VERBOSE: Reading access proxy port '5061' from topology process successfully finished.
    VERBOSE: Reading certificate process started.
    VERBOSE: Reading certificate process successfully finished.
    VERBOSE: Searching for certificate with issuer name = 'CN=ourdomian-CERTSRV-CA, DC=ourdomain, DC=local' and serial number =
    '1a4ea48d000000000064'.
    VERBOSE: Successfully found certificate with the matching issuer name and serial number.
    VERBOSE: Workflow Instance Id '0f00cfb4-ecfa-44f2-94b2-a9b704e0aef0', started.
    VERBOSE: Command line executed is 'test-CsFederatedPartner -targetFqdn skypeedge.ourdomain.local -domain msn.com -verbose'.

    Target Fqdn   :
    Result        : Failure
    Latency       : 00:00:00
    Error Message : 504, Server time-out

    Diagnosis     : ErrorCode=1046,Source=sip.ourdomain.co.nz,Reason=Failed to connect to a federated peer
                    server,winsock-code=10051,peer-type=FederatedPartner,ip-address=52.113.8.31,winsock-info=The peer network is unreachable
                    Microsoft.Rtc.Signaling.DiagnosticHeader

    VERBOSE:
    VERBOSE: Workflow Instance ID '0f00cfb4-ecfa-44f2-94b2-a9b704e0aef0' completed.
    VERBOSE: Workflow run-time (sec): 5.9530232.

    Thanks, Neal 

    Wednesday, November 8, 2017 8:05 PM
  • Have you tried the suggestions above?
    Tuesday, November 14, 2017 5:51 AM