locked
Office2013 IRM Could not Connect to Digital RMS server and get templates! RRS feed

  • Question

  • Hi all!
    Happy Christmas Eve!

    I have the Office 365 E3 plan.

    OS:Win7

    Office:2013 pro plus   version:15.0.4569.1506

    I want set the local Office file with IRM. So I login in with my E3 account in local Office 2013 Excel file.

    *I have opened the office 365 RMS service.

    But When I protecting a new document or Excel with IRM via the "Protect Workbook" button in the File > Info tab>Protect Workbook>Restrict Access>Connect to Digital Rights Management Servers and get templates.

    I see the following error:

    Error:

    ----------------------

    Your machine isn't set up for Information Rights Management (IRM). To set up IRM, sign in to Office, open an existing IRM protected message or document, or contact your help desk.

    ----------------------

    I found the following two questions:

    ==============

    1. I  uninstall the Office2013 install the Office2016. The error didn't display.

    2. My home computer and the computers of the company have the same OS version and the version of Office.but this issue happened in my company  PC. My home computer didn't happen this problem.

    *My company PC use the proxy to connect to internet.

    ==============

    And then I searched the TechNet and Google to find the answer. I  found the following answer.

    http://social.technet.microsoft.com/wiki/contents/articles/30219.troubleshooting-irm-with-modern-authentication-in-office-2013.aspx

    I am very happy to think that I found the answer. But I tried the link above all the way this problem also did not solved.

    So I want to know :

    *******************

    1. what’s the difference between Office2013 and Office 2016 in IRM setting.

    2. My home's PC is as the same as My Office's PC  and Office version why I can connect the RMS server with my home PC.This is because the two parts of the network is different?. I can not belive it.

    3. How can I solve this problem with Office 2013 pro plus.

    Thanks!

    Tobey.







    Saturday, December 24, 2016 9:25 AM

All replies

  • Hi Tobey,

    As this issue is more related to Office Word Client, I would move this thread to Office client forum, you will get more detailed information from there and more experts will help you about this question.

    Thanks for your understanding and cooperation.

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, December 26, 2016 6:01 AM
  • Hi Jerry

    Thank you for helping me move the thread to here.
    I'm  waitting  someone to help me.

    Thanks.
    Tobey

    Tuesday, December 27, 2016 1:03 AM
  • Hi,

    Generally, Office 2016 and Office 2013 share the same IRM settings. If it works for Office 2016, it means the IRM settings are correct.

    Do you sign in to Office 2013 correctly using the Office 365 credentials? When testing in Office 2016, did you sign in to Office 2016 using the same Office 365 account that you used to sign in Office 2013? If Office 2013 is not correctly signed in with an Office 365 credential, this error will display. Besides, we may also try to sign out of the Office 365 account and then sign back again to see if this issue continues.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by Steve Fan Tuesday, December 27, 2016 8:30 AM
    Tuesday, December 27, 2016 8:29 AM
  • Hi Steve Fan

    Thank you for your response very much.

    I also use my virtual machine (made by hyper-v) to test the error.

    When I found this error then I  reset the OS return to the initial state of the OS and Office to ensure that no Office 365 account has already signed in. Then I logged in Office 2013 with my Office 365 E5 account at the first time . But I still can't connect to the Azure RMS server.

    Another user can use the IRM which pc is installed Office 2016. The Office 2013 user cannot connect.

    I have reset OS and reinstall  Office 2013 but the error is still occur.

    Which confuse me most is that  I can use the irm in my home's pc that  is the same version of the OS and Office with my company's PC.

    Now I don't care about the reason I just want to solve the problem how can I  use the irm with Office2013 in my Company.

    Thanks!

    Tobey.

    Tuesday, December 27, 2016 9:12 AM
  • Thank you Tobey for the update.

    Have you contacted your admin and confirmed whether this feature has been blocked for Office 2016 in your environment?

    In addition, since this issue could be related to the Azure RMS server, I'd recommend you also post a question in the Azure forum to see if anyone over there encountered the same issue before:

    https://social.technet.microsoft.com/forums/azure/en-US/home

    Thank you for your understanding.

    Regards,

    Steve Fan


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Steve Fan Friday, December 30, 2016 9:27 AM
    Wednesday, December 28, 2016 8:56 AM