none
DPM 2010 - not compatible w/server 2008 R2 x64? SQL Woes RRS feed

  • General discussion

  • Hi,

    I'm trying to install DPM 2010 onto a Server 2008 R2 x64 system.  If I try to have it set up its own SQL instance it fails with a error ID 4310 Unspecified error when it tries to install SQL Server 2008 SP1.  The error log is below.

    I tried installing SQL 2008 R2 and using that, but DPM gets stuck stating that I need SP1.  I then tried SQL 2008 but I get messages that it is incompatible with Server 2008 R2.

    So is the latest DPM incompatible with the latest server OS?

    SQL Error log:

    Overall summary:
      Final result:                  User cancelled
      Exit code (Decimal):           -2068380094
      Exit facility code:            1207
      Exit error code:               1602
      Exit message:                  User has cancelled.
      Start time:                    2010-10-20 10:48:10
      End time:                      2010-10-20 10:48:40
      Requested action:              RunRules

    Machine Properties:
      Machine name:                  APPSRV1
      Machine processor count:       4
      OS version:                    Windows Server 2008
      OS service pack:               
      OS region:                     United States
      OS language:                   English (United States)
      OS architecture:               x64
      Process architecture:          64 Bit
      OS clustered:                  No

    Product features discovered:
      Product              Instance             Instance ID                    Feature                                  Language             Edition              Version         Clustered

    Package properties:
      Description:                   SQL Server Database Services 2008
      SQLProductFamilyCode:          {628F8F38-600E-493D-9946-F4178F20A8A9}
      ProductName:                   SQL2008
      Type:                          RTM
      Version:                       10
      SPLevel:                       0
      Installation location:         F:\x64\setup\
      Installation edition:          EVAL

    User Input Settings:
      ACTION:                        RunRules
      CONFIGURATIONFILE:             
      FEATURES:                      
      HELP:                          False
      INDICATEPROGRESS:              False
      INSTANCENAME:                  <empty>
      MEDIASOURCE:                   F:\
      QUIET:                         False
      QUIETSIMPLE:                   False
      RULES:                         GLOBALRULES,SqlUnsupportedProductBlocker,PerfMonCounterNotCorruptedCheck,Bids2005InstalledCheck,BlockInstallSxS,AclPermissionsFacet,FacetDomainControllerCheck,SSMS_IsInternetConnected,FacetWOW64PlatformCheck,FacetPowerShellCheck
      X86:                           False

      Configuration file:            C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20101020_104808\ConfigurationFile.ini

    Detailed results:

    Rules with failures:

    Global rules:

    There are no scenario-specific rules.

    Rules report file:               C:\Program Files\Microsoft SQL Server\100\Setup Bootstrap\Log\20101020_104808\SystemConfigurationCheck_Report.htm

    Exception summary:
    The following is an exception stack listing the exceptions in outermost to innermost order
    Inner exceptions are being indented

    Exception type: Microsoft.SqlServer.Chainer.Infrastructure.CancelException
        Message:
            User has cancelled.
        Stack:
            at Microsoft.SqlServer.Configuration.UIExtension.Request.Wait()
            at Microsoft.SqlServer.Configuration.UIExtension.UserInterfaceProxy.NavigateToWaypoint(String moniker)
            at Microsoft.SqlServer.Configuration.UIExtension.WaypointAction.ExecuteAction(String actionId)
            at Microsoft.SqlServer.Chainer.Infrastructure.Action.Execute(String actionId, TextWriter errorStream)
            at Microsoft.SqlServer.Setup.Chainer.Workflow.ActionInvocation.InvokeAction(WorkflowObject metabase, TextWriter statusStream)
            at Microsoft.SqlServer.Setup.Chainer.Workflow.PendingActions.InvokeActions(WorkflowObject metaDb, TextWriter loggingStream)
    Wednesday, October 20, 2010 6:06 PM

All replies

  • Hello,

    There should not be any problems installing DPM 2010 on a Windows 2008 R2 x64 system.  Is this a clean install of the operating system, if not you may want to start fresh.

    DPM 2010 does not support SQL Server 2008 R2 for DPM database.  See the following article: http://technet.microsoft.com/en-us/library/ff399021.aspx  - look under the community content section.

     


    Regards, Mike J. [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Wednesday, October 20, 2010 9:06 PM
    Moderator
  • This is a clean install of 2008 R2 x64 with all current updates.  There's another thread on this in the setup forum.  I'll pursue a answer there.
    Wednesday, October 20, 2010 9:14 PM
  • hi 

    i got the same problem. but i did manged it by install the SQL server 2008 R2 in the same local PC where the DPM 2010 is going to install and use that SQL server instants in the setup . it worked for me.

     

    Regards.

    Tuesday, March 15, 2011 6:20 AM
  • G'day All,

    I seem to have a variation on this theme.

    on Windows Server 2008 R2 Datacenter running DPM 2010 for 3 weeks. Something, possibly Windows Update, upgraded SQL from the default version installed initially to SQL 2008 R2. Reporting stopped working. I was no longer able to determine which tapes may be recycled.

    The databse now says it is version 662.

    Any suggestions? Should I declare 20TB of disk backup lost, rebuild the entire system from scratch & scan all my tapes for content?

    Thursday, April 7, 2011 2:19 AM
  • Windows Update should *not* have done this SQL upgrade.  I would consider contacting Microsoft support on this one.  If you have a proper DPM backup, I would look at a restore at this point.
    Friday, April 8, 2011 1:36 AM