netdom renamecomputer breaks RDP?


  • Hi there,

    I renamed a Windows Server 2012 R2 Standard computer from NAME1 to NAME2 using netdom, and then I rebooted the computer:

    netdom renamecomputer NAME1 /NewName:NAME2

    In DNS, I had an A record for NAME1. To support the rename operation, I reconfigured DNS as follows:

    • create A record for NAME2
    • delete A record for NAME1
    • create CNAME for NAME1 pointing to NAME2

    Now when I try and RDP to NAME1 from a Windows 8 Enterprise x64 computer, I get the following error dialog from Remote Desktop Connection:

    An authentication error has occurred.
    The specified target is unknown or unreachable
    Remote computer: NAME1

    When I RDP to NAME2, it connects with no problems.

    I thought the CNAME might be to blame so I decided to test things with a different computer, TEST1. I created a CNAME for TEST2 pointing to TEST1, then tried RDP to the TEST1 CNAME, which worked. TEST1 has the same OS version as NAME1.

    So I think the netdom renamecomputer operation broke things, not the CNAME.

    How can I make it so that I can RDP to NAME1 again?

    • Edited by 0xCBW Thursday, January 02, 2014 12:22 AM Typo
    Thursday, January 02, 2014 12:18 AM


All replies

  • Hi,

    Is it possible that Network level authentication(NLA) is still on? on the machine with the RDP Problem?

    Thursday, January 02, 2014 12:29 AM
  • Okay, so I tried a different client computer and I can connect to NAME1 with no problems.

    I now just need to figure out how to fix the original client computer...

    Thursday, January 02, 2014 12:35 AM
  • With kind of OS  and SP are you running on the client? 
    Thursday, January 02, 2014 12:44 AM
  • Maybe not the error, but check if LANMAN is configured to use the alternative's name.



    Value name: DisableStrictNameChecking = 1 (DWORD - DECIMAL)

    nb. The strictnamechecking value is there to refuse a access to it by a different netbios's name.

    Regards, Philippe

    Thursday, January 02, 2014 12:48 AM
  • I don't want to turn off NLA...
    Thursday, January 02, 2014 2:20 AM
  • Rebooting fixed it. Thanks everyone.
    • Marked as answer by 0xCBW Thursday, January 02, 2014 2:20 AM
    Thursday, January 02, 2014 2:20 AM
  • Windows 8 Enterprise x64 RTM.
    Thursday, January 02, 2014 2:21 AM
  • @Philippe: FWIW, none of those were present/set on either the client or the server.
    • Edited by 0xCBW Thursday, January 02, 2014 2:24 AM Typo
    Thursday, January 02, 2014 2:24 AM