none
PC Restarts After Hibernating RRS feed

  • Question

  • I followed the instructions given in the Seven Forums thread, disabled the "hybrid sleep" option, and configured the power button to hibernate the PC. When I press the button, the PC hibernates, and then restarts, so I have to press the power button a second time to turn it off. When I turn on the PC, it resumes as expected.

    Is there a way to stop the PC from restarting after hibernating? I tried setting the power option in the BIOS from S3 or "auto" toi S1 but that didn't work.
    Saturday, May 16, 2009 11:35 AM

Answers

  • The problem with rebooting right after hibernate has to do with the devices allowed to wake the computer.  Go to device manager and pull up properties on the mouse, keyboard, and network cards.  In each go to the Power Management tab and uncheck the "Allow to wake computer" box.  If you do want to wake on lan check the "magic packet only" option.

    I'm doing these from memory, so the wording may be different. 
    • Proposed as answer by Alcartur Thursday, October 15, 2009 3:37 AM
    • Marked as answer by Ralfyman Saturday, August 21, 2010 3:52 PM
    Monday, July 13, 2009 1:31 PM
  • Try changing back to the power button shuts down the PC, reboot, and then change it back again. Any change?
    Friday, May 22, 2009 9:32 PM

All replies

  • Try changing back to the power button shuts down the PC, reboot, and then change it back again. Any change?
    Friday, May 22, 2009 9:32 PM
  • The problem with rebooting right after hibernate has to do with the devices allowed to wake the computer.  Go to device manager and pull up properties on the mouse, keyboard, and network cards.  In each go to the Power Management tab and uncheck the "Allow to wake computer" box.  If you do want to wake on lan check the "magic packet only" option.

    I'm doing these from memory, so the wording may be different. 
    • Proposed as answer by Alcartur Thursday, October 15, 2009 3:37 AM
    • Marked as answer by Ralfyman Saturday, August 21, 2010 3:52 PM
    Monday, July 13, 2009 1:31 PM
  • The problem with rebooting right after hibernate has to do with the devices allowed to wake the computer.  Go to device manager and pull up properties on the mouse, keyboard, and network cards.  In each go to the Power Management tab and uncheck the "Allow to wake computer" box.  If you do want to wake on lan check the "magic packet only" option.

    I'm doing these from memory, so the wording may be different. 
    Perfect!!!

    It works pretty good on my pc, thanks dkman..
    Thursday, October 15, 2009 3:38 AM
  • Thank u very much, dkman123 and also Alcartur bcz u posted the same problem as my desktop computer right now. I lost all morning for searching from every VietNam forum, but nobody answer the right answer. That's fantastic this moment, very nice to meet all of u. Have a lucky day,okay!
    Sunday, December 13, 2009 5:24 AM
  • I had the same problem of restart on hibernate with a brand new out of the box dell running windows 7... here's something that may help someone else, i hope so.   After checking all the devices as suggested above, and showing everything just the way it should be, when all else failed, i did this...shut down completely,  disconnected the a/c power supply from back of computer, removed the battery completely from unit.  I waited about an hour (went and took a nap, i was tired of trying to find helpful information for my problem with no luck), came back, replaced the battery and a/c power, fired it up.... haven't had a problem with the restart on hibernation since!!!  This solution has actually worked on another laptop i had for a somewhat different problem...so...don't knock it until you try it, it might be the simplest fix you ever find...  If this does the trick for anyone else, it makes me very happy...post a reply to this if it worked for you...
    Wednesday, December 7, 2011 6:26 PM
  • Searched for a solution to this exact problem of rebooting when selecting the hibernation option; your recommendation of turning off the wake option of certain devices (mouse, keyboard, network card) was dead on.  Thank you very much!!!
    Monday, April 23, 2012 1:40 AM
  • Hey I cant find Power Management tab in properties, i have windows 7 idk if its any different. :\
    Tuesday, May 1, 2012 10:52 PM
  • http://www.askvg.com/fix-windows-8-restart-and-shutdown-problems-by-disabling-hybrid-shutdown-feature/

    Monday, October 21, 2013 10:40 PM
  • Thanks for sharing :) that was an easy fix cf loosing the ability to hibernate on 7 - w/o a reliable explanation working in certain situations.....

    .....I tried all the endless solutions - nothing. It turns out my loss of hibernation is to do with  something HIGHLY ESOTERIC - NOTHING I'd heard about before being linked to hibernation - the default install of the "system partition" which expects to be on the FIRST in the bios sequence EVEN if you don't have the "system partition" the bcd files still expect to be there - essentially if they're not you loose hibernation (you can tell they'll activate hibernation  if you try opening them even under administrative privileges, a msg says "they are being used by another process")





    • Edited by Al79 Wednesday, February 11, 2015 9:37 PM
    Wednesday, February 11, 2015 9:33 PM