none
FAST Search cannot crawl subsite RRS feed

  • Question

  • I have a SharePoint 2010 server RTM and FAST Search Server for SharePoint  deployed on two different servers . I'm getting:

    The Execute method of job definition Microsoft.Office.Server.Search.Administration.FSDictionaryManagementJobDefinition (ID 3849833f-de66-4c97-8858-fea174b507fa) threw an exception. More information is included below.

    Failed to communicate with the WCF service.

    All the FAST services appear to be running - in services console and using nctrl status. Crawls appear to work ok and the FAST search query service is 'online for crawling' with 456 searchable items,but FAST cannot crawl ppt, doc file and subsite.

    I've switched off the windows firewall. The required folders under FASTSearch\data exist. I've tried the usual IIS reset and server restarts. Can anyone suggest any other tests specific to the WCF service or anything else I could try?

    Question 1: Failed to communicate with the WCF service

    Question 2:FAST cannot crawl ppt doc file and subsite

    Thanks

    Friday, July 16, 2010 4:15 AM

Answers

  • Hello Bob,

    Is this a new installtion of FAST. Considering the answer is yes please check the following

    On the admin node, in IIS is the FastSearchAdminAppPool running?

    Also please check and ensure you do not have any certificate or communication issue . Below link talks about FAST installation and configuration multi node

    http://blogs.msdn.com/b/spses/archive/2010/04/09/installation-and-configuration-of-fast-search-server-for-sharepoint-2010.aspx  Installation And Configuration Of FAST Search Server for SharePoint 2010

    What do you see when you run  Get-FASTSearchContentCollection -name sp

    The first step to troubleshoot missing documents is to verify that the service application is correctly setup. Go to the service application created for FAST Search for SharePoint and check default content access account. If the user specified is missing required privileges to crawl documents they appear as errors. It is possible to add rights to a user for crawling a specific SharePoint site with stsadm.

    stsadm.exe -o addpermissionpolicy -url http://sharepointsite -userlogin domain\user -permissionlevel "Full Read"


    Through Windows PowerShell, the content distributor properties can be checked:

    Add-PSSnapin Microsoft.SharePoint.PowerShell
    $searchApp = Get-SPEnterpriseSearchServiceApplication -Identity "Connector SSA"

    PS C:\fastsearch>$serviceApp.ExtendedConnectorProperties["ContentDistributor"] hostname:13329 This can be used to verify that the Connector SSA is correctly configured.

    If this has been working for some time or if the  above action does not resolve the issue please enable debug log and document trace to verify document processing and post the errors you see

    Psctrl doctrace on


    Psctrl debug on

    ===========================================
    Regards,

    Manas-MSFT

    • Marked as answer by Lily Wu Monday, July 26, 2010 1:41 AM
    Tuesday, July 20, 2010 4:55 PM

All replies

  • Hello Bob,

    Is this a new installtion of FAST. Considering the answer is yes please check the following

    On the admin node, in IIS is the FastSearchAdminAppPool running?

    Also please check and ensure you do not have any certificate or communication issue . Below link talks about FAST installation and configuration multi node

    http://blogs.msdn.com/b/spses/archive/2010/04/09/installation-and-configuration-of-fast-search-server-for-sharepoint-2010.aspx  Installation And Configuration Of FAST Search Server for SharePoint 2010

    What do you see when you run  Get-FASTSearchContentCollection -name sp

    The first step to troubleshoot missing documents is to verify that the service application is correctly setup. Go to the service application created for FAST Search for SharePoint and check default content access account. If the user specified is missing required privileges to crawl documents they appear as errors. It is possible to add rights to a user for crawling a specific SharePoint site with stsadm.

    stsadm.exe -o addpermissionpolicy -url http://sharepointsite -userlogin domain\user -permissionlevel "Full Read"


    Through Windows PowerShell, the content distributor properties can be checked:

    Add-PSSnapin Microsoft.SharePoint.PowerShell
    $searchApp = Get-SPEnterpriseSearchServiceApplication -Identity "Connector SSA"

    PS C:\fastsearch>$serviceApp.ExtendedConnectorProperties["ContentDistributor"] hostname:13329 This can be used to verify that the Connector SSA is correctly configured.

    If this has been working for some time or if the  above action does not resolve the issue please enable debug log and document trace to verify document processing and post the errors you see

    Psctrl doctrace on


    Psctrl debug on

    ===========================================
    Regards,

    Manas-MSFT

    • Marked as answer by Lily Wu Monday, July 26, 2010 1:41 AM
    Tuesday, July 20, 2010 4:55 PM
  • Hello Bob,

    Once you follow the steps above and if the issue is still not resolved you may also wnat to have a look at the article http://support.microsoft.com/?id=981297 Error message when you use PowerShell cmdlets to try to access managed properties in FAST Search Server 2010 for SharePoint: "Failed to communicate with the WCF service"

    =================================================

    Regards,

    Manas-MSFT

    Wednesday, July 21, 2010 4:44 PM