none
Disk Based Cache section missing from Site Collection Object Cache

    Question

  • We are experiencing a problem with our blob cache in SharePoint 2013 Enterprise.  Images, especially, are not being flushed from the disk so if an image is updated, then the old image is still being served up.

    We use image renditions for our People Directory which is where we noticed the problem.

    After doing some research we found that the Disk Base Cache section is missing from the Site Collection Object Cache page in Site Settings.

    Is there a feature which would enable this section or a setting in the webconfig which we are missing?

    Setting from webconfig:

    <BlobCache location="C:\BlobCache\14" path="\.(gif|jpg|jpeg|jpe|jfif|bmp|dib|tif|tiff|themedbmp|themedcss|themedgif|themedjpg|themedpng|ico|png|wdp|hdp|css|js|asf|avi|flv|m4v|mov|mp3|mp4|mpeg|mpg|rm|rmvb|wma|wmv|ogg|ogv|oga|webm|xap)$" maxSize="10" enabled="true" />

    Thanks


    • Edited by simon1976 Wednesday, March 8, 2017 11:43 AM
    Wednesday, March 8, 2017 9:24 AM

All replies

  • Hi simon,

    To resolve your issue, I suggest you using PowerShell command to flush the BLOB cache  as below:

    $webApp = Get-SPWebApplication "http://sitename.domain"
    [Microsoft.SharePoint.Publishing.PublishingCache]::FlushBlobCache($webApp)
    

    Reference:

    https://technet.microsoft.com/en-us/library/gg277249(v=office.15).aspx

    Best regards,

    Grace Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, March 9, 2017 6:53 AM
  • I have already found and tried this, the issue is two fold, firstly the files are NOT being flushed from the disk, secondly, the documentation states that the disk can be cleared using the Disk Base Cache section from the Site Collection Object Cache page in Site Settings, however this section is missing.

    Why would this be missing?

    Thursday, March 9, 2017 3:30 PM