locked
Exchange 2010 SP3 Installation hangs Language Pack Hell RRS feed

  • Question

  • Ok, Exchange 2010 SP2 running in Hyper V on a 2012 server, and using the Server 2008 R2 as the OS, is hanging on the SP3 language pack for hours.  I tried rebooting the server because I am not a vampire and will continue to waste precious years of my life in this upgrade process as I age.  

    I am currently running the SP3 install again, and hope to advise, but any word on why this would hang?

    Again, guest OS is server 2008 R2 running in Hyper V on Server 2012 (how I roll), and has 8 GB of Ram and using Forefront for exchange.  

    Saturday, February 16, 2013 7:35 PM

Answers

  • Finished after six hours.  Long after my marathon time.  
    • Marked as answer by wosully Sunday, February 17, 2013 2:53 AM
    Sunday, February 17, 2013 2:53 AM

All replies

  • Please see the hell that has imprisoned me!
    Saturday, February 16, 2013 7:42 PM
  • On Sat, 16 Feb 2013 19:35:35 +0000, wosully wrote:
     
    >
    >
    >Ok, Exchange 2010 SP2 running in Hyper V on a 2012 server, and using the Server 2008 R2 as the OS, is hanging on the SP3 language pack for hours. I tried rebooting the server because I am not a vampire and will continue to waste precious years of my life in this upgrade process as I age.
    >
    >I am currently running the SP3 install again, and hope to advise, but any word on why this would hang?
    >
    >
    >
    >Again, guest OS is server 2008 R2 running in Hyper V on Server 2012 (how I roll), and has 8 GB of Ram and using Forefront for exchange.
     
    Try "run as administrator" to start the update.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Saturday, February 16, 2013 10:21 PM
  • I am logged in as the admin.  How is this possible?
    Sunday, February 17, 2013 12:44 AM
  • How would run as change this glacially slow process?  I understand that access denied if you do not have permission, not access at the pace of the drifting Pangea.  
    • Marked as answer by wosully Sunday, February 17, 2013 2:52 AM
    • Unmarked as answer by wosully Sunday, February 17, 2013 2:52 AM
    Sunday, February 17, 2013 1:10 AM
  • Finished after six hours.  Long after my marathon time.  
    • Marked as answer by wosully Sunday, February 17, 2013 2:53 AM
    Sunday, February 17, 2013 2:53 AM
  • On Sun, 17 Feb 2013 00:44:27 +0000, wosully wrote:
     
    >I am logged in as the admin.
     
    Being logged in as the admin isn't the same thing. Right-click, then
    "Run as administrator".
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    Sunday, February 17, 2013 3:23 AM
  • UAC is not enabled fo this account, but even if it was, I think install would work or fail, not work slowly.  Right?  
    Sunday, February 17, 2013 4:19 AM
  • Hello all. Having the same issue here as well. Does anybody know if this has been answered by MS? Thanks!

    Amit B. Agarwal

    Wednesday, February 20, 2013 4:55 PM
  • Mine worked.  Let it install for now.  Mine is up and working great, just hell for the install.
    Wednesday, February 20, 2013 4:59 PM
  • Ok thanks :)

    Amit B. Agarwal

    Wednesday, February 20, 2013 5:01 PM
  • I had the same problem. Hanging on 'Languages' after 30 minutes I decided to check the processes and I noticed the 'Anti Malware' process was taking quite a lot of processor time.

    I'm using Forefront protection on the servers and I disabled the 'Real-time protection' right away the upgrade continued without any problems.

    Thursday, February 21, 2013 12:13 PM
  • I was using Forefront and noticed the same thing.  There were a large amount of log files being written to disk, but the real-time was high.  Maybe we will figure this out. 
    Thursday, February 21, 2013 1:00 PM
  • If using Forefront Endpoint protection. Try disabling the real-time protection. It solved it for me.
    • Proposed as answer by DannyMuchmore Friday, September 27, 2013 9:28 PM
    Thursday, February 28, 2013 8:13 AM
  • Hi,

    I removed forefront completely, then updated. Disabling did not work for me. I know since SP2 rollup package 5 it should update without disabling  forefront but in my experience.... 

    Not a beautiful solution but this works for me.

    Panicz

    Thursday, February 28, 2013 5:45 PM
  • Same here. Running Forefront Client Security (probably applies to SC 2012 Endpoint Protection and MS Security Essentials). In Tools then Options, under "real-time protection options" disabled "use real-time protection" and scrolling down to the bottom under "administrative options" unchecked "use the program." There will be a pop-up window confirm it is turned off. EXE process to watch for is MsMpEng.exe (Antimalware Service Executable).

    If the processed is killed it will re-spawn so either uninstall or disable it correctly. Give it a few to several minutes and Languages should complete and move forward.

    • Proposed as answer by MC-FSP Friday, March 22, 2013 2:21 PM
    Friday, March 15, 2013 2:26 PM
  • This worked for me. Once Forefront protection "Real-time protection" was disable the installation moved on without a hitch!
    Tuesday, March 19, 2013 3:12 AM
  • Unfortunately SC 2012 Endpoint protection wouldn't let me disable real-time protection or stop/kill the service. I had to uninstall it completely, disable the SMS service (to prevent it from re-installing) and reboot. Then the Languages step finished in 5 mins instead of being stalled fro an hour, when I killed it. All those prereq checks and no mention of disabling AV.
    • Proposed as answer by KD07 Friday, July 26, 2013 6:07 AM
    Tuesday, April 9, 2013 3:21 AM
  • Have you tried disabling the the option "Check for Publisher’s Certificate Revocation" in Internet Explorer. When you are installing a SP or RU, a huge number of connections to Microsoft’s Certificate Revocation Server are being established in the background. Temporary disabling this option significantly reduces installation time/Exchange downtime.  You can get more info in this video:

    How to Reduce Downtime When Installing Rollup Updates in Exchange 2010


    Saturday, April 13, 2013 8:35 PM
  • Thanks for posting - I ran into this and your fix worked!

    Friday, July 26, 2013 6:07 AM
  • This helped us otherwise we would have been doomed too!
    Saturday, August 17, 2013 8:19 PM
  • Thank you and the others for this. Working back late to update our Enterprise and it was hanging on Languages.

    We are often told to disable AV - I will take more notice from now on.

    Tuesday, October 15, 2013 6:25 PM
  • Mine was hanging on a anti-spam service from GFI.

    After stopping the service the update continued.

    Tuesday, October 29, 2013 12:11 PM
  • I had the same problem. Hanging on 'Languages' after 30 minutes I decided to check the processes and I noticed the 'Anti Malware' process was taking quite a lot of processor time.

    I'm using Forefront protection on the servers and I disabled the 'Real-time protection' right away the upgrade continued without any problems.

    I am glad I ran into this post. Mine was stuck at [Languages] too. I am using Microsoft Security Essentials. I disabled Real-time protection and it resumed almost instantly. Did not have to kill anything. Thank you.
    Thursday, October 31, 2013 5:35 AM
  • This worked for me, thanks
    Friday, November 8, 2013 5:48 PM
  • You are awesome, you just saved me half a year in dog years.

    Here's what I did:

    1.Disabled Forefront real time protection - didn't seem to help

    2. Disabled the Internet Options -> Advanced -> (security section) Check for publisher's certificate revocation, and this allowed the install to IMMEDIATELY move on from Languages to Hub Transport role.

    So, one or both of these did the trick.


    Wednesday, November 20, 2013 5:18 AM
  • Same for me, temporary disabled the services and voila

    cheerz

    Wednesday, December 4, 2013 8:00 PM
  • Symantec Endpoint protection. As soon as I shut it down, it took 10 seconds to move past "Language".  Good find. +1
    Thursday, February 20, 2014 6:45 PM
  • Thanks to Microsoft for making all our lives are stress fully miserable...  Why don't they just put up an informational / warning dialog box to TELL Sys Admins to temporarily disable all anti-virus software before proceeding ????

    anthony maw/vancouver/canada

    Wednesday, April 16, 2014 5:05 PM
  • Wow that was easy after staring at nothing for an hour.  Thanks!!
    Monday, May 12, 2014 9:33 PM
  • Same issue with Microsoft Exchange Server 2013 CU 9, 

    Antimalware Service Executable was high process and need to be disabled to pass the Language Update in Step 8. 

    Thanks for the tip guys!

    Friday, September 18, 2015 3:17 AM
  • Hi Wosully,

      Found that culprit was endpoint protection. I just disabled the services of Endpoint protection and after then languages got installed.

    • Proposed as answer by AerrowMVP Wednesday, October 7, 2015 10:33 AM
    Wednesday, October 7, 2015 10:33 AM
  • As they say, an oldie, but a goodie! This week had to reinstall Exchange 2010 SP3 on an SBS 2011 server. As per the posts here, very long install time (I think the longest I can every remember), particularly the dreaded "Languages" section, which in my case was at over 3 hours, and no green on the status bar. This extreme processing time prompted me to search and subsequently found this post.

    Like others, I also tried disabling realtime AV and shutting down other memory or disk intensive activities to give the Exchange 2010 SP3 installer more resources, however Mikelaughs / NetoMeter Screencasts "Check for Publisher's Certificate Revocation" post resolved the issue.

    The steps are: In IE or Control Panel, open Internet Options, click the Advanced tab, scroll down to the Security section and untick "Check for publisher's certificate revocation". Then Click Ok to apply.

    As soon as I did this in IE on the server, the Languages section of the SP3 upgrade completed INSTANTLY!

    I rarely post, but in this case, to save some other person time and stress, this was the ANSWER!

    Monday, November 23, 2015 6:53 AM
  • Thanks Tim
    Friday, January 29, 2016 9:04 PM
  • Have you tried disabling the the option "Check for Publisher’s Certificate Revocation" in Internet Explorer. When you are installing a SP or RU, a huge number of connections to Microsoft’s Certificate Revocation Server are being established in the background. Temporary disabling this option significantly reduces installation time/Exchange downtime.  You can get more info in this video:

    How to Reduce Downtime When Installing Rollup Updates in Exchange 2010


    This did it for me.
    Wednesday, February 24, 2016 8:43 AM