none
MDT 2013 - Image Capture fails to upload image RRS feed

  • Question

  • I am attempting to capture and upload an image. The drivers for the hardware imported into MDT. Downloading images works fine.

    I run the litetouch script from within the OS but when the system reboots to create the WIM and upload to the server the NIC drivers are not found. Why?

    I should also add that this was working. I am unaware of any changes made other than driver imports for new models.

    Thanks!


    JJ


    Tuesday, July 29, 2014 11:37 AM

All replies

  • Hi JJ. Are you capturing an image on a virtual machine? Also, how do you create your WinPE file? More information would be helpful....
    Tuesday, July 29, 2014 2:13 PM
  • I am using a VM (vSphere 5.5) as well as physical PCs. They act the same.
    The drivers are imported into MDT.
    The ISO created by MDT works fine.
    I am using the standard Sysprep and Capture task sequence.

    Is there some other step required that I am missing to get the drivers into the WIM that is installed to the hard drive? I was under the impression that it uses the same WIM as WinPE.

    JJ

    Tuesday, July 29, 2014 5:08 PM
  • I see, thank you. So you mentioned that it WAS working earlier. At the point where it reboots and cannot upload to the server is troubling. Here is a website I used previously. Check it out and I hope it finds you well.

    http://www.the-d-spot.org/wordpress/2010/01/20/vmware-network-drivers-for-winpe-3-0/

    Tuesday, July 29, 2014 5:17 PM
  • Thanks I appreciate you taking time on this.

    I already have the drivers integrated into WinPE and they work when I boot from it.

    This is really weird.


    JJ

    Tuesday, July 29, 2014 5:29 PM
  • HAHA Happens all the time. I'm glad your up and running. Have a good week.
    Tuesday, July 29, 2014 5:31 PM
  • Sorry you misunderstand. The ISO has always worked but booting for the capture has stopped working. THAT is the weird part.

    The MDT server is Windows Server 2012 with Data Dedupe enabled on the data drive only. We have been running dedupe for several months but I thought I'd throw that out there.


    JJ

    Tuesday, July 29, 2014 6:07 PM
  • OK. Question. Do I need to inject unsupported network drivers into the WIM:

    Operating Systems\Capture WIM\boot.wim?

    If so, where is this mentioned in the MDT help? Still looking...

    Thanks!


    JJ

    Tuesday, July 29, 2014 6:54 PM
  • Well, there are two wims.. One that contains the image which SHOULD NOT have any drivers and the LiteTouch wim located under your deployment share\BOOT folder. Your LiteTouch wim has drivers injected based on what you specified under your WINPe environment. The out of box drivers is the repository that will be injected for the image.. Does that make sense?
    Tuesday, July 29, 2014 7:10 PM
  • Yes it makes sense and confirms what I thought. Thanks!

    So it appears that for some reason that seems to make no sense that even though the drivers appear to be injected into WinPE (I boot from it and connect to the LAN) that they are not included when the WIM is copied to the hard drive.

    This started when I decided to "Completely regenerate the boot images". This has to be something simple I'm missing.


    JJ

    Wednesday, July 30, 2014 11:55 AM
  • Yes! It is now working again. Here is what I have observed.

    The missing NIC drivers were listed in the MDT GUI but I do not think the files were actually existing in the file system. I say this because after closing a re-opening the GUI several times over the course of this nightmare they finally disappeared from the GUI (WTF?). I re-added them and now all is well.

    Coincidentally to that I had opened the drivers.xml in notepad but made no changes.

    That is NOT cool.


    JJ

    Wednesday, July 30, 2014 12:16 PM