none
HyperV Manager in Windows 10 Enterprise 1709 not working for connection to Windows 2012 R2 HyperV RRS feed

  • Question

  • After upgrading from Windows 10 Enterprise 1703 to Windows 10 Enterprise 1709 (Fall Creators Update), I am unable to connect to my Windows 2012 R2 HyperV machines with HyperV Manager.  Connections to computer management still work, and HyperV connections to Windows 2016 HyperV still work.  Only the HyperV connection to Windows 2012 R2 HyperV is failing, with "RPC Server not available."

    Confirmed with a Windows 10 Enterprise 1703 HyperV manager that I can connect to Windows 2012 R2 HyperV with no issues.

    Guessing that the new Windows Defender Firewall is the culprit...perhaps a manual rule is needed?

    Any help would be appreciated.  Thanks!


    Edward Ray



    Friday, October 27, 2017 3:45 PM

All replies

  • Well have you disable the Windows Firewall as a test to see if that works?

    Sunday, October 29, 2017 11:25 PM
  • Hi,

    I agree. Based on my check, after upgrade to Windows 10 1709, some Hyper issues have been reported. The issue always related to the firewall. A third-party firewall or any other security application running on a server, or on a client, might sometimes block the traffic from reaching the server on its TCP ports, resulting in the interruption of RPCs.

    Try to turn off the feature for a while until your RPC is successfully made. This way, you can find out whether your firewalls are the root cause for RPC errors.

    Hope it will be helpful to you


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, October 30, 2017 9:40 AM
    Moderator
  • Yup that did it.

    Disabling the firewall turned out to be an interesting adventure in 1709.  It is called "Windows Defender Firewall" and the ability to turn off/disable from local machine has been grayed out.

    Had to apply a GPO to disable.  Even that did not turn it off.  Had to reboot.

    I am guessing that windows is trying to move away from RPC port calls.  This will take time due to legacy apps.


    Edward Ray

    Monday, October 30, 2017 4:42 PM
  • Do you control the Windows Firewall with GPO at all, just wondering as can turn that off via the Defender page on this system.

    You could try packet capture to see what it does use and then create rules for it.

    Monday, October 30, 2017 7:25 PM
  • I have the same problem :-(

    Quite annoying, MS does this again, like when Windows 7 couldn't manage Hyper-V 2012 R2 ;-(

    /Jesper


    Regards Jesper Østerdal

    Wednesday, November 1, 2017 7:33 AM
  • i use 3rd Party Firewall and tried to turn it off but it didn't work. Maybe i have to try the GPO method too.

    Which GPO did you applied?

    Sunday, November 12, 2017 6:57 PM