none
Library Disabled in powershell RRS feed

  • Question

  • Physical library was divided to two logical library.  One library was used by DPM and second by  Veeam.  After i week proper working DPM stop doing tape backup.I can see two libraries with one drive each. I can do detailed inventory on library , but it can't do backup. In powershell  i can see that library is disabled wirh status = enabled. 

      Name                : Library: IBM TotalStorage 3573 Tape Library: (Disabled)
    DriveCount          : 4
    SlotCount           : 21
    NumberOfIEPortSlots : 3
    Status              : Enabled
    Computer            : CPD1- xxxxx
    DoorStatus          : Locked
    BarcodeStatus       : Available
    AutoloaderStatus    : Available
    SerialNumber        : 00X4U78W2738_LL0
    AutoloaderLocation  : Port 0, Bus 0, Target 3, Lun 1
    ProtectionGroups    : ITSM_xxxx, xxx

    And in the GUI i looks good:

    Tuesday, September 25, 2018 12:31 PM

All replies

  • Hello!

    Do you receive any errors while trying to perform a backup to this tape? Are you trying with DPM's own schedules or just manually?

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Tuesday, September 25, 2018 1:53 PM
  • there is an error  : The back up to tape job failed for the following reason: (ID: 3311) The command sent by DPM to the library agent timed out. (ID: 24076)
    Tuesday, September 25, 2018 4:07 PM
  • Try restarting DPMLA service and then in DPM console in management tab do rescan and refresh. After that check for errors.

    Tornado

    Wednesday, September 26, 2018 6:17 AM
  • Restarting DPMLA dosen't help.

    I returned to the orginal settings - mean one physical library. And one drive start backing up. Anyone can explain why  library is steel in state Disabled. Status is of course "enabled'"   What does it mean when after the name of library in parentheises is typed  "Disabled" - a little bit strange.

      

     
    Friday, September 28, 2018 1:17 PM
  • I had the same issue as my Library Drive was disabled. I ran the following commands from an elevated powershell replacing my server name in the first command

    https://docs.microsoft.com/en-us/powershell/module/dataprotectionmanager/enable-dpmtapedrive?view=systemcenter-ps-2016

    When I ran the command I got a kick back

    Enable-DPMTapeDrive : Operation failed because drive \\.\Tape2147483646 is offline. (ID: 31146)

    Upon further research I ran the Qualcom Super Loader 3 tools to test the drive and our drive is bad. I also updated our Dell Perc drivers and the tape drive driver with no luck. Good luck!

    Friday, September 28, 2018 6:26 PM