locked
Exchange 2007 cannot deliver emails RRS feed

  • Question

  • We have a coexistance setup with one Exchange 2003 and one Exchange 2007 (formal release) server. The Active Directory is fairly simple: one domain, one site and single IP segment.

    When we send out email from the mailboxes on the Exchange 2007(through OWA) to a mailbox on Exchange 2003, the emails are automatically sent to "Drafts" box. Go throught Event View, there are a couple of warning:

    Event Type: Warning
    Event Source: MSExchangeMailSubmission
    Event Category: MSExchangeMailSubmission
    Event ID: 1009
    Date:  1/11/2007
    Time:  4:35:50 PM
    User:  N/A
    Computer: DCCEXCHANGE2007
    Description:
    The Microsoft Exchange Mail Submission service is currently unable to contact any Hub Transport servers in the local Active Directory site. The servers may be too busy to accept new connections at this time.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    I am sure we are experiencing Back Pressure. The Exchange2007 server is very new and has 4GB memory. Right now mailboxes on two servers are less than 30.

    Using Test-Mailflow cmdlet, the test fails. Every service is running normally.

    I have enabled the Hubtransport on this site.

    Really frustrating. Not sure if MS has really done any serious tests before releasing this product to the market.

     

    Thanks for any inputs.

     

    Tony Tan

     

     

     

    Thursday, January 11, 2007 10:49 PM

Answers

  • Scott,

    Thank you for the reply. I found the is Kerberos related problem. The Exchange 2007 machine's SID is not generated correctly. I reinstalled the machine. The problem is gone.

    Thanks again,

    Tony Tan
    Monday, January 15, 2007 3:53 PM

All replies

  • Tony,

    How do you know that you're experiencing back pressure?  Have you checked the event logs?  There should be a back pressure event in the logs on the hub server.

    If you are, the most likely cause is that you do not have 4GB of free disk space on the drive with the mail.que database.

    I can assure you that this product was very much tested and is used internally for all of our email.

    HTH,

    -Scott

    Friday, January 12, 2007 5:00 PM
  • Scott,

    Thank you for the reply. I found the is Kerberos related problem. The Exchange 2007 machine's SID is not generated correctly. I reinstalled the machine. The problem is gone.

    Thanks again,

    Tony Tan
    Monday, January 15, 2007 3:53 PM
  • Hi Guys,

    I am experiencing the same problem - e-mails moved to draft folders, and event generated:

    "The Microsoft Exchange Mail Submission service is currently unable to contact any Hub Transport servers in the local Active Directory site. The servers may be too busy to accept new connections at this time.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp."

    Interestingly, a guy on Experts Exchange mentioned that he had the same, and that it had to do with an "lmhost file that was pointed to the wrong ip"  Unfortunately he didn't give more info.  I am not sure how to look / fix the Kerberos problem (related to the Exchange 2007 SID), or rather to fix the "Imhost" file.

    Any help will be appreciated.

    Regards, Rupert

    Saturday, February 24, 2007 9:50 AM
  • Check the status of time synchronization between servers in your environment. I found that if the Exchange Hub Transport Server gets unsynchronized from the AD servers in the environment, it stops sending email, instead, depositing the messages in the Drafts folder.
    Thursday, April 5, 2007 1:56 PM
  •  I met the same error and notice there is also an error from the MSExchange Transport Service with Event ID 15002.

     

    Then I find the answer from here:

    http://krudler.spaces.live.com/blog/cns!E121B0CC6C05B66C!355.entry

     

    Now my test mailboxes can receive emails.

    Tuesday, April 10, 2007 7:14 AM
  • I had ever encountered this problem.

    I followed the way in this article and the issue was also resolved.

    http://www.proexchange.be/modules.php?name=News&file=article&sid=305&mode=nocomments&order=0&thold=0

    Just edit EdgeTransport.exe.config, change <add Key="EnableResourceMonitoring" value="ture" /> to EdgeTransport.exe.config

    <add Key="EnableResourceMonitoring" value="false" />

     

    I also get support from Microsoft tech. support. The guy told me, "provide 4G memory, install mailbox database role in a separate file server". he he~~

    Wednesday, April 18, 2007 3:34 PM
  • Hi all,

    I had similar problem earlier and were able to fix it following the steps explained in the below forum. I know it include the same information mentioned earlier, but it add a lot of other reasons and resolutions for them that can cause the same issue.

    http://itcomparison.com/phpBB2/viewtopic.php?p=55#55


    I hope that will be of help to every one.
    Yours,
    VMguru007


    Tuesday, January 8, 2008 11:23 PM
  • Hi

    I need some help urgently.we hada an OCS integration with Nortel systems everything was working fine,when there was a power failure.After the power was restored theres a small problem my mails are not being delivered.the mails that are being send are there in the send items but it is not delivered to the recipient.Now there are two errors being shown on the exchange server errors with event ID 15002 and 1009 respectively.I just found out that the free space on my mailbox drive is less than 4 GB.So is this really a problem for my mails not being delivered.

    Please help me its very urgent.

     

     

    thanks

    Saturday, March 22, 2008 5:24 AM
  • Deleted
    Thursday, June 12, 2008 9:54 AM
  •  

    did you find any solutions
    Wednesday, October 8, 2008 11:44 PM


  • Did you find any solution for the other than re-installing
    Wednesday, September 23, 2009 6:17 AM
  • HI ALL,


    HERE IS THE SOLUTION    I FOUND AND IT IS WORKING


    I DID FIRST CMDELT   TEST-MAILFLOW

    RESULT WAS   *FAILURE*

    I WENT TO C:\WINDOWS\SYSTEM32\DRIVERS\HOSTS OPEN IN NOTE PAD


    I FOUND THERE WAS ONE WORNG ENTRY  OTHER THAN MY COMPUTER IP ADDRESS

    I CHANGE THIS TO MY ORIGINAL IP ADDRESS

    THEN I CHECK THE TEST-MAILFLOW FROM THE EXCHANGE MANAGEMENT SHELL COMMAND

    RESULT WAS *SUCCESS*


    THEN I WENT TO OWA    REALY ITS STATED WORKING .

    Thanks  for all



    Wednesday, September 23, 2009 6:40 AM
  • 1.stop transport services
    2. deletel all files:C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\data\Queue
    3.restart transport services.

    I hava the same problem, I solved it.
    Monday, March 1, 2010 6:02 AM
  • 1.stop transport services
    2. deletel all files:C:\Program Files\Microsoft\Exchange Server\V14\TransportRoles\data\Queue
    3.restart transport services.

    I hava the same problem, I solved it.
    this works perfectly, thanks for the solution
    Tuesday, September 13, 2011 1:22 PM
  • Be careful -- this may "fix" your issue, but it also may delete any messages that were in transit.

    If your disk space is low, I would suggest that instead of delete, you might be better off with one of the following:

    1) Add a step before #1 -- pause transport services; make sure queues are all empty

    2) In step #2 -- Move the files off to another machine instead of delete

    3) Another option is to add more space, that is, move the queues to a drive with more space

    Tuesday, September 20, 2011 9:02 PM
  • Also, to follow up on Scott's point...

    I ran into this problem due to low disk space.  The following was written to the Event Viewer but, for some reason, was only written AFTER I had restarted the Exchange Transport service:

     The Microsoft Exchange Transport service is rejecting message submissions because the available disk space has dropped below the configured threshold.

    Resource utilization of the following resources exceed the normal level:
    Queue database and disk space ("C:\Program Files\Microsoft\Exchange Server\TransportRoles\data\Queue\mail.que") = 99% [High] [Normal=94% Medium=96% High=98%] 

    In my case, this was a non-Production environment where I hadn't been running regular backups.  A full Information Store backup reclaimed needed disk space and solved the problem.


    skirscht@hotmail.com
    Friday, October 14, 2011 6:47 PM
  • I had the same issue.

     

    You need to make sure that Ms Exhcange transport service is running under Logon user "Network Service".

    Note: If Exchange is running on a DC, then you may set the Logon user as "Local System"

    Wednesday, November 2, 2011 4:19 AM