locked
Another users' email account linked / associated in Outlook Desktop app RRS feed

  • Question

  • Hello,

    I have a client with an odd problem. First - they are using Office 365 - Exchange. Using Outlook (on-premise) Michele's outlook shows both her email and another employees mail. We are unable to close the other users mail. It is not set to open as a shared mailbox, it s not setup as a 2nd exchange account in her mail settings under her profile. I created a new profile and the other mail account appears.

    However, when we connect to her mail through office 365 (web) the other users mailbox is not there. 

    I am at a loss as I cannot figure out how this mailbox is associated / linked to her Outlook - on-premise (only).

    Any ideas would be greatly appreciated.

    John

    Sunday, May 10, 2020 12:47 PM

Answers

  • Hi John,

    It shows that Michele has got Full Access permission on Steve's mailbox. Because of that, Steve's mailbox is being automapped to Michele's.

    If Michele is not supposed to have this permission, run this command to remove it:

    Remove-MailboxPermission -Identity Steve -User Michele -AccessRights FullAccess

    If Michele is supposed to have this permission but not the automapping thing, run this command right after you ran the one above (this will grant the permission back without automapping):

    Add-MailboxPermission -Identity Steve -User Michele -AccessRights FullAccess -AutoMapping:$false

    Of course, you need to be connected to Exchange Online PowerShell again.

    Regards,
    Burak V.

    Monday, May 11, 2020 4:40 PM
  • Hi John,

    Welcome to our forum.

    >> We are unable to close the other users mail. It is not set to open as a shared mailbox, it s not setup as a 2nd exchange account in her mail settings under her profile. I created a new profile and the other mail account appears.

    According to your description, it seems that your issue may be related to the auto mapping feature. I researched a lot and found that if you have full access of other mailbox, the mailbox auto-mapping feature will use Autodiscover to automatically open the mailbox in your Outlook profile. For more information, please check the content of full access in this article.

    If this is your case, to remove the other user's mailbox, please check this article: How to remove automapping for a shared mailbox in Outlook for Office 365 for help.

    If this is not your case, please provide me with more information related to your issue for further research.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.



    Monday, May 11, 2020 7:18 AM

All replies

  • Hi John,

    User (Michele?) might have "full access" permission on the other user's mailbox that causes it to be auto-mapped in Outlook. Have you checked mailbox delegation for the other user in ECP to see if the main user has got delegation on it?

    Also, I'd suggest you to connect to Exchange Online PowerShell and run the the command below to see a list of all mailboxes that Michele has got delegation on, if any:

    Get-Mailbox -ResultSize Unlimited | Get-MailboxPermission -User michele


    You'll need to replace "michele" with her identity (name, userPrincipalName, distinguishedName, GUID, etc.) in the command.

    Regards,
    Burak V.

    Sunday, May 10, 2020 6:02 PM
  • Hi John,

    Welcome to our forum.

    >> We are unable to close the other users mail. It is not set to open as a shared mailbox, it s not setup as a 2nd exchange account in her mail settings under her profile. I created a new profile and the other mail account appears.

    According to your description, it seems that your issue may be related to the auto mapping feature. I researched a lot and found that if you have full access of other mailbox, the mailbox auto-mapping feature will use Autodiscover to automatically open the mailbox in your Outlook profile. For more information, please check the content of full access in this article.

    If this is your case, to remove the other user's mailbox, please check this article: How to remove automapping for a shared mailbox in Outlook for Office 365 for help.

    If this is not your case, please provide me with more information related to your issue for further research.

    Regards,

    Jeff Yang


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.



    Monday, May 11, 2020 7:18 AM
  • Hi Burak,

    I ran the PS command on Michele's account and this is what I got back:

    Identity         USER          Access Rights               IsInherited    Deny

    Steve            Michele         {FullAccess}               False           False 

    What is confusing me on this is the Identity is Steve even though i ran this on Michele's UserID. It does show full access under access rights - Is this the output I was expecting? 

    John

    Monday, May 11, 2020 3:37 PM
  • Hello Jeff,

    I posted a response to Burak regarding a PS get command I ran. I am confused about how the response was formatted but I think this is probably the issue. 

    PS command I ran: Get-Mailbox -ResultSize Unlimited | Get-MailboxPermission -User michele

    I ran the PS command on Michele's account and this is what I got back:

    Identity         USER          Access Rights               IsInherited    Deny

    Steve            Michele         {FullAccess}               False           False 

    What is confusing me on this is the Identity is Steve even though i ran this on Michele's UserID. It does show full access under access rights - Is this the output I was expecting? 

    John

    Monday, May 11, 2020 3:41 PM
  • Hi John,

    It shows that Michele has got Full Access permission on Steve's mailbox. Because of that, Steve's mailbox is being automapped to Michele's.

    If Michele is not supposed to have this permission, run this command to remove it:

    Remove-MailboxPermission -Identity Steve -User Michele -AccessRights FullAccess

    If Michele is supposed to have this permission but not the automapping thing, run this command right after you ran the one above (this will grant the permission back without automapping):

    Add-MailboxPermission -Identity Steve -User Michele -AccessRights FullAccess -AutoMapping:$false

    Of course, you need to be connected to Exchange Online PowerShell again.

    Regards,
    Burak V.

    Monday, May 11, 2020 4:40 PM
  • Hi Burak,

    Thank you. It's working correctly now. I appreciate your help.

    John

    • Marked as answer by John Anemone Monday, May 11, 2020 8:17 PM
    • Unmarked as answer by John Anemone Monday, May 11, 2020 8:18 PM
    Monday, May 11, 2020 8:17 PM