none
Force default search engine Windows 10 / IE11

    Question

  • Hi all,

    I have a GPO that forces the default IE search engine.

    This GPO works on all our Windows XP/7 workstations but does not work on a Windows 10 PC.

    What could I do ?

    Thank you.

    Regards,


    FXE

    Thursday, September 24, 2015 4:06 PM

All replies

  • Hi,
     
    Could you please let us know the steps on how exactly you configured the GPO? Does the Windows 10 PC reside in the OU to which the GPO is linked?
     
    Try to run "gpresult /h c:\result.html" and see if the GPO is received by the machine.
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Friday, September 25, 2015 5:59 AM
    Moderator
  • Hi Ethan and thank you for your answer.

    I've set up this GPO several years ago. I will try to remember how I set it up...

    These 3 parameters are configured under User configuration \ Policy \ Administration templates \ Windows components \ Internet Explorer :

    • List of search providers : Aclivated
    • Restrict modification of the default search engine : Activated
    • Restrict the search providers to a specific list : Activated

    gpresult confimrs that this GPO is applied to the Windows 10 station.

    Regards,


    FXE

    Friday, September 25, 2015 7:36 AM
  • Which search engine do you have configured with your GPO?

    If you are using Google search, KB3038314 update is preventing this. So check if you have this installed.

    Also, I would suggest you update your ADMX templates with the latest Windows 10 templates, then try again and see if it works.

    • Marked as answer by Leo HanModerator Tuesday, October 13, 2015 3:20 AM
    • Unmarked as answer by FXE Wednesday, December 2, 2015 8:00 AM
    Monday, September 28, 2015 5:49 AM
  • Hi all and thank you for your answers,

    To Aravindhan : this KB is not applicable to Windows 10 as it said in this article :

    https://support.microsoft.com/en-us/kb/3038314.

    I dig up this topic because now I can identify the issue with more accuracy.

    There is a Strange comportement in the registry about the key HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes.

    On Windows 7 PC, there is only 1 subkey corresponding to Google.

    On Windows 10 PC, there are 2 subkeys : 1 for Google and another for Bing.

    Always on Windows 10 PC, the GPO that is being used to specify Google as default searchscope has no effect.

    So I decided to set a Registry GPO preference in order to force the value of HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes\DefaultScope.

    After gpupdate /force, I can see the value is updated correctly. But when I launch IE on Windows 10, the value is superseded by the Bing parameters...

    More : I deleted the entire key corresponding to Bing parameters and updated the DefaultScope value for Google, but when I launched IE all Bing parameters came back...

    Any idea please ?
    Thank you.


    FXE

    Wednesday, December 2, 2015 8:52 AM
  • Hi all,

    No idea about that ?


    FXE

    Wednesday, January 6, 2016 8:23 AM
  • Hi Fxe,

    Have you got any answered to your question?
    I have the same problem.

    Regards,

    Shohreh

    Thursday, January 21, 2016 10:58 PM
  • It works for Win7 but not Win 10.

    Bing is still default search engine.

    Thursday, January 21, 2016 11:06 PM
  • Hi Shohreh,

    No answers sadly...

    Regards,


    FXE

    Tuesday, January 26, 2016 11:11 AM
  • Hi

    Did you ever find a solution?

    Best regards,

    Thomas

    Monday, February 1, 2016 11:52 PM
  • Hi,

    No, nobody provided an answer...

    Where is MS Windows 10 team ???


    FXE

    Thursday, February 4, 2016 9:09 AM
  • Am 04.02.2016 um 10:09 schrieb FXE:
    > No, nobody provided an answer...
     
    If it can be set in UI:
    - create a registry snapshop (regshot.exe - sourceforge, registry
    workshop - Torchsoft, whatever)
    - set value in UI
    - create another snapshop and compare ...
    - set value with GPP Registry or create your own ADM(x)
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Thursday, February 4, 2016 9:18 AM
  • Mark,

    Registry changes are already known and GPP had already been tested :

    Hi all and thank you for your answers,

    To Aravindhan : this KB is not applicable to Windows 10 as it said in this article :

    https://support.microsoft.com/en-us/kb/3038314.

    I dig up this topic because now I can identify the issue with more accuracy.

    There is a Strange comportement in the registry about the key HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes.

    On Windows 7 PC, there is only 1 subkey corresponding to Google.

    On Windows 10 PC, there are 2 subkeys : 1 for Google and another for Bing.

    Always on Windows 10 PC, the GPO that is being used to specify Google as default searchscope has no effect.

    So I decided to set a Registry GPO preference in order to force the value of HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes\DefaultScope.

    After gpupdate /force, I can see the value is updated correctly. But when I launch IE on Windows 10, the value is superseded by the Bing parameters...

    More : I deleted the entire key corresponding to Bing parameters and updated the DefaultScope value for Google, but when I launched IE all Bing parameters came back...

    Any idea please ?
    Thank you.


    FXE


    FXE


    • Edited by FXE Thursday, February 4, 2016 9:29 AM
    Thursday, February 4, 2016 9:28 AM
  • Hi,

    Can you try below manual steps and see if it works? If that is working you can export the registry and target the Win10 PC's.

    To change your default engine, follow the steps below

    In the browser open Google.com

    Click on the three dots in the top right corner of the browser window, then click on Settings scroll down if you cannot see

    Go down to the bottom and click 'View Advanced Settings'

    Scroll down until you see 'Search in the address bar with', click on it and select 'Add New'

    Then click on Google and select 'Add as default'

    Check the registry before and after the changes. Export settings to .reg or Group Policy Preferences Wizard from HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\SearchScopes\ – Default Scope key


    Regards,

    J

    Please remember to mark the replies as answers if they help.


    Cheers, J

    Thursday, February 4, 2016 9:39 AM
  • I have the same issue. When I launched IE 11 on Win 10, all Bing parameters are back again.
    Thursday, February 4, 2016 9:44 AM
  • Hi,
     
    Am 04.02.2016 um 10:28 schrieb FXE:
    > There is a Strange comportement in the registry about the key
    > HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes.
     
    Step 1:
    I add and changes manually via regfile:
    HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes
    "DefaultScope"={F1F5C95F-BF45-49FC-94FE-6A2DADA7F6D7}
    HKCU\SOFTWARE\Microsoft\Internet
    Explorer\SearchScopes\{F1F5C95F-BF45-49FC-94FE-6A2DADA7F6D7}
    ... some google blablabla
     
    Step 2:
    I start IE and get a yellow message pop up at the bottom:
    An unknown program wants to change your searchengine to google
    allow or disallow ...
     
    ---> not enough registry changes ...
     
    Step 3:
    Changing it in UI and compare the registry there are 2 ugly binary blobs
    changing in HKCU\SOFTWARE\Microsoft\Internet Explorer\User Preferences
    aswell, when setting default search engine
     
    Step 4:
    Import them aswell
     
    ---> Now, I am able to change my search providers just by toggling
    "DefaultScope"
     
    Should work with GPP aswell with one little problem:
    This settings will not take efect in first run IE with new user
    profiles. It needs a re-apply settings, which GPP usually do at the next
    login. Say a secound logon of the user.
    The first run of IE sets defaults provided by install.ins and other
    settings, and your previous deployed reg values are overwritten by this
    technic.
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    • Proposed as answer by Eugene_Sokolov Tuesday, April 26, 2016 8:53 PM
    Thursday, February 4, 2016 10:53 AM
  • Am 04.02.2016 um 11:53 schrieb Mark Heitbrink [MVP]:
    > The first run of IE sets defaults provided by install.ins and other
    > settings, and your previous deployed reg values are overwritten by this
    > technic.
     
    I did a quick test with a clean and fresh installed Win10 (1511) client:
    My settings applied this time without a secound login. ??
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     
    Thursday, February 4, 2016 12:26 PM
  • Hello,

    Exact same situation as decribed above. Win7 and Win8.1 with IE9,10,11 all is ok, Win10 with IE11 not, Bing all the time.

    As Mark suggested :

    Unlink the computer OU from the GPO, did it manually with the UI, exported the reg key from the local machine and applied the keys to the GPO.

    Link back the GPO to the OU where my Win10 is, gpupdate /force and Bing back to default search provider and no more Google.

    So please Mark, can you elaborate more.

    Still no solution so far for Win10 and IE11 default search by GPO....

    Friday, February 5, 2016 8:50 PM
  • Hi,

    I´ve the same Problem.

    The registry Settings are working fine with IE11 and Win 7 but with Win 10 it doesn´t work.

    It doesn´t matter if I configure it manually or by GPP, it doesn´t work.

    I changed the DefaultScope manually to the Google ID, opened IE11, saw only the bing search, checked the registry and the ID was changed again to bing

    EDIT: I´ve to add that in the the same GPO I´ve enabled "Restrict search Providers to a specific list" and the registry keys are written to HKLU\Software\Policies.... and there is the DefaultScope set to Google but in IE it´s still bing.

    • Edited by MatthiasWenz Thursday, February 11, 2016 7:34 AM Added
    Thursday, February 11, 2016 7:14 AM
  • +1 to Matthias, This is still an issue,

    Please every Win10 early adopter in business, is someone has been able to acheive this by GPO ?

    Is the release of Win10 as something to do in the equation (pre 1511) and 1511 and + ???

    Thanks

    Thursday, February 11, 2016 6:35 PM
  • Seriously, is there any MS employee who can read the various posts about this monopolistic situation ?

    We are not consumers here, we are enterprise-class clients...


    FXE

    Tuesday, March 1, 2016 8:13 PM
  • Hi all,

    I've open a case with MS.

    I'll give you feedback asap.

    Regards,


    FXE

    Thursday, March 3, 2016 6:59 PM
  • Any luck with the MS case? 
    Monday, March 14, 2016 4:20 PM
  • MICROSOFT OWNS YOUR SOUL!!!!!!!!!!!!!!!!!!!!!!BING OR DEATH!!!!!!!!!!!!!!!!!!!!!!!!!!

    Monday, March 14, 2016 5:16 PM
  • Hi all,

    Here the Microsoft Support answer :

    Based on the lab testing and troubleshooting session that we performed we have found that it’s By design scenario.

     

    Unfortunately there is no way we can make Google as default Search provider as using Domain Group policy for IE 11 on windows 10

     

    I apologies in delay in response as I have spent most of the time finding workaround for the same but didn’t found any.

    In substance : there is no solution.

    Thank you Microsoft for this brand new abusive position. I hope EU will take the expected measures...


    FXE


    • Edited by FXE Wednesday, March 16, 2016 4:29 PM
    Wednesday, March 16, 2016 4:28 PM
  • Disappointing, but not unexpected.  We got the same answer when we tried to unpin edge from the taskbar.  We are a mid-sized shop, and I have a hard time believing that the larger enterprise clients have not made a stink about this yet…  MS is effectively forcing us to use their awesome new browser \sarcasm/ and search provider by not providing a centralized method for removing it from the UI or sufficient group policies to control the behavior of or secure the browser. 

    The only work around that I have found is to manually change the search provider and un-pin edge after the system is imaged.  That is exactly what I want my front line guys spending their time on \more sarcasm/

    • Proposed as answer by Brian___B Saturday, March 19, 2016 5:11 PM
    • Unproposed as answer by Brian___B Saturday, March 19, 2016 5:11 PM
    Friday, March 18, 2016 5:21 PM
  • Hi,
     
    Am 04.02.2016 um 10:28 schrieb FXE:
    > There is a Strange comportement in the registry about the key
    > HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes.
     
    Step 1:
    I add and changes manually via regfile:
    HKCU\SOFTWARE\Microsoft\Internet Explorer\SearchScopes
    "DefaultScope"={F1F5C95F-BF45-49FC-94FE-6A2DADA7F6D7}
    HKCU\SOFTWARE\Microsoft\Internet
    Explorer\SearchScopes\{F1F5C95F-BF45-49FC-94FE-6A2DADA7F6D7}
    ... some google blablabla
     
    Step 2:
    I start IE and get a yellow message pop up at the bottom:
    An unknown program wants to change your searchengine to google
    allow or disallow ...
     
    ---> not enough registry changes ...
     
    Step 3:
    Changing it in UI and compare the registry there are 2 ugly binary blobs
    changing in HKCU\SOFTWARE\Microsoft\Internet Explorer\User Preferences
    aswell, when setting default search engine
     
    Step 4:
    Import them aswell
     
    ---> Now, I am able to change my search providers just by toggling
    "DefaultScope"
     
    Should work with GPP aswell with one little problem:
    This settings will not take efect in first run IE with new user
    profiles. It needs a re-apply settings, which GPP usually do at the next
    login. Say a secound logon of the user.
    The first run of IE sets defaults provided by install.ins and other
    settings, and your previous deployed reg values are overwritten by this
    technic.
     
    Mark
    --
    Mark Heitbrink - MVP Windows Server - Group Policy
     
    GPO Tool: http://www.reg2xml.com - Registry Export File Converter
     

    Thank you Mark! That worked for me finally after several days fighting with Group Policy to try and make this work (Windows 10 and IE 11). I don't usually post, but hope I can save someone a lot of frustration and they will find this useful. I have included a screenshot of 9 registry settings I made in GPMC following Mark's advice. You can install Google search manually and then copy registry settings from locations on my screenshot on to GPO.

    Tuesday, April 26, 2016 9:03 PM
  • It worked for me as well however if you implemented this solution in the past then you most likely enabled GP's such as restricting search providers to a specific list.  If that is the case then you must undo those changes and set them back to Not Configured.  Otherwise the first time you run IE it'll reset back to Bing as the default provider.

    Thanks Mark!

    p.s. see you all back here again when 2017 LTSB is released and whoever is bored at MS decides to change it again!

    Tuesday, May 3, 2016 9:46 PM