locked
PULLDP.MSI not trusted RRS feed

  • Question

  • Hi all,

    I have one PullDP already configured and pulling content regularly and smoothly.

    Now, to pull down new content or new content version I note the following logged message in DISTMGR.LOG saying that PULLDP.MSI is not trusted,

    Primary site OS is w2008 r2 enterprise SP1;

    PULLDP server is w2003 enterprise sp2

    Would you please help me fix this issue as it is recurring for other PULL DP also.

    Thank you


    Wednesday, August 6, 2014 11:50 AM

All replies

  • Please post the entire relevant snippet from the log file -- talking about the error you saw doesn't help us help you.


    Jason | http://blog.configmgrftw.com

    Wednesday, August 6, 2014 2:17 PM
  • Failed to copy D:\Program Files\Microsoft Configuration Manager\bin\i386\pulldp.msi to \\pulldpfqdn\SMS_DP$\sms\bin\pulldp.msi. GLE = 53 SMS_DISTRIBUTION_MANAGER 8/6/2014 2:30:06 PM 13588 (0x3514)

    Error in verifying the trust of file '\\pulldpfqdn\SMS_DP$\sms\bin\pulldp.msi'. SMS_DISTRIBUTION_MANAGER 8/6/2014 3:00:28 PM 3568 (0x0DF0)
    File \\pulldpfqdn\SMS_DP$\sms\bin\pulldp.msi is not trusted SMS_DISTRIBUTION_MANAGER 8/6/2014 3:00:28 PM 3568 (0x0DF0)

    Wednesday, August 6, 2014 2:30 PM
  • When I've seen errors like that, it has usually been due to the domain membership of the computer having been lost/corrupt. A rejoin to the domain has always fixed it.

    Of course, there could be other reasons for it, but that is one that I've seen - and not for this specific issue (pulldp.msi) however I have seen that error for other client files before, and the re-join to the domain resolved it.


    Wally Mead

    Wednesday, August 6, 2014 3:19 PM
  • Now the erro log for untrusted file changed this way:

    The file '\\pulldpfqdn\SMS_DP$\sms\bin\pulldp.msi' is not signed. SMS_DISTRIBUTION_MANAGER 8/6/2014 4:23:59 PM 9180 (0x23DC)


    Wednesday, August 6, 2014 3:28 PM
  • I've seen the same symptom and resolution for this one as well. Domain membership. If you've already rejoined the domain, then unless there is some trust issue with the computer and domain, that's the only thing I've seen (well, other than a reimage being done in some cases, which has always resolved it). Rather drastic, but does point out that it is not a ConfigMgr issue, it is just exposing the issue in the environment.

    Before you go reimaging, you might want to wait for others to offer their thoughts on it as well, they may have seen other resolutions than what I have seen.


    Wally Mead

    Wednesday, August 6, 2014 3:31 PM
  • Once I removed PULLDP role, hence get it back to DP then package transfer is going smoothly.

    Some other PULLDP configuration issues were resolved by deinstalling and reinstalling CCM client in order to have the CCMEXEC service started up properly.

    Wednesday, August 6, 2014 3:35 PM
  • I tried to remove PULLDP feature then I got the following entries:

    CDistributionManager::ConfigurePXE failed; 0x80041013 SMS_DISTRIBUTION_MANAGER 8/6/2014 4:40:04 PM 7052 (0x1B8C)
    ExecStaticMethod failed (80041013) SMS_DistributionPoint, EnableDPUsageStatsGathering SMS_DISTRIBUTION_MANAGER 8/6/2014 4:38:34 PM 7052 (0x1B8C)
    Failed to register DP task through method E on PULLDPFQDN. error = 0x80041013 SMS_DISTRIBUTION_MANAGER 8/6/2014 4:38:34 PM 7052 (0x1B8C)


    Wednesday, August 6, 2014 3:41 PM
  • I can't tell from your reply if you are working as you want now, or just stating these are two things that you've done to work around the issue. If you are fine, then please mark your thread as answered. If still need other suggestions, then feel free to leave it unanswered for others to respond to. Or open a case with CSS.

    Wally Mead

    Wednesday, August 6, 2014 3:41 PM
  • it is just a remark, i'm not happy with PULLDP removed.
    Wednesday, August 6, 2014 3:43 PM
  • Could you please update the current situation? What's (not) working? Are there any issue right now? If so: which ones?

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, August 6, 2014 5:28 PM
  • Actually Primary site cannot install PULLDP on remote server
    Wednesday, August 6, 2014 5:30 PM
  • So can you please post the relevant lines of distmgr.log then? Those snippets above don't help as they are taken out of context.

    Torsten Meringer | http://www.mssccmfaq.de

    Wednesday, August 6, 2014 5:54 PM
  • hi, I've seen this error quite a bit in our environment, I think you will find that the pulldp.msi file is now missing from the sms_dp$\sms\bin folder along with a number of other files.

    if you copy the file back in there from another system it will get up and run again.  it seems that the primary doesn't check for these files, so they won't be copied back until you reinstall the pulldp.

    In the instances we have had validation was also not running because smsdpmon.exe was also missng from \bin.

    I don't know why the files get deleted though, still working through that!

    Cheers,

    David

    Thursday, August 7, 2014 11:08 AM
  • Hi David,

    Did you figure out your problem with files in the Bin and log Directory getting deleted on a PullDP?

    I having same problem. I have been coping the files over and running repair, which will keep it going for few weeks.

    Planning to reinstall the pulldp sometime soon, but curious of what's causing this.

    Thanks,

    Vinod.

    Tuesday, March 17, 2015 2:28 PM
  • Hi Vinod,

    After we installed CU3, the issues have stopped occurring.
    We found that the files would be deleted when a package failed to be distributed correctly, and the PullDP tried to clean up the failed files and performed a recursive delete instead of a selective one, deleting some critical files.

    (note, we also ensured our PullDP's had the CU3 client agent as well)

    • Proposed as answer by VinodR Thursday, March 19, 2015 11:50 AM
    Tuesday, March 17, 2015 8:58 PM
  • Hi David,

    Thanks for the quick reply.

    Do you know of any issues with CU3? CU4 is out but is too new for consideration.

    Wednesday, March 18, 2015 11:53 AM
  • We didn't experience any new issues as a result of updating to CU3.
    Just some issues remained ;)...(that weren't part of this update)

    We are planning to update to CU4 in the next couple of weeks.

    Wednesday, March 18, 2015 8:46 PM
  • Thanks David. I will plan for CU3 sometime soon.

    Thursday, March 19, 2015 11:54 AM