locked
Access denied to sites in SharePoint RRS feed

  • Question

  • Hello,

    I have successfully restored the SharePoint production environment to a test server.

    Now I would like to get access to the sites restored:

    1. how to identify for sure the site is test as they have the same URL.

    2. Even as Farm Administrator most of the sites are getting "access denied" how to correct this?

    3. When sending an access request from the site on the test server to the "site owner" where fdo I locate the site owner? is it the Primary Administrator?

    4. the account used is:

    Primary Administrator on most of the sites but still getting access denied...

    Primary Site Collection Administrator

    Farm Admintrator

    Under

    Add or change a site collection administrator

    1. At the top level of your site collection, click Site Actions and then Site Settings.
    2. Under Users and Permissions, click Site Collection Administrators.
    3. In the Site Collection Administrators field, type or browse to find the name of the person you want to designate a site collection administrator.
    4. Click OK.

    I do see Site Collection Administrator under Central Administration > Site Settings for server name:43338 ONLy ... no other sites !!! what did I miss?

    ALso access denied to the Shared Services Administration???

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager









    • Edited by Felyjos Friday, December 21, 2012 1:56 AM
    Friday, December 21, 2012 1:08 AM

Answers

  • Hi,

    Have you disabled the loopback check?

     

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    1. Right-click MSV1_0, point to New, and then click Multi-String Value.
    2. Type BackConnectionHostNames, and then press ENTER.
    3. Right-click BackConnectionHostNames, and then click Modify.
    4. In the Value data box, type the host name or the host names for the sites that are on the local  computer, and then click OK.
    5. Quit Registry Editor, and then restart the IISAdmin service.

    -Ivan

     


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders, Business Intelligence in SharePoint 2013.

    • Marked as answer by Felyjos Friday, February 1, 2013 8:58 PM
    Monday, January 28, 2013 4:42 AM

All replies

  • Hi,

    Just try to add user in central admin as admin (full control right) and then give full control for this user for each and every web application (CA--application--web application permisison). you need to also add same user in local admin group (click here to provide local admin right. This is for 2010 but will work in 2007 as well).

    If you are not able to access SSP then create new SSP using above account and configure same as production. SSP is more secured and only authenticate user can access it (even if admin does not have right for SSP then it will be inaccessible for admin as well).

    Let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Friday, December 21, 2012 5:55 AM
    Moderator
  • Hello,

    The users are Members of a Group which Administrator Full Control Right (should I add each user individually?).

    Under CA > Application  > Application Security > I see User permissions for Web Application where everything is checked for all sites but I do not see a Web Application Permissions by itself ... where to look to correct this? Is it the correct place?

    All users are in a Group Local Administrators on the server.

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager


    • Edited by Felyjos Friday, December 21, 2012 4:32 PM
    Friday, December 21, 2012 4:24 PM
  • Hello,

    With the help of Jason(http://social.technet.microsoft.com/Forums/en-US/sharepointgenerallegacy/thread/8f95e42f-d316-4dcb-9e84-9e0d77c5086a) I was able adding a host file to be sure to use the local URL.

    but from the

    The list is incomplete...

    Any idea?

    Thanks,

    Dominique


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager

    Friday, December 21, 2012 10:16 PM
  • Hello

    I should have all these sites listed... or at least I need to find a way to see the permissions on those...

    But apparently in Production only the Central Administration site is visble on the Settings > View Permissions for the Farms Administrators... How the other sites are permissionned?

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager



    • Edited by Felyjos Wednesday, December 26, 2012 5:06 PM
    Friday, December 21, 2012 10:19 PM
  • Hi,

    If you are able to open central admin then add your name as farm admin in admin group first. Then open the site as you mentioned above and see the permission of each site from site settings-->site permission. From central admin you can see the permission of site not for users so you have to open the site collection to see the permission of all users.

    Hope it could help


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    Monday, December 24, 2012 6:36 AM
    Moderator
  • Hello,

    I am already a farm admin so I will try this ...

    I can't go/open the site by its URL as I have no access so I am trying through Web Application > Select the URL > Site Collection List > Select the URL > SIte Actions > Site Settings > People And Group > View Site COllection Permissions ... I have only the Central Administration URLs displayed...

    Web Application > Select the URL > Site Collection List > Select the URL > Site Actions > Site Settings > Site Permissions... I have only Farms Aministrators Full Control on the Central Administration URLs ...

    but still not seeing the Site I need to have accesses...

    I tried on different sites but apparently I need to be Farms Administrators (Groups or Individual), Site Administrator(Individual ONLY) to be able to access the site!!! How all other users are accessing it if they are not in this pattern?

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager



    • Edited by Felyjos Wednesday, December 26, 2012 5:45 PM
    Monday, December 24, 2012 6:49 PM
  • Hi,

    Have you tried giving yourself access to the web application via a policy?

    Central Admin -> Application Management -> Policy for Web Application.

    Once in there add yourself with full control then navigate to the affected sites.

    At this point you should be able to access the sites permissions page and add proper access to users.


    Regards, Savoeurn Va Microsoft Online Community Support

    Sunday, January 6, 2013 8:14 PM
  • Hello,

    I added myself to Central Admin > Application Management > Policy Web Application

    I am Site Collection Administrators

    I am a Farm Administrators

    Full Control on Central Administrations

    SQL Permissions:(Same as Production)

    Public, sysadmin

    still not able to access the site !!!

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager


    • Edited by Felyjos Monday, January 7, 2013 4:58 PM
    Monday, January 7, 2013 4:54 PM
  • Hello,

    I have a URL aa.bb.cc.dd in Production and I have moved the enviroment (Restoration databases) to test with the same URL.

    I added IP local Test Server aa.bb.cc.dd in the hosts file and now If I ping the URL on the test server it replies properly.

    But when using IE I am getting "waiting for http://aa.bb.cc.dd for ever"

    I could click ok 3 times and it shows a blank page but no error.

    If I cleick Cancel same blank page and no error either!!!

    Any clue?

    Thanks,

    Dom


    System Center Operations Manager 2007 / System Center Configuration Manager 2007 R2 / Forefront Client Security / Forefront Identity Manager



    • Edited by Felyjos Friday, January 11, 2013 9:25 PM
    Friday, January 11, 2013 8:42 PM
  • It sounds like you're describing an authentication prompt if you are pressing OK three times or pressing cancel.

    In IE, check to make sure all of the proxy settings are unchecked. 


    Regards, Savoeurn Va Microsoft Online Community Support

    Monday, January 28, 2013 12:07 AM
  • Hi,

    Have you disabled the loopback check?

     

    1. Click Start, click Run, type regedit, and then click OK.
    2. In Registry Editor, locate and then click the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0

    1. Right-click MSV1_0, point to New, and then click Multi-String Value.
    2. Type BackConnectionHostNames, and then press ENTER.
    3. Right-click BackConnectionHostNames, and then click Modify.
    4. In the Value data box, type the host name or the host names for the sites that are on the local  computer, and then click OK.
    5. Quit Registry Editor, and then restart the IISAdmin service.

    -Ivan

     


    Ivan Sanders My LinkedIn Profile, My Blog, @iasanders, Business Intelligence in SharePoint 2013.

    • Marked as answer by Felyjos Friday, February 1, 2013 8:58 PM
    Monday, January 28, 2013 4:42 AM