none
Exchange 2016 with DPM2012 R2 - Error "Database is currently being backed up" RRS feed

  • Question

  • Hi all,

    We use DPM 2012 R2 to backup an Exchange 2016 DAG of 4 databases.

    Regularly, the backup failed with this error message on DPM :
    Backup failed as another copy of 'DB2' database is currently being backed up. (ID 32628 Details: Internal error code: 0x80990D51)

    At the same time on the concerned Exchange server, there is this error messages in the application logs :

    EventID 2140
    Source MSExchangeRepl

    The Microsoft Exchange Replication service VSS Writer encountered an exception in function Microsoft::Exchange::Cluster::ReplicaVssWriter::CReplicaVssWriterInterop::PrepareSnapshot. HResult -2147467259. Exception Microsoft.Mapi.MapiExceptionDatabaseError: MapiExceptionDatabaseError: Unable execute Prepare on snapshot. (hr=0x80004005, ec=1108)


    Then there is another error message on Exchange server at the same time :
    Event ID 2026
    Source : MSexchangeRepl
    The Microsoft Exchange Replication service VSS Writer (Instance 99cd0e02-c148-41f6-8fb5-0e82b18cd6d7) failed with error 80004005 when preparing for snapshot.

    Then the backup job on DPM wait during one hour without transfering any datas. And finally the backup job failed with the aforementioned DPM error message

    This issue not happens on every schedule or every server. Usually after I see this error, I do a "resume disk backup", which works well... and later the job fails again

    I tried to monitor the value "BackupInProgress" of the Exchange databases, this value never change even during the backup

    DB sizes :
    DB1: 800GB
    DB2: 1100GB
    DB3: 30GB
    DB4: 650GB

    The DB3 never had this issue...

    I tried different schedule, always same issue (6hours synchronization, 12h synchronization, synchronization juste before recovery point). So the last scheduled backup always has the time to finished before there is another one. Usually a backup duration is between 5 or 8 hours for the biggest database

    Well then... Does anyone has an idea how can we solve this issue... ?

    Many thanks for your help

    P.S. Already posted this issue in Exchange forum, they suggest me to post here sorry :)
    https://social.technet.microsoft.com/Forums/office/en-US/55e10460-3e40-4bea-9b64-6185a1c16f95/backup-exchange-2016-databases-with-dpm2012-r2-failed

    Wednesday, December 14, 2016 6:51 AM