locked
NV Cache RRS feed

  • Question

  • I have a new Dell Inspiron 1720 with 1GB Intel Turbo Boost memory as recognized and enabled in BIOS.  I have enabled "Readydrive" and "Readyboost" in the Intel Turbo Boost memory control panel. However, when I look at the hardware device settings for my hard drive, in the NV Cache Tab I get this message:

    "This device has 387 MB of NV (non volatile) cache and can help
    improve
    system performance. If using this disk as a Hybrid Hard Disk
    is enabled, the disk can provide power savings and optimize the boot
    and resume times of the
    system.

     

     The use of this disk as a Hybrid Hard Disk can be turned on or off

    by the group policy administrators."


     I've turned on Readyboost and Readydrive. Am I getting the advantage of that 387MB NV Cache, despite this the message? Is
    there a way to know if it is activated?

    I am using the OEM factory installed Vista Home Premium edition (32bit).  It does not come with GPMC.MSC ('group policy administrator) nor will it install.  It gives me a message that it cannot install on XP Home Edition???  So how do I change that setting?  Does this mean my Hybrid Hard Disk Device is dead in the water because of this “Catch 22”?

     

    Friday, January 11, 2008 7:13 PM

Answers

  • Hello Anntron,

     

    Thanks for your post and sorry for reply delay!

     

    ReadyDrive is the software in Windows Vista that supports hybrid hard disk drives (H-HDD). An H-HDD is a traditional hard disk drive with integrated nonvolatile (NV) flash memory that acts as a high performance cache for writes and low-latency reads.

     

    If your Intel Turbo Boost memory can perform this feature as NV flash memory. You may use the following step to confirm whether it is active:

     

    1.   In Device Manager, expand the Disk drives node.

    2.   Right-click the flash disk item and select Properties.

    3.   You may check the feature in Policies tab.

    For the group policy object that can enable or disable NV cache, you may check it using the following steps:

     

    1.   Click Start icon, and then click Run…

    2.   Type gpedit.msc and press Enter. Click Continue if receiving UAC prompt.

    3.   You can find the group policy object in the path: Computer Configuration – Administrative Templates – System – Disk NV Cache.

    For more information about ReadyBoost, ReadyDrive and SuperFetch technologies, please refer to the following document:

     

    Windows PC Accelerators

    http://www.microsoft.com/whdc/system/sysperf/perfaccel.mspx

     

    Thanks!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Tuesday, January 15, 2008 10:04 AM

All replies

  • Hello Anntron,

     

    Thanks for your post and sorry for reply delay!

     

    ReadyDrive is the software in Windows Vista that supports hybrid hard disk drives (H-HDD). An H-HDD is a traditional hard disk drive with integrated nonvolatile (NV) flash memory that acts as a high performance cache for writes and low-latency reads.

     

    If your Intel Turbo Boost memory can perform this feature as NV flash memory. You may use the following step to confirm whether it is active:

     

    1.   In Device Manager, expand the Disk drives node.

    2.   Right-click the flash disk item and select Properties.

    3.   You may check the feature in Policies tab.

    For the group policy object that can enable or disable NV cache, you may check it using the following steps:

     

    1.   Click Start icon, and then click Run…

    2.   Type gpedit.msc and press Enter. Click Continue if receiving UAC prompt.

    3.   You can find the group policy object in the path: Computer Configuration – Administrative Templates – System – Disk NV Cache.

    For more information about ReadyBoost, ReadyDrive and SuperFetch technologies, please refer to the following document:

     

    Windows PC Accelerators

    http://www.microsoft.com/whdc/system/sysperf/perfaccel.mspx

     

    Thanks!

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Tuesday, January 15, 2008 10:04 AM
  • Lionel,

    Thank you for your reply.  I read the document you recommended and it was very helpful in understanding how NV cache is implemented.  However, you suggested I use gpedit.msc to enable disk NV cache.  Unfortunately, that is part of my problem:

     

    I am using the OEM (Dell) factory installed Vista Home Premium edition (32bit).  It does not come with GPMC.MSC ('group policy administrator) nor will it install.  It gives me a message that it cannot install on XP Home Edition???  So how do I change that setting?  

     

    No gpedit.msc either!

     

    Is there a remedy or do I need to upgrade Vista?

     

    thanx,

    ron


     

    Friday, January 18, 2008 3:56 PM
  • Hello Ron,

     

    Thanks for your feedback!

     

    As ReadyDrive is a feature included in Windows Vista Home Premium, it is enabled automatically if the H-HDD has passed the performance assessment. In other words, you needn’t use group policy to enable it manually.

     

    If I misunderstood your concern, please let me know. I’m happy to be of further assistance.

     

    Regards,

    Lionel Chen

    Microsoft Online Community Support

     

    Tuesday, January 22, 2008 2:54 AM
  • I have Windows Vista Ultimate 64 bit on my Asus Lamborghini VX2S laptop.

     

    Windows Readydrive is NOT enabled, boot times can take up to ten minutes

     

    I have used the Intel Turbo Memory console, and the option to enable readydrive is greyed out and not checked.

     

    This would imply that it is not working, in the sane world, anyway.

     

    There is no way I have been able to find a way to verify that it is working or that it is possible to MAKE it work.

     

    What do I need to do to make it work?

     

    I have disabled the Group Policy things that make it NOT work, which used to not be configured at all, but I don't know that this will make it actually WORK.

     

     

     

    Wednesday, July 16, 2008 2:19 PM
  • Hi.
    I recently purchased a new laptop that came with XP Pro pre-installed. I created a 2nd primary partition and installed Vista Ultimate 64-bit on that new partition.
    I then installed an Intel Turbo Memory card and downloaded the Intel driver (in Vista), then ran the Intel Turbo Memory program.
    The ReadyBoost option showed up as already enabled but the ReadyDrive option was greyed out.
    To cut a long story short - I edited the registry (see support.microsoft.com/kb/922976) and changed the AHCI driver value to 0, then in BIOS (with Vista set as the main system) I enabled AHCI rather than IDE, which in turn enabled "Robson" - Turbo Memory. (If BIOS set as AHCI but without AHCI drivers enabled, this results in a "BSOD"!).
    On rebooting I re-installed Intel's Turbo Memory driver, which then downloaded a whole different set of drivers amd made certain other updates.
    On re-booting and re-running the Intel Turbo Memory program, both the ReadyBoost and ReadyDrive options were available, and the ReadyBoost option was already ticked.
    However when I tick the "enable ReadyDrive" option and re-boot, ReadyBoost stays enabled but ReadyDrive becomes disabled again although the option still shows as available rather than being greyed out.
    Not sure how to fully enable ReadyDrive.
    2 steps forward.........
    Wednesday, December 10, 2008 10:44 AM