none
Cannot Set IE 11 as Default Browser in Windows 10 RRS feed

  • Question

  • We have Windows 10 Pro on a laptop.  We want to set the default browser to Internet Explorer 11 (rather than the default, Edge).  I am familiar with the process of setting "Default apps" in Settings/System in Win 10.  When I choose "Web browser," I see Internet Explorer as an option.  When I choose IE by clicking on it in the "Choose an app" window, the change does not occur.  The Default apps screen still shows Microsoft Edge as the default browser.  I should note that the same thing happens when I try to select "Outlook 2016" as the default email program on this screen (nothing changes).

    Thanks for any help you can offer with this frustrating problem.


    John

    Friday, July 1, 2016 3:53 PM

Answers

  • Hi JN92,

    According to your description, do you have changed some settings recently? I suggest that we could start in Clean Boot to avoid the effects of third party software and temporarily turn off security software. Then we could install the latest Windows Updates and check if this helps in resolving the issue.

    If the error insists, we could try use the command “sfc /scannow” to repair system files or run DISM to check.

    Open command prompt by pressing Windows key + X and selecting “Command prompt admin”.

    In command prompt, type the following commands and press Enter after each command:

                    DISM.exe /Online /Cleanup-image /Scanhealth

                    DISM.exe /Online /Cleanup-image /Restorehealth

    Close the command prompt and restart the PC and check if it works.

    If these steps don’t work, does your system have a restore point? I suggest that we could try system restore.

    Hope it will be helpful to you


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Monday, July 4, 2016 6:57 AM
    Moderator

All replies

  • I was able to get this to "stick" (IE 11 as default browser) by going through the old Control Panel/Default Programs process.  I selected Internet Explorer as the default there, and it finally showed up in the Settings/system/Default Apps section.  I was not able to make the change directly there in Default Apps, however.  I had to use the time-honored Control Panel method.

    John

    Friday, July 1, 2016 4:20 PM
  • Hi JN92,

    According to your description, do you have changed some settings recently? I suggest that we could start in Clean Boot to avoid the effects of third party software and temporarily turn off security software. Then we could install the latest Windows Updates and check if this helps in resolving the issue.

    If the error insists, we could try use the command “sfc /scannow” to repair system files or run DISM to check.

    Open command prompt by pressing Windows key + X and selecting “Command prompt admin”.

    In command prompt, type the following commands and press Enter after each command:

                    DISM.exe /Online /Cleanup-image /Scanhealth

                    DISM.exe /Online /Cleanup-image /Restorehealth

    Close the command prompt and restart the PC and check if it works.

    If these steps don’t work, does your system have a restore point? I suggest that we could try system restore.

    Hope it will be helpful to you


    Please mark the reply as an answer if you find it is helpful.

    If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Monday, July 4, 2016 6:57 AM
    Moderator
  •  not able to make the change directly there in Default Apps, however.  I had to use the time-honored Control Panel method.

    That seems normal to me, especially if you mean you used the  Set Program Access and Computer Defaults  there.  That is the only part which has ever actually fixed anything in this regard.  E.g. the rest just try to relink using the existing settings and therefore cannot fix broken ones.

    HTH



    Robert Aldwinckle
    ---

    Tuesday, July 5, 2016 4:04 PM
    Answerer