none
DHCP Dynamic DNS Update issue? RRS feed

  • Question

  • Hello,

    We have 3 Windows Server 2008 R2 Domain controllers running DHCP and DNS each server handles different DHCP scopes and then should update our RLZ and FLZ in the shared DNS.  We have our DHCP checked to Enable DNS dynamic updates according to the settings below then Enable Name Protection selected.  We have our DNS dynamic updates set to Secure Only and scavenge scale resources after 7 days.  We followed a guide when setting this up which recommended these settings along with adding each server to the DNSUpdateProxy group.  I have computer that was freshly imaged at one building that server1 handles DHCP on.  Then the PC is taken to a different building handled by a different DHCP server3 and the FLZ does not update but the RLZ does.  If I look at the server DHCP or DNS events nothing points to any problems.   Any ideas on what might be happening or something we can try to figure out the issue?

    We have tried changing our DNS records to update secure and non-secure with various different DHCP check boxes selected.  If we go to that other extreme we do always get a FLZ update but we tend to have duplicates which is not favorable.

    Thanks in advance for any advice.

    Friday, March 13, 2015 9:32 PM

Answers

All replies

  • Hi,

    First, please try to run ipconfig /registerdns on the client. Then we can check if the FLZ is updated.

    If the client can register the DNS record, please try to configure the credential for DNS registration on DHCP server.

    For detailed information, please refer to the link below:

    http://blogs.technet.com/b/stdqry/archive/2012/04/03/dhcp-server-in-dcs-and-dns-registrations.aspx

    Best Regards.


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, March 17, 2015 1:27 AM
    Moderator
  • Steven,

    Thank you for the reply.  I was able to update the FLZ by running ipconfig /registerdns on the workstation.  I then went into the server and the credentials for the DNS registration on the DHCP server was already set but I re-typed the password so I will see if the problem persists.

    Thanks again for your reply.

    Wednesday, March 18, 2015 3:45 PM