locked
Changed the public URL for a web application and now Reporting Server integration is not working RRS feed

  • Question

  • After changing the public URL for a Web Application, how do you also change the URL for the paths under the Reporting Web Service.   The collections paths under https://hostname/ReportServer still have the old hostname.  The Report Library web parts are using the new hostheader name when making calls to the report server web service.  As a result I get the following error when I select a data source from the report library.  When I switch back to the old public URL, it works again.

    The item 'https://hostname.domain.com/dept/demo/Report Library/test.rsds' cannot be found. ---> Microsoft.ReportingServices.Diagnostics.Utilities.ItemNotFoundException: The item 'https://hostname.domain.com/dept/demo/Report Library/test.rsds' cannot be found.

    Thanks!!

    Wednesday, March 23, 2011 7:49 PM

Answers

All replies

  • Hello mikea730,
     
    Thank you for your question.

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay. Appreciate your patience.
     
    Thank you for your understanding and support.

    Friday, March 25, 2011 2:22 AM
  • Hi mikea730,

    After discuss this question with my colleague, We have a few questions for you.
    1.) Can you browse to the site using the new host header?
    2.) Is the new URL Registered?
    3.) Are there any duplicates?

    In addition:
    the new host header needs to be in default zone or this will not work.

    Also we found a few link on setting up and configuring the Reporting services .

    How to: Configure a URL (Reporting Services Configuration): http://technet.microsoft.com/en-us/library/bb630447.aspx
    Configuring Report Server URLs: http://technet.microsoft.com/en-us/library/ms159261.aspx
    How to: Configure Report Server Integration in SharePoint Central Administration: http://technet.microsoft.com/en-us/library/bb326213.aspx

    • Marked as answer by Wayne Fan Sunday, April 3, 2011 9:47 AM
    Wednesday, March 30, 2011 6:41 AM
  • I restarted all the servers in the farm (not just reporting services) and now the paths for /ReportServer have updated!  Thanks again for your help!!
    • Marked as answer by Wayne Fan Sunday, April 3, 2011 9:47 AM
    Friday, April 1, 2011 6:49 PM