locked
Unable to access SharePoint via VPN when using a home computer but ok when using work laptop RRS feed

  • Question

  • I have posted about this issue before regarding accessing SharePoint via VPN from a home computer and someone suggested that the issue might be with VPN or network. The strange thing is that I am able to access SharePoint via VPN from work laptop, but when I connect to VPN from my personal laptop and try to access SharePoint I get the message "Internet Explorer cannot display this webpage". Also, if I try to access the SharePoint site using the IP address of the server, I get a login windows and I login using domain\username and my password and I get page "Oops! Internet Explorer could not find ibsharept".

    From my home laptop I am able to ping the server using the IP address but not using the server name, while from work laptop at home via VPN I am able to ping server using both IP and name.

    I am the Admin and I am not able to figure out the problem. I am not sure if the issue with trust or network or something else since I am able to access it from work laptop when at home via VPN.

    I really appreciate if someone can assist in this matter.

    Thanks....B

    Wednesday, May 18, 2011 1:06 AM

Answers

  • It should be semi-permanent, as long the entry stays in your hosts file it should keep working.

    It's not a true fix though, you may run into the same problem with other applications which need DNS to find servers on your work LAN, or with other users laptops from home etc. So when you have a chance you should try and look into the underlying DNS resolution problem, solving that would be the better solution.

    • Marked as answer by Peng Lei Thursday, May 26, 2011 2:01 AM
    Monday, May 23, 2011 1:58 PM

All replies

  • Hi Bluem1,

     

    From your description of the issue, my assumption is that the problem is on the settings of your VPN or IE browser. It seems that it is not related with SharePoint.

     

    My suggestion is, first, make sure the setup of your VPN is correct, you can follow this article to check depends on your Operating System:

    http://compnetworking.about.com/od/vpnsetup/VPN_Setup_How_to_Set_Up_a_VPN.htm.

     

    And, according to the error message, another possible reason may be the incorrect IE settings. You can go through this article and try the solutions there, maybe this could help you to solve this issue:

    http://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/oops-internet-explorer-could-not-find/3d0f009d-0dae-4831-a078-5b898ce5e238.

     

    Thanks & Regards,

    Peng Lei

    Wednesday, May 18, 2011 8:17 AM
  • I suspect it's a DNS issue since you seem to be able to hit the server via IP address but not via name.

    I'm guessing that if your work laptop normally lives on your work LAN that it has either cached the name/IP of the sharepoint server, or it knows to use the DNS server on your work LAN while your home laptop either hasn't got it cached or doesn't know to use the DNS server on your work LAN.

    To do a test fix for this should be pretty easy, on your home laptop put an entry in the hosts file (c:\windows\system32\drivers\etc\hosts) to map the SharePoint server's hostname to it's IP. Close and reopen IE if it's open. You should now be able to ping the SharePoint server via it's hostname. Then try browse to your SharePoint site (with the normal URL, not the IP) and see if that works.

    If that all works you probably need to setup your DNS settings, depending on your VPN software you'll be able to do this either through the VPN software itself, or by editing the network connection it uses in Windows.

     

    By the way, typically browsing to a SharePoint site via IP address won't work, SharePoint relies pretty heavily on being able to recognise the URL that you access it with so that it can identify which web application and content you are trying to use, and to generate links and URLs that you see in pages. Your request will make it as far as IIS, which is smart enough to realise that you are accessing a site which requires authentication, but without a recognised URL it can't hand it off to SharePoint correctly. You can confgure Alternate Access Mappings which are extra URLs that SharePoint will recognise and work with, so you can create one to use the IP as the URL but by default this won't be enabled.

    Thursday, May 19, 2011 10:08 AM
  • We currently use the VPN feature built within Windows 7 and XP and I have setup a Windows 2003 to act as my VPN Server...not sure if that makes the different, but it is strange that I am able to access SharePoint from home using work laptop when connecting my VPN connection.

    I have setup my VPN server to hand out IP address in the range of XX.XX.XXX.245 to XX.XX.XXX..255, but when I connect from my home computer via VPN I open my DNS and DHCP on the server and I don't see the ip address assigned or listed.  Not sure if this make a difference.

    I will try the suggestions above and report back.

    Thanks...B


    Friday, May 20, 2011 8:11 PM
  • In reply to the suggestions:

    - I checked my VPN settings and they are correct

    - I did reset my IE setting on my home computer and made sure the IE settings are similar to the work laptop and still could not access SharePoint from home computer.

    - I added the SharePoint name and IP address to hosts file on my home computer and I am able to ping the SharePoint server via name. after I made this change I was able to access SharePoint site from my home computer. I was presented with login window and I typed my login as follow domain\username.

    Hopefully this is a permanent fix.

    Thanks...B

    Monday, May 23, 2011 3:00 AM
  • It should be semi-permanent, as long the entry stays in your hosts file it should keep working.

    It's not a true fix though, you may run into the same problem with other applications which need DNS to find servers on your work LAN, or with other users laptops from home etc. So when you have a chance you should try and look into the underlying DNS resolution problem, solving that would be the better solution.

    • Marked as answer by Peng Lei Thursday, May 26, 2011 2:01 AM
    Monday, May 23, 2011 1:58 PM