none
I am getting Replica Inconsistent on one cluster same VMH host 3106 RRS feed

  • Question

  • I have had an issue for awhile now with no results in fixing it, I have called MS direct and they said to add more storage I did that and still same result

    I am getting Replica Inconsistent on  on host in a cluster, I have added and merged the xml files into the dpm from the host

    here is the error I get

    :

    Affected area: \Backup Using Saved State\MS002
    Occurred since: 10/8/2012 8:44:11 AM
    Description: The replica of Microsoft Hyper-V \Backup Using Saved State\MS002 on MS002.VMHC002.webhostingprovider.com is inconsistent with the protected data source. All protection activities for data source will fail until the replica is synchronized with consistency check. You can recover data from existing recovery points, but new recovery points cannot be created until the replica is consistent.

    For SharePoint farm, recovery points will continue getting created with the databases that are consistent. To backup inconsistent databases, run a consistency check on the farm. (ID 3106)
     Failed to prepare a Cluster Shared Volume (CSV) for backup as another backup using the same CSV is in progress. (ID 32612 Details: Back up is in progress. Please wait for backup completion before trying this operation again (0x8007173D))
     More information
    Recommended action: If you are using software VSS providers, we recommend that you use hardware providers. For more information go to [http://go.microsoft.com/fwlink/?LinkId=179952] .
    If hardware VSS provider is already installed on the node, check the status of CSVs used by this virtual machine from the Cluster Administration Console and re-enable direct I/O for the CSV. Then retry the operation.
     Synchronize with consistency check.
     Run a synchronization job with consistency check...

    I have run many consistency checks and still get this error

    None of the replicas have any creation point either

    Thursday, October 11, 2012 4:19 PM

All replies

  • If you are using a Hardware VSS provider, you should add the following registry key on one of the nodes to force the System Software VSS provider to be used for testing purposes.

    [Software\Microsoft\Microsoft Data Protection Manager\Agent\UseSystemSoftwareProvider]

    Rerun the backup of a VM that is owned by the node where the registry key was added.

    Have you seen KB article 2549533 - "Using System Center Data Protection Manager 2010 to perform a host level backup fails with error 0x8007173D" at http://support.microsoft.com/kb/2549533?

    The following steps should also be tested.

    If you believe you have serialization enabled properly, check the %programfiles%\Microsoft DPM\DPM\Config\DataSourceGroups.xml file on the DPM server for special characters like & character.  The easiest way to accomplish that is to open the DataSourceGroups.xml file using Internet Explorer - there should be no errors.

    Regardless if using hardware or software snapshot provider , the following registry settings allow you to make adjustments to how DPM performs retries to claim the CSV in order to get reliable backups.

    CsvMaxRetryAttempt - Adjust the maximum number of times (Default is 1) the DPM agent will attempt to claim the CSV volume. The value 0xC8 = 200 times.
    CsvAttemptWaitTime - Adjusts the amount of time in milliseconds to wait between retry attempts.  The value 0x2bf20 = 3 minutes.


    1) Copy the following in notepad, then save the file as csvretry.reg


    Windows Registry Editor Version 5.00
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft Data Protection Manager\Agent\CSV]
    "CsvMaxRetryAttempt"=dword:000000C8
    "CsvAttemptWaitTime"=dword:0002bf20

    2) Copy the csvretry.reg file to each node in the cluster.

    3) Logon to each node in the cluster as an administrator, then right-click the csvretry.reg file and select "open with" - then "Registry Editor" option to import the registry settings.

     --------------------------------------------------------------------------------
     Regards, Michael V [MSFT] - This posting is provided "AS IS" with no warranties, and confers no rights.


    -------------------------------------------------------------------------------- Regards, Michael V [MSFT] - This posting is provided "AS IS" with no warranties, and confers no rights.

    Tuesday, November 13, 2012 9:41 PM
    Moderator