locked
Exception from HRESULT: 0x80004004 Error when trying to Edit List Properties - SP2007 RRS feed

  • Question

  • I am running SharePoint 2007 with two Load balanced front end servers and a single SQL Server (SQL2005) on the back end. 

    I am trying to edit the properties of a List (Advanced Setting) and when I hit save get the following Error:

    Operation aborted (Exception from HRESULT: 0x80004004 (E_ABORT))

    I thought it was just that list so I tried the same thing on several other lists and had the same Error.

    So I tried to change other list properties (Versioning Setting) and got an Error of "Cannot Complete this operation"

    If I try to Edit (Title, description and navagation) by changing if the List shows in the Quick Launch I get the same 0x80004004 Error.

    The only changes made to the Farm recently were the deletion of two old site that we had not used in over 2 years and weekly Maint plans that run to rebuild Indexes and Statsicts.

    I have checked the Drive space on the SQL Data and Logs and both have over 25% free.

    Any insight is appreciated.

    ----

    Update:  3/28

    In our Farm I ran the Config Wizard on one of the Web Servers with the other one disabled in NLB and once it was done the Error went away.  I then tried to update the other Web Server and the Wizard failed and the error came back.  Thinking I might have an out of sync Farm and need to run updates on all Servers.  Found this article on that.  Still not sure what the exact challenge is.

    http://technet.microsoft.com/library/cc288269(office.12).aspx#section4d


    Jason B Hand


    • Edited by JasonBHand Wednesday, March 28, 2012 8:53 PM
    Tuesday, March 27, 2012 6:12 PM

All replies

  • Hi JBH3812,

    This is not actually a SharePoint issue but more a SQL issue...usually a result of the transaction log being full or no drive space available to it.
    To view the log information use DBCC LOGINFO('[dbName]')
    To fix the issue above, use the following code to reduce the size of the transaction log (replacing the items in square brackets with your variables - [dbName]):

    use [dbName]
    go
    BACKUP LOG [dbName] TO DISK = N'[driveLetter]:\SQL Backup\[backupName].trn'
    WITH NOFORMAT, NOINIT, NAME = N'[dbName]-Transaction Log Backup', SKIP, NOREWIND, NOUNLOAD, STATS = 10
    GO
    
    DBCC SHRINKFILE (N'[dbLogFileName]' , 0, TRUNCATEONLY)
    GO
    
    DBCC LOGINFO('[dbName]')
    
    
    For more information, please refer to the following links:
    http://www.calvinirwin.net/2009/07/26/operation-aborted-exception-from-hresult-0x80004004-e_abort/
    http://social.msdn.microsoft.com/Forums/da-DK/sharepointecm/thread/0f7245b3-13e5-403a-bed4-53fc89cfce12

    Thanks,
    Lhan Han
    Friday, March 30, 2012 9:21 AM
    Moderator
  • Lhan

    Thanks for the post.  I looked at my transaction logs and they appear fine.  All of the Logs for this SQL Server sit on a dedicated drive in our SAN and they are currently using 8GB out of 53 GB avaliable Drive Space.  My Log file for the WSS_Content DB is 253MB and is set to auto grow at 10% with a 2 TB limit so that is again no where close.  In addition we run nightly backups using DPM and the Log files are all updated at that time.

    I saw another post that mentioned something about Windows System Updates causing an Issue and having to run the SP Config Wizard to fix it.  In my case we have a 3 server farm and when I ran the Wizard on one server it temporarly solved it them came back on the next.  I have sense discovered that I need to install some more updates to have the Wizard run successfully.  If that solves it I will note such here.

    In the mean time do you have any other ideas?

    Thanks

    Jason


    Jason B Hand

    Tuesday, April 3, 2012 12:29 AM