none
Excessive Memory Usage IE11 RRS feed

  • Question

  • I'm running Windows 7x64 on a Toshiba laptop, third-generation i3 processor, 16 GB. I'm having problems with Internet Explorer 11 not releasing memory and closing tasks. It keeps building up to the point where Internet Explorer freezes and I have to either close it completely or use process Explorer to kill some of the erroneous tasks.

    I've tried running IE 11 without any add-ons and I have the same problem. I've also completely remove IE 11 all the way back to the base IE 8 that comes with Windows 7 and install everything from their up and still have the same problem.

    Here's a link to a screenshot of what it looks like in process Explorer: https://www.dropbox.com/s/brhcwsk8v7zlq1l/IE%2011.JPG?dl=0

    Any other ideas what I can trying to solve this problem?

    Saturday, December 20, 2014 11:07 PM

All replies

  • Hi,

    the first trouble shooting step is to test in noaddons mode...

    or

    using tasks manager identify any unknown tasks (like googleToolbarupdater.exe) and killing them.

    possibly it could be your Advanced settings for "Use software rendering instead of GPU rendering"

    Regards.


    Rob^_^

    Monday, December 22, 2014 12:18 AM
  • I've already done that and all the other normal things for problems like this.  As I said in my original post I've also completely reinstalled IE 11 taking Windows7 back to its base of IE 8.  I've also actually tried a repair install of Windows 7 also to see if that helps the problem.

    I've also run Malwarebytes and Norton Eraser in addition to having my base Norton Internet Security always active.  I even tried removing it and installing Kaspersky Pure3.0 to see of changing security software made any changes and it didn't.

    Whatever is causing the problem with something very unusual and not simple.

    Monday, December 22, 2014 12:24 AM
  • Hi,

    Have you tried to reset the Internet Explorer for test?

    1.Close all Internet Explorer windows that are currently open.

    2.Open the desktop, and then tap or click the Internet Explorer icon on the taskbar. Changing your settings will affect both Internet Explorer and Internet Explorer for the desktop.

    3.Tap or click the Tools button, and then tap or click Internet options.

    4.Tap or Click the Advanced tab, and then tap or click Reset.

    5.In the Reset Internet Explorer Settings dialog box, tap or click Reset.

    6.When Internet Explorer finishes applying default settings, tap or click Close, and then tap or click OK. You'll need to restart your PC for these changes to take effect.

    If it persists, perform a Clean boot to see if any third-party software or service conflict:

    How to perform a clean boot in Windows

    https://support.microsoft.com/KB/929135?wa=wsignin1.0 


    Karen Hu
    TechNet Community Support

    Tuesday, December 23, 2014 9:43 AM
    Moderator
  • Karen, thanks for the ideas.  I'd already tried resetting everything within IE 11 but I did it again anyway.  I actually forget if I had done a clean boot or not so I went and tried it again.  Unfortunately, I still am having the same problem!

    Obviously, whatever is causing the problem is very strange and unusual.  I certainly tried everything I can think of and what my friends have come up with with no improvement.

    If you have any more ideas please let me know, I'm more than willing to try them!

    Tuesday, December 23, 2014 7:22 PM
  • Hi,

    It sound really so odd. Let's trace its activity for analysis.

    Follow this guide to get the trace log:

    Troubleshooting High CPU Utilization issues using Tracelog.exe

    http://blogs.technet.com/b/askperf/archive/2012/01/20/troubleshooting-high-cpu-utilization-issues-using-tracelog-exe.aspx


    Karen Hu
    TechNet Community Support

    Friday, December 26, 2014 3:04 AM
    Moderator
  • Karen, I can't get the trace log to run.  I'm posting the image of what I get when I tried to run it below.  I checked however and the file does not exist anywhere in my computer!

    Saturday, December 27, 2014 7:21 PM
  • Hi,

    You need to download the Process Explorer application to do this:

    Process Explorer v16.04

    http://technet.microsoft.com/en-us/sysinternals/bb896653


    Karen Hu
    TechNet Community Support

    Tuesday, December 30, 2014 6:38 AM
    Moderator
  • I already had Process Explorer downloaded when I tried running the test of the first time.  I went ahead and downloaded again and had it running and tried everything again.  I still get the same error as I posted above that the file already exists although it actually doesn't.  Just for the fun of it I tried running the analysis routine (

    tracerpt test.etl -report dpcisr.html -f html) and it could find the file either.

     

    Any idea why I can't get tracelog to run?

    Can I be possibly using the wrong tracelog.exe?  I find it five places on my computer, the screen capture below shows the five places.  Which one should I be using?


    • Edited by Msradell Wednesday, December 31, 2014 12:26 AM
    Wednesday, December 31, 2014 12:16 AM