locked
"this website has been configured to disallow editing with sharepoint designer" RRS feed

  • Question

  • Hi,

    Recently upgraded my WSS3.0 farm to Foundation 2010; the upgrade happend without any major drama however I am unable to open any site in Sharepoint Designer 2010, I get the "Web Site Editing is Disabled" / "this website has been configured to disallow editing with sharepoint designer" message.

    I checked the usual suspects: ONET.XML, permissions and the "SharePoint Designer Settings" in 2010 Central Admin, they are all fine, I cannot explain this problem.

    I tried on another Sharepoint Foundation front end, one that I installed from scratch (no upgrade) and it works fine.

    Has anyone encountered this issue?

    Cheer, Vincent

     

    Wednesday, April 28, 2010 11:53 PM

Answers

  • Hi Eric,

    I am afraid, I was doing something really silly, I upgraded my WSS 3.0, ensured all the settings to allow Designer were set but forgot to upgrade SharePoint Designer itself!

    I kept getting the error simply because I wasn't using the right SD :(

    V

     

    • Marked as answer by Clayton Cobb Monday, November 15, 2010 4:27 PM
    Friday, May 28, 2010 2:35 AM

All replies

  • Hi Vincent,

    You checked in the correct places. What kind of template is the upgraded site (publishing, team site, project site, etc)? Were you able to open the site in SPD 2007 before the upgrade?

    One last place to check if you're not a site collection admin is the "SharePoint Designer Settings" for the site collection itself (http://collection/_layouts/SharePointDesignerSettings.aspx).

    Hope you're able to solve this soon!

    Kolby

    Friday, April 30, 2010 12:11 AM
  • HI Kolby,

    Yup, before the upgrade I could use SPD, also I have full control on the box.

    Checked the SharePoint Designer Settings", designer is ticked but still can't use sharepoint designer anywhere; whatever is preventing, it is at the farm / server level.

    Thx, Vincent

     

    Monday, May 3, 2010 10:58 PM
  • You said you checked in Central Admin, but did you check specifically at the web application level?
    SharePoint Architect || Microsoft MVP || My Blog
    Wednesday, May 5, 2010 6:59 AM
  • I'm also having the same issue.  Migration from WSS3.0 to Foundation 2010.  Checked the Edit in Designer settings and still get the message.
    Eric
    Friday, May 28, 2010 12:28 AM
  • Hi Eric,

    I am afraid, I was doing something really silly, I upgraded my WSS 3.0, ensured all the settings to allow Designer were set but forgot to upgrade SharePoint Designer itself!

    I kept getting the error simply because I wasn't using the right SD :(

    V

     

    • Marked as answer by Clayton Cobb Monday, November 15, 2010 4:27 PM
    Friday, May 28, 2010 2:35 AM
  • I'm also having the same problem. I have full rights, am a collection admin, we have SP server 2010 and designer 2007, and we upgraded from WSS3.0. Is the problem that we're using designer 2007? The old version of designer is not compatible with the new version of sharepoint?
    Friday, June 11, 2010 2:08 PM
  • You can only use SPD2010 with SP2010 sites. 

    http://www.microsoft.com/downloads/details.aspx?FamilyID=eeda9ab1-ac53-4870-9e1c-38940343d677&displaylang=en

    Note:
    SharePoint Designer 2010 only connects to SharePoint 2010. To connect to SharePoint 2007 and earlier sites you must continue to use SPD 2007 . If you elect to install both applications side-by-side, you must download the 32-bit version of SPD 2010. Please also note that 64 bit Office applications will not run if SPD 2007 is installed; 64bit Office 2010 applications should only be used if not connecting to SharePoint 2007 servers.

    I have SP2007 installed in my XPMode VM. If you need to install on your system, then the 32 bit product has to be uninstalled.  When you have all of your 64 bit products installed you can reinstall SPD 32 bit.


    Heather Waterman SharePoint Desginer www.heatherwaterman.com
    • Proposed as answer by Davide4 Monday, November 15, 2010 11:01 PM
    Friday, June 11, 2010 2:44 PM
  • Hi Vincent,

    did you make some progress? I have the same issue: it seems that upgraded sites (from Sharepoint 2007 to 2010) are still connected to SPD 2007 and are not editable with SPD2010. This not depend from Central Admin or site settings, it seem that somewhere the site is recognized as V3...

    Davide


    Davide Michelotto
    Monday, November 15, 2010 9:35 AM
  • My issue is solved, it was client side... I have SPD2007 and SPD2010 installed side by side and Sharepoint Designer 2007 was still caching path to my Sharepoint Server, so when I was opening SPD from the upgraded server I had the error.

    I uninstalled SPD2007 and my server now point to the right SDP2010.

    Davide


    Davide Michelotto
    Monday, November 15, 2010 3:26 PM
  • You don't have to uninstall SPD 2007.  YOu just need to open SPD 2010 and connect from there instead of invoking the connection from the site.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, November 15, 2010 4:28 PM
  • Hi Clayton, let me explain better:

    when I was trying to open the the Sharepoint Server 2010 site directly from SPD2010 I had an error and the other SPD2007 was opening automatically (obviously giving me an error).

    At the same time when I was trying to open SPD from the browser (site action - open in SPD2010) I received an error.

    The issue was on my client cache (in a webcache folder somewhere under %userprofile%) that was "driving" the sharepoint url to SPD2007 (working until the server upgrade).

    I suppose the problem could be solved by cleaning that cache but it was faster for me to uninstall the SPD2007. Hope this is more clear. Thanks for your help.


    Davide Michelotto
    Monday, November 15, 2010 4:54 PM
  • That's not clear to me.  I don't see how opening SPD2010, clicking Open Site, and typing in the URL could somehow invoke SPD2007.  I have run both in parallel on multiple machines for over a year, and that has never happened.  The other direction always messes up (opening from the SharePoint site) unless I already have SPD2010 open, because then it knows to default to SPD2010.  If I have no SPD instances open, and click on Edit in SPD, it defaults to SPD2007 regardless of my browser settings.  So, I just invoke from SPD2010 or make sure it's already open.

    I'm very familiar with the web cache and know how to modify it, but that doesn't affect the method I mentioned.  Were you clicking on an existing link instead of using Open Site?


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, November 15, 2010 4:57 PM
  • Ok, this are the facts:

    Starting from server (this happened immediately after Sharepoint Server inplace upgrade):

    When I clicked on Site Action to open SPD I had no instances of SDP 2007 or 2010 opened. The first time I had this error: “this website has been configured to disallow editing with sharepoint designer”. I checked settings on CA and site and all was ok. After that I tried opening from SPD2010 client.

    Starting from client:

    The exact operation I did from SPD2010 was opening the site by “Open Site" and typing the path: I've seen correctly the 2010 designer site home page. Then I opened a list and clicked on a view to make some change. At that time SPD2007 was surprisingly (really) opening… So (sorry if I have not been accurate before) it wasn’t an immediate redirect, just a redirect when I clicked on the view.

    At this point I uninstalled SPD2007 and, damn, didn’t checked immediately but repaired Office2010 installation (you know, from control panel). After this stuff I tried on server side and it was ok, so I tried client side and everything was working.

    I thought about cache because in this client I used the exact url https://intranet.company.com from SPD2007 yesterday on a 2007 site, and today that url is an upgraded 2010 site. If you have a better explanation I’m here to learn J from you.

    EDIT: Sorry, I wrongly proposed as answer a post on this thread and I don't know how to uncheck...


    Davide Michelotto
    • Edited by Davide4 Monday, November 15, 2010 11:11 PM Wrong propose as answer
    Monday, November 15, 2010 5:42 PM
  • See the whole article at http://ethan-deng.tech.officelive.com/TroubleshootSPDesigner2010.aspx

    Issue:

    We cannot open our root web site in SharePoint Designer 2010. We got the error saying "This web site has been configured to disallow editing with SharePoint Designer". However, we could open any of our sub web sites under the root. For example, we cannot open site http://intranet.mycompany.com but we could open http://intranet.mycompany.com/hr

    Conclusion:

    Our investigation found out that there are two hidden methods that are used by SharePoint 2010 to disable a site from openning in Designer. First, the property setting in ONET.xml file DisableWebDesignFeatures="wdfopensite". Second, the web site property "vti_disablewebdesignfeatures2". Our Micorosoft Project Server 2010 SharePoint site by default has DisableWebDesignFeatures="wdfopensite" and it prevents any other site collection from openning in Designer. 

    Our Micorosoft Project Server 2010 SharePoint site is deployed at http://intranet.mycompany.com/pwa and all our other sites are deployed at different site collection at http://intranet.mycompany.com. In theory, these are two different site collections and they should NOT interfere with each other, but the reality is that if the PWA site doesn't allow openning in Designer, the other site collection won't either.

    Monday, March 14, 2011 10:16 PM
  • In case anyone comes across the issue of not being able to open some migrated 2007 sub-sites to 2010, I've written a post about the fix here with clues from Ethand.

    http://www.henryong.com

    Wednesday, February 27, 2013 7:51 PM