none
Public Folders RRS feed

  • Question

  • We are leveraging Exchange 2007 SP2, We have not mail enabled public folders but email is being sent to one of the public folders.  We need to delete the email (180) ASAP however, it keeps saying we don't have permissions.  Anyone knows how to fix this issue.  We are not leveraging public folders in our environment but have them available for Enterprise Vault and possible backwards compatibility with Outlook 2003. 

    Monday, May 2, 2011 10:50 PM

Answers

  • On Mon, 2 May 2011 22:50:51 +0000, Debra Montague wrote:
     
    >We are leveraging Exchange 2007 SP2, We have not mail enabled public folders but email is being sent to one of the public folders.
     
    If that's true then the sender should be receiving a NDR becasue
    there's no place to deliver the message to!
     
    >We need to delete the email (180) ASAP however, it keeps saying we don't have permissions. Anyone knows how to fix this issue. We are not leveraging public folders in our environment but have them available for Enterprise Vault and possible backwards compatibility with Outlook 2003.
     
    Use the "Disable-MailPublicFolder" on the public folder if it's not
    supposed to be receiving e-mail.
     
    Have your public folder admin use "Add-PublicFolderClientPermission"
    to grant you (or someone else) permission to remove items from the
    public folder if you must delete the e-mail in the non-mail-enabled(?)
    public folder.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Marked as answer by Jerome Xiong Monday, May 16, 2011 3:39 AM
    Wednesday, May 4, 2011 1:32 AM
  • I agree with Rich. The public folder must be mail enabled.

    You could see it via Public Folder Management Console.

    Open Public Folder Management Consoleà right click the public folderàProperties.

    If the public folder is not mail enabled, mail enable public folder with E-mail Addresses and Mail Flow Settings attributes.

    Resource:

    Using the Public Folder Management Console

    How to Mail-Disable Public Folders


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Jerome Xiong Monday, May 16, 2011 3:39 AM
    Wednesday, May 4, 2011 8:02 AM

All replies

  • 1. Do you know the path to the public folder? i.e you you navigate there and see the emails?

    2. Make sure you have rights on the PF and delete via Outlook.

    3. Use the shell - http://technet.microsoft.com/en-us/library/bb201664(EXCHG.80).aspx

    Sukh

    Monday, May 2, 2011 10:57 PM
  • On Mon, 2 May 2011 22:50:51 +0000, Debra Montague wrote:
     
    >We are leveraging Exchange 2007 SP2, We have not mail enabled public folders but email is being sent to one of the public folders.
     
    If that's true then the sender should be receiving a NDR becasue
    there's no place to deliver the message to!
     
    >We need to delete the email (180) ASAP however, it keeps saying we don't have permissions. Anyone knows how to fix this issue. We are not leveraging public folders in our environment but have them available for Enterprise Vault and possible backwards compatibility with Outlook 2003.
     
    Use the "Disable-MailPublicFolder" on the public folder if it's not
    supposed to be receiving e-mail.
     
    Have your public folder admin use "Add-PublicFolderClientPermission"
    to grant you (or someone else) permission to remove items from the
    public folder if you must delete the e-mail in the non-mail-enabled(?)
    public folder.
     
    ---
    Rich Matheisen
    MCSE+I, Exchange MVP
     

    --- Rich Matheisen MCSE+I, Exchange MVP
    • Marked as answer by Jerome Xiong Monday, May 16, 2011 3:39 AM
    Wednesday, May 4, 2011 1:32 AM
  • I agree with Rich. The public folder must be mail enabled.

    You could see it via Public Folder Management Console.

    Open Public Folder Management Consoleà right click the public folderàProperties.

    If the public folder is not mail enabled, mail enable public folder with E-mail Addresses and Mail Flow Settings attributes.

    Resource:

    Using the Public Folder Management Console

    How to Mail-Disable Public Folders


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Jerome Xiong Monday, May 16, 2011 3:39 AM
    Wednesday, May 4, 2011 8:02 AM