locked
APPV Excel 2003 Plugin RRS feed

  • Question

  • Hello,

    We are using Office 2010 locally installed on a TS Server and deploy an Excel 2003 xla addin using APPV. It is one package being deployed that contains the excel 2003 and the xla plugin ( so no dsc is being used ). All works fine and when the user clicks the excel 2003 shortcut the appv application is started.

    However when the locally installed Excel 2010 is open while clicking on the shortcut for the APPV Excel 2003 then another local instance of Excel 2010 is being started. The option ALLOW_LOCAL_INTERACTION has been disabled in the APPV application. Does anyone have the same issue ?

    Monday, January 31, 2011 3:29 PM

Answers

  • Are you opening an XLA file? It sounds like the FTAs are conflicting somehow as though it see's the FTA's in place for both applications. I would look at the reg for the FTAs and see if these are in different hives...usually if the FTA is the same the Virtual one will win out
    • Marked as answer by Ginodh Tuesday, February 8, 2011 10:13 AM
    Tuesday, February 1, 2011 12:08 PM
  • All,

    Thanks for your help ! The problem was resolved. Apparently the shortcut was indeed directed to the xla file directly. Now we modified the shortcut to excel.exe with the xla file as argument. And now the problem no longer occurs.

    Thanks

    Tuesday, February 8, 2011 10:13 AM

All replies

  • I have the opposite setup, Office 2003 installed locally and Office 2010 provided via App-V. I can successfully run both at the same time (no matter which one i launch first). I have ALLOW_LOCAL_INTERACTION set to TRUE.

    What is your shortcut pointing to? I know that if you launch an excel file type (such as an xla) it will launch in whatever excel version that is open. If they're both open then it will open in the last launched excel version.

    Tuesday, February 1, 2011 11:09 AM
  • Are you opening an XLA file? It sounds like the FTAs are conflicting somehow as though it see's the FTA's in place for both applications. I would look at the reg for the FTAs and see if these are in different hives...usually if the FTA is the same the Virtual one will win out
    • Marked as answer by Ginodh Tuesday, February 8, 2011 10:13 AM
    Tuesday, February 1, 2011 12:08 PM
  • Thanks for the responses however the shortcut is pointing directly to the Excel 2003 installation and not to the XLA file. The plugin is included in the Excel 2003 package.
    Tuesday, February 1, 2011 12:38 PM
  • Do you have a WorkingDir set? I would make sure it is set as perhaps it is just opening EXCEL.exe and finding it in both places. It shouldn't do this by right but could try it..
    Tuesday, February 1, 2011 1:12 PM
  • All,

    Thanks for your help ! The problem was resolved. Apparently the shortcut was indeed directed to the xla file directly. Now we modified the shortcut to excel.exe with the xla file as argument. And now the problem no longer occurs.

    Thanks

    Tuesday, February 8, 2011 10:13 AM