none
Merge Replication Issue RRS feed

  • Question

  • We have configured Merge Replication on SQL Server 2014 (SP3-CU4)

    Publisher and one Subscriber.

    Everything working fine but after 2 hours ,we identified  4 tables at Subscriberside the date and time fields are automatically changed to Varchar(16). But publisher side everything looks good.

    Look like it's strage to me. 

    Monday, October 21, 2019 8:36 PM

Answers

  • What does this return?

    select distinct subscription_type, subscriber_type ,schemaguid, last_validated from sysmergesubscriptions

    • Marked as answer by VijayKSQL Thursday, October 24, 2019 4:51 PM
    Tuesday, October 22, 2019 3:53 PM
    Moderator

All replies

  • Are you replicating to SQL CE?
    Monday, October 21, 2019 8:53 PM
    Moderator
  • Microsoft SQL Server 2014 (SP3-CU4) (KB4500181) - 12.0.6329.1 (X64) 
    Jul 20 2019 21:42:29 
    Copyright (c) Microsoft Corporation
    Standard Edition (64-bit) on Windows NT 6.3 <X64> (Build 9600: ) (Hypervisor)

    Both Publisher and Subscriber versions are same.

    • Edited by VijayKSQL Monday, October 21, 2019 9:10 PM add
    Monday, October 21, 2019 9:09 PM
  • This should not be the case. can you confirm that the data types on the subscriber are also not varchar?
    Tuesday, October 22, 2019 3:50 PM
    Moderator
  • What does this return?

    select distinct subscription_type, subscriber_type ,schemaguid, last_validated from sysmergesubscriptions

    • Marked as answer by VijayKSQL Thursday, October 24, 2019 4:51 PM
    Tuesday, October 22, 2019 3:53 PM
    Moderator
  • I found  there are some configuration issues.

    Now i fixed. Thank you.

    Thursday, October 24, 2019 4:51 PM