Dynamic DNS - Multiple A Records RRS feed

  • Question

  • We run a mixed environment Macintosh and Windows workstations joined to a Windows 2008 AD.  Most of these systems have VMWare Workstation and VMWare Fusion installed on them.

    VMWare workstation creates "Virtual" network adaptors with non-routable ip addresses.  These non routable ip addresses get registered into Microsoft active directory for that workstation which causes problems when one pings the workstation.  

    The below example workstation ws122228.stl.ad resolves to &  The problem is that the is the VMWare Workstation's virtual ip address which is NOT routable.

    Same behavior on both Windows and Macintosh.  Does anyone have any ideas on how to only register the ip address which is the wired ethernet connection?

    If I dig this workstation, I get the below:

    [fjeuw@dkslin261 ~]$ dig ws122228.stl.ad A

    ; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.30.rc1.el6_6.2 <<>> ws122228.stl.ad A

    ;; global options: +cmd

    ;; Got answer:

    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 1918

    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 0, ADDITIONAL: 0


    ;ws122228.stl.ad. IN A


    ws122228.stl.ad. 1200 IN A
    ws122228.stl.ad. 1200 IN A

    ;; Query time: 1 msec

    ;; SERVER:

    ;; WHEN: Sat May  9 09:01:19 2015

    ;; MSG SIZE  rcvd: 72

    Saturday, May 9, 2015 1:10 PM


  • Hi,

    you have to disable the automatic DNS registration from the IPv4 settings of the the network card in your virtualmachine using the graphical IP config or you can run a netsh command.

    see also




    VM and the virtual host should have different hostnames as well to avoid confusion. I saw that before in a Mac VMware Fusion environment where the used the same names for the Mac and the Windows VM and that gave all sorts of trouble. Just wanted to mention that even it does might not apply in your case.

    Hope that helps,


    • Proposed as answer by Meinolf Weber Tuesday, May 12, 2015 1:34 PM
    • Marked as answer by Mary Dong Wednesday, May 20, 2015 6:12 AM
    Saturday, May 9, 2015 4:41 PM