none
App-V Windows 10 RRS feed

  • Question

  • Hello People :)

    I've made a couple of AppV applications using InstallShield 2018 build.  I tried both repackaging and using an ISM and using just a straight MSI.

    It looks ok and I get to fully publish but when I run the Icon I get the same message (on both an vanilla Win 10 PC and on SOE'd machine from our environment);

    The Application was unable to start correctly (0xc0000142). Click OK to close the application.

    On Event viewer under Microsoft -> AppV ->Client -> virtual Applications I get the following;

    The virtual application 'C:\ProgramData\App-V\9FEC58F4......\A1729DBF...\Root\VFS\AppVPackageDrive\Program Files\APP....\....APP.EXE' could not be started because the App-V Subsystem 'Virtual Filesystem' could not be initialized. {error: 0x74300E0A-0x20006}

    Would really appreciate some help :)

    Wednesday, October 10, 2018 12:33 AM

All replies

  • Hi,
    I suggest you submit a new case on App-V forum as they will be more professional on your issue:

    This is the App-V forum link.
    https://social.technet.microsoft.com/Forums/en-US/home?forum=mdopappv

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us. Thank you for your understanding.
    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, October 11, 2018 5:30 AM
    Moderator
  • I received the same error.  Took me a week to resolve, but found that the registry key NtfsDisable8dot3NameCreation was set to a 1 on my sequencing machine, while my virtual machine clients were all set to a value of 2.  After changing it on my sequencing machine to a 0 everything worked again.

    https://support.microsoft.com/en-us/help/121007/how-to-disable-8-3-file-name-creation-on-ntfs-partitions

    I actually dug into the appv using 7zip looking at the FilesystemMetadata.xml file and comparing with the xml file with a known good application using Notepad++.  Good xml looked like Short="MICRO~1" while the bad looked like Short="xwy3gedi.h03"

    I had not considered it was a setting on my sequencing machine.

    Sunday, July 14, 2019 4:06 PM