none
Windows 7 Enterprise installation issue at setup windows page RRS feed

  • Question

  • So i have seen many pages with the issue of mouse and keyboard not being detected at the language selection page during the windows 7 enterprise installation, so i was bale to find a work around for that issue by patching the ISO file with the USB 3.0 drivers, I was able to move past the language selection page and install the OS, when installation completed and the system rebooted, it wont detect the mouse or keyboard at the "set up windows - Type a name for our PC" page.

    Please help!!!

      
    Thursday, April 6, 2017 10:06 PM

All replies

  • Hi VolantTech,

    What is the exact machine model? Is the mouse and keyboard detected in BIOS? Have you tried any PS keyboard or mouse?

    This issue is usually related to the USB port or the BIOS configuration. Please plug in the mouse and keyboard from a USB 2.0 port. Refer to the following link`s suggestion to check the BIOS configuration. 
    Windows installation media cant detect keyboard and mouse
    https://superuser.com/questions/851143/windows-installation-media-cant-detect-keyboard-and-mouse

    Your best bet is to search the installation manual document about your machine model from the device manufacturer website for the BIOS configuration.

    Best regards

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, April 7, 2017 2:50 AM
    Moderator
  • im working with a Xplore XSLATE R12 which only has one USB 3.0 port and no Ps/2 port, no USB 2.0 ports, im using a amazon USB 3.0 hub to attache the keyboard and mouse and the ISO USB, the keyboard and mouse is detected in the bios and i even patched the ISO image (boot and image file) with the USB 3.0 driver from the manufacturer and even the Intel USB 3.0 driver, which solved the initial problem of the keyboard and mouse not being detected at the language selection options page, so not sure why after installing the OS when the system reboots it wont detect the keyboard mouse or the display input, when i go into bios is does. 

    i have contacted the manufacturer and they arent sure, since the device comes in with a windows 7 professional they cant support enterprise and haven't been much help.  there isnt any thing in the manufacturers documentations about this issue. 

    Friday, April 7, 2017 3:19 PM
  • Hi VolantTech,

    " im using a amazon USB 3.0 hub "
    We could connect the keyboard to the machine directly when we input the name.

    According to my research, that model device is a tablet and it has touch screen feature. We could use the touch feature or attach it to a dock station then finish the OOBE. Then update the machine from Windows  Update then check the symptom again.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, April 10, 2017 9:34 AM
    Moderator
  • sorry for not posting all the details, but i have tried attaching the Keyboard directory, plus tried 2 different type of keyboards, tried the USB 3.0 and USB 2.0 extension cable to see is that works, but no luck. it wont detect the display input either, we dont have a dock for it.  
    Monday, April 10, 2017 2:50 PM
  • Hi VolantTech,

    Will the keyboard and mouse need special driver?

    I think the key point is that there is no keyboard or mouse driver in the windows image. We could try to download the drivers for the keyboard and mouse and add them to the Windows 7 image manually  then install it again.

    Best regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, April 13, 2017 8:50 AM
    Moderator