locked
Give Group Permissions to this Site missing RRS feed

  • Question

  • Hi

    I want to create a custom group with custom permissions. Making a custom permission level works but my problem is: how to add this permission level to my custom group?

    I searched online and found e.g.  this site: http://www.sharepointmonitor.com/2010/05/how-to-create-a-group-for-a-sharepoint-site/ which explains how to add a custom group, but I just don't seem to get the last "Give Group Permissions to this Site", which I guess I would need to assign a permission level to the group.
    Knowing that in the permissions page, you can change the permissions levels of a group aswell, I opened this site but ... weard ... my custom group is not listed...

    This sounds very stupid, but I just don't seem to figure this out. I have full control to the site and everything else works fine.

    Thanks for any explaination.

    • Edited by Sjokke Tuesday, June 15, 2010 7:53 AM more details
    Tuesday, June 15, 2010 7:44 AM

Answers

  • I'm using SharePoint 2013 and am in the same boat.

    Someone had stupidly Removed site-level permissions for default groups and now there is simply no way to Add existing groups back. When editing the Group via the Groups.aspx page the "Give Group Permissions to this Site" section is not present.

    The only way I can get this section to display is if I selecting an existing group from User.aspx and click Edit User Permissions from the ribbon.

    When I create a new group here I also see this section. But for any existing custom groups with no site-level permissions I simply cannot find any way to grant them through the UI. 


    UPDATE: Oh my God, I finally figured it out. :@

    1. Site Settings -> Site Permissions
    2. Click Grant Permissions
    3. The default setting is to invite people to Contribute, which automatically adds Users to the site's Member group. Ignore this and click the extremely subtle SHOW OPTIONS link at the bottom of the dialog.
    4. Now click the dropdown for the Select a group or permission level.
    5. Scroll all the way down past all your groups...and you will finally see the site Permission Levels.
    6. Select the appropriate level and now type the desired Group name and click OK.

    Seriously, just how unintuitive is this??

    • Edited by PANoone Friday, May 30, 2014 12:21 AM Found solution and received a migraine for my efforts
    • Proposed as answer by Arif Hooda Friday, May 30, 2014 6:54 AM
    • Marked as answer by Pratik Vyas Tuesday, June 10, 2014 10:46 PM
    Friday, May 30, 2014 12:07 AM

All replies

  • When creating a group for a site via Site Actions > Site Permissions > Ribbon menu > Create Group, you should see the Give Group Permissions to this Site at the bottom of the page.
    Sincerely,
    Lambert Qin
    Posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, June 17, 2010 2:50 AM
  • That's my problem, I don't see this, neither on the new group page nor on the edit group page ...
    Thursday, June 17, 2010 6:04 AM
  • Does anybody have the same issue? Or a workaround?

    Really annoying to have this, I'm unable to use newly created groups this way...

    Monday, June 21, 2010 8:00 AM
  • I'm able to see and change this at site collection level, but not on subsite. Is this default behaviour?

    What I want to achieve: the standard user can access the site collection. Some of the subsites and list/libraries need to have a different administrator etc. So I wanted to create groups at site level, to define the different permissions per site, in stead of at site collection level because than would a site administrator of a subsite also have the full access on site collection level and that's something we don't want.

    Thursday, June 24, 2010 11:13 AM
  • I'm using SharePoint 2013 and am in the same boat.

    Someone had stupidly Removed site-level permissions for default groups and now there is simply no way to Add existing groups back. When editing the Group via the Groups.aspx page the "Give Group Permissions to this Site" section is not present.

    The only way I can get this section to display is if I selecting an existing group from User.aspx and click Edit User Permissions from the ribbon.

    When I create a new group here I also see this section. But for any existing custom groups with no site-level permissions I simply cannot find any way to grant them through the UI. 


    UPDATE: Oh my God, I finally figured it out. :@

    1. Site Settings -> Site Permissions
    2. Click Grant Permissions
    3. The default setting is to invite people to Contribute, which automatically adds Users to the site's Member group. Ignore this and click the extremely subtle SHOW OPTIONS link at the bottom of the dialog.
    4. Now click the dropdown for the Select a group or permission level.
    5. Scroll all the way down past all your groups...and you will finally see the site Permission Levels.
    6. Select the appropriate level and now type the desired Group name and click OK.

    Seriously, just how unintuitive is this??

    • Edited by PANoone Friday, May 30, 2014 12:21 AM Found solution and received a migraine for my efforts
    • Proposed as answer by Arif Hooda Friday, May 30, 2014 6:54 AM
    • Marked as answer by Pratik Vyas Tuesday, June 10, 2014 10:46 PM
    Friday, May 30, 2014 12:07 AM