locked
Network HOme Folders Renamed to Documents RRS feed

  • Question

  •  

    We recently added 130 Vista computers to our network.  We are finding, however, that when someone logs onto the Vista computer, it changes their network home folder name from their username to Documents.  When you do select one of the new "Documents" folders, it does show the correct url with the person's username.  This, however, is unacceptable as we are a school district who constantly need to access students' folders.  It makes it very difficult to find the student's folder.  How can this be changed so that it correctly displays the folder name and not Documents?
    Friday, September 21, 2007 1:48 PM

Answers

  • I noticed that it didn't happen to all users - only certain ones (and I still don't know why these were singled out).  But anyway, they are missing in their desktop.ini file in their home folder the following:

     

    [DeleteOnCopy]

    Owner=username - or name of home folder

    Personalized=5

    PersonalizedName=MyDocuments

    (This is at the top.  I left the rest of the ini file intact.)

     

    for example I had a student with the username of smithm.  I put this in the top of the desktop.ini file.

     

    [DeleteOnCopy]

    Owner=smithm

    Personalized=5

    PersonalizedName=MyDocuments

     

    After saving the ini file, the folder immediately renamed back to the correct home folder name of smithm. 

     

    the other users whose folders were working correctly did have that information in it.

     

    Hope this helps!  It is such a frustrating issue.

     

     

     

     

    Friday, October 26, 2007 4:05 PM

All replies

  • Hi Kathy...

     

    did you manage to figure out what was happening with the home folders?

     

    We are slowly starting to get Vista users with in my company and im seeing this issue occur and could do with fixing this issue

     

    Many thanks

     

    Gareth Collins

     

    Friday, October 26, 2007 8:39 AM
  • I noticed that it didn't happen to all users - only certain ones (and I still don't know why these were singled out).  But anyway, they are missing in their desktop.ini file in their home folder the following:

     

    [DeleteOnCopy]

    Owner=username - or name of home folder

    Personalized=5

    PersonalizedName=MyDocuments

    (This is at the top.  I left the rest of the ini file intact.)

     

    for example I had a student with the username of smithm.  I put this in the top of the desktop.ini file.

     

    [DeleteOnCopy]

    Owner=smithm

    Personalized=5

    PersonalizedName=MyDocuments

     

    After saving the ini file, the folder immediately renamed back to the correct home folder name of smithm. 

     

    the other users whose folders were working correctly did have that information in it.

     

    Hope this helps!  It is such a frustrating issue.

     

     

     

     

    Friday, October 26, 2007 4:05 PM
  •  

    Kathy,

     

    Thanks for the post.  adding those lines in to the desktop.ini file has resolved the issue when looking on the file server but when looking from a vista computer they still display as "documents" and not "username"

     

    will have a little play about with this and see what i can find.  At least now when people are browsing they can see the username.. Thankfully it is only us in IT and one or two others that have vista so the problem is not at large just yet.. but with new hardware needed soon and vista becoming more and more wide spread i can see this becoming more of an issue

     

    Thanks

     

    Gareth Collins

    Monday, October 29, 2007 10:03 AM
  • Kathy, we are experiencing the same thing, except the only students folders that are affected are the ones that I created using the AddUser command. All other accounts seem to be unaffected. If I create a user in Active Directory and setup his/her home folder there, it does not change to "Documents".

    We also use folder redirection, and have found some references to that being the problem.

    But, like you, we are a school that must be able to view these folders by user name. Hope someone has a solution.

    Monday, March 3, 2008 8:00 PM
  • Teri & Kathy,

     

    Take a look at this and see if it relates to your issue.

     

    MS Knowledge base article 947222


    http://support.microsoft.com/kb/947222

     

    Tony

     

    Wednesday, March 12, 2008 3:30 PM
  • OK so I'm having the exact same issues but when you open the desktop.ini file for the home folders that are named correctly they have nothing in them, but the home folders that are named Documents have the following in their desktop.ini file...

     


    [.ShellClassInfo]
    LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21770
    IconResource=%SystemRoot%\system32\imageres.dll,-112
    IconFile=%SystemRoot%\system32\shell32.dll
    IconIndex=-235

     

    So I deleted the contents of the desktop.ini file for the home folders that are named Documents, saved it and then it went back to the correct name of the home folder...  But as soon as they log back into Vista it turns back to Documents...  One thing I noticed is that there is an R attribute attatched to the ones that change...

     

    Any suggestions...

     

    I tried the Microsoft Knowledge base with no luck also...

    Tuesday, May 13, 2008 7:08 PM
  • The key is to lock down the rights to the Desktop.ini so nothing replaces or changes the ini file. I made a desktop.ini that can not be messed up and copied it into each home folder and all my troubles went away. Hope this helps

     

    Tuesday, May 13, 2008 8:34 PM
  • OK Great...  but here comes a stupid question...  How do I make a desktop.ini file that is locked down...  What steps did you take...
    Tuesday, May 13, 2008 8:50 PM
  •  

    Short version.

    ***Remove the “Include inheritable permissions blahhhhhhh”

    Only give yourself rights to do anything to the file.

    Grant the “everyone” group normal read access.

     

    Long version…

     

    Go to the desktop.ini properties

    Security

    Advanced button

    Ownership tab

    Take ownership…

    You will have to close and reopen properties and then go back to.

    Security

    Advanced button

    Permissions

    Edit button

    Remove the “Include inheritable permissions blahhhhhhh”

    Now remove all user permission to this file.

    Add the “everyone” group grant them read & execute only

    Add yourself full rights.

    Say ok to everything to save your grueling work.

    Tuesday, May 13, 2008 9:15 PM
  • So how are people doing these steps for hundreds or thousands of home folders? Or is the option to not use Vista in a large organization what people are trying?

     

    Tuesday, July 1, 2008 6:03 PM
  • The real issue is that the desktop.ini is copied to the network share when you redirect the folder. If you can prevent that from happening you will not have the issue. How you stop it will be up to you. In my case, I inform the users not to copy all files to the new location when the redirection is setup. In your case, I would look at modifying the default login profile in your Vista image (if that is how you deploy) to use the modified desktop.ini. I can only guess to what will work best for you but that is the path I would investigate.

     

    Tuesday, July 1, 2008 6:31 PM
  • Put this in the users logonscript.
    Or as i did since this also is a problem with 2008 Terminalserver, and using the gpo "redirect my documents to users home folder" without "granting user exclusive rights to my documents"

    create a cmd file with the command line shown bellow in it. put it on the logon share and add it as a logon  / logoff script in the GPO for the  OU where the Terminalserver / computers are in.

    %windir%\system32\icacls.exe %homedrive%\Desktop.ini /deny "Domain Admins":r OR

    %windir%\system32\icacls.exe %homedrive%\Desktop.ini /deny Administrators:r



    This will prevent the Admins from seeing all folders as documents in the home folder share.

     

    • Proposed as answer by TEK- Saturday, February 27, 2010 6:54 PM
    • Edited by TEK- Saturday, February 27, 2010 7:23 PM skriveleif
    Saturday, February 27, 2010 6:54 PM
  • I think I have a nice work around for server 2008R2 !!!

    I have set up a filescreen that blocks all desktop.ini's in the users homedirectories structure.
    Seems to work fine, all folders have there old names back and the user doesn't feel a thing.
    Hope this helps some of you out there...

    Tuesday, April 13, 2010 3:01 PM
  • I've written a PowerShell script which denies read access to the desktop.ini file to a specified group. Anyone in this group will then not have the documents renamed .

    http://blog.salamandersoft.co.uk/index.php/2010/09/how-to-stop-home-folders-being-renamed-documents-in-the-network-share/

     

    Richard
    Friday, September 24, 2010 3:06 PM
  • What I did to fix the issue was to install FSRM and make a file screen for the share where their home directory is mapped disallowing any ini files. That did the trick for me.
    Saturday, December 11, 2010 7:51 PM
  • All I did to fix this issue was to add a policy to the default domain policy.

    User Configuration

    --Policies

    -----Administrative Templates

    --------Desktop

    Enable "Prohibit User from manually redirecting Profile Folders"

    I had to recreate the affected users home folders but it hasn't done it since (fingers crossed)

    Friday, June 3, 2011 10:57 AM
  • What about the existing folders that have been renamed.  I manually removed permissions from the desktop.ini, however, the documents folder is still named "Documents" and not the users username.  Is this fix only for new home directories?

    Should I remove all the contents from the desktop.ini?

    Friday, July 15, 2011 1:57 PM
  • Bump...

    I was struggling with this problem but found a solution that works for me. I created a Group Policy User preference that deletes the desktop.ini file at logon."P" being the home folder drive letter for my users. I also checked the box for "Run in logged-on..." under the  "Common" tab when creating this policy.

    Hope this helps!

    Tuesday, August 9, 2011 7:58 PM
  • Agree with MMustain I simply used a GPP to fix this;

    Windows - Users Home Drives Renamed to 'My Documents'

    Pete


    Regards Pete Long http://www.petenetlive.com

    Monday, March 11, 2013 12:46 PM