locked
SharePoint Library default save location RRS feed

  • Question

  • When a new document is created from a template in a Sharepoint library, the created document does not automatically save into the same library and has to be saved elsewhere and then uploaded.

    This only happens on some machines. On others it prepopulates the default save location as the library from where it was created.

    Any ideas?
    Monday, June 29, 2009 2:22 PM

Answers

  • Hi,


    I understand the issue that the
    default location for document created form document template is local Documents folder, instead of the SharePoint document library.

    If I am right, it is a known issue and the issue has been fixed by KB907306: http://support.microsoft.com/kb/907306

     

    Let me know if I misunderstand you.


    Xue-Mei Chang
    Wednesday, July 1, 2009 6:32 AM
    Moderator

All replies

  • You can try opening the document library from the Sharepoint Designer. Then right click on the document library/list folder > properties > supporting files. and check the path of the 'allitems.aspx'(for list) (or) Default view page(for document library).
    Monday, June 29, 2009 2:50 PM
  • >>the created document does not automatically save into the same library and has to be saved elsewhere and then uploaded.

    You could you clarify the statement that it working and documents are saved inside the library or it's not working?
    Visit: http://yagyashree.wordpress.com MCP & MCTS [WSS 3.0/MOSS]
    Monday, June 29, 2009 6:06 PM
  • Are all of your users on the domain that your SharePoint instance are on?  If so, are they using their domain login credentials?
    http://www.spdan.com
    Tuesday, June 30, 2009 4:24 AM
  • All users are on the same domain that MOSS is on and are using their domain usernames.
    The document library is working, e.g.  you can upload docs etc.

    However on some machines, not all, if i create a document from the library template then save the file, the default save location is not the document library from which I created the document.
    Therefore i need to save locally then upload the document manually.
    Tuesday, June 30, 2009 8:15 AM
  • In the problem machines, when the office document open and you try to save them, do you go to office button and save it or use save as and choose the location to save?
    Visit: http://yagyashree.wordpress.com MCP & MCTS [WSS 3.0/MOSS]
    Tuesday, June 30, 2009 6:43 PM
  • Hi,


    I understand the issue that the
    default location for document created form document template is local Documents folder, instead of the SharePoint document library.

    If I am right, it is a known issue and the issue has been fixed by KB907306: http://support.microsoft.com/kb/907306

     

    Let me know if I misunderstand you.


    Xue-Mei Chang
    Wednesday, July 1, 2009 6:32 AM
    Moderator
  • Hi,

    I use the 'save' option, not the 'save as'
    Wednesday, July 1, 2009 8:09 AM
  • Hi,

    you have understood the problem.
    I will have a look at the KB.

    The problem is not happening with everyone, only some users.
    Wednesday, July 1, 2009 8:10 AM
  • Hi,

    I had a similar issue, and found out that the Webclient service was not running on the client pc with the problem. In that case, you can open documents from SharePoint, but if you want to save changes back to SharePoint, this fails, and it defaults to a location on your local hard drive. Starting the web client services solves the issue.

    Hope this helps,

    Jan.
    Friday, July 3, 2009 1:07 PM