locked
Exchange Server connect to wrong site RRS feed

  • Question

  • I have Exchange 2010 and two sites when i create new user " Test user " on main site and go to EMC to create new mailbox from existing users i don't see user but i see " Test user " on remote site .


    Wednesday, July 8, 2015 9:52 AM

Answers

  • Hi All ,

    Thanks for replay .. Exchange server on main site pointing to server on DR site so when create mailbox user from Exchange server user not be visible and i changed properties on Exchange pointer to correct server. go to with following: EMC --> MS Exchange on premise --> Organization configuration --> R click--> properties --> select Tab site and modify server  connect to correct server site. 

    Regards,

    Magdy






    Tuesday, July 14, 2015 9:06 AM

All replies

  • Hi,

    Are you able to see the test user in exchange management shell in the main site??

    get-user -identity "test user"

    Regards

    Vickram

    Wednesday, July 8, 2015 11:49 AM
  • Hi Magdy,

    When you say  "i don't see user" which user are you refering to.

    Do a get-user on the missing user or all users, what are the user's RecipientType listed as?

    [PS] C:\Scripts>get-user *Satya*
    
    Name                                                         RecipientType
    ----                                                         -------------
    Satyajit                                                     UserMailbox
    SatyaTEST1                                                   UserMailbox
    SatyaAdmin                                                   User

    To assign a mailbox it needs to be 'User' not 'UserMailbox'.

    Please note the default search scope is not ADSite based but AD Domain based. You can expand it to include entire forest as well.

    Then again if you are having some custom RBAC roles assigned the behaivour might change to which OU users can be managed and which not.


    Regards,

    Satyajit

    Please“Vote As Helpful” if you find my contribution useful or “MarkAs Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.



    • Edited by Satyajit321 Wednesday, July 8, 2015 12:24 PM
    Wednesday, July 8, 2015 12:15 PM
  • Hi Hassan,

    Thank you for your question.

    By my understanding, we could run the following command to check if the Exchange connect to remote site :

    Get-ADServerSettings | FL

    If the Exchange connect to remote site, we could refer to the following steps to check if the issue persist:

    1.        Make sure the “Preferred DNS server” and “Alternate DNS server” and “Alternate DNS server” to point to main site
    2.        Then restart the service of “Microsoft Exchange Active Directory Topology” and run the command to check if the Exchange connect to the local site
    3.        If the issue persist, we could run the following command to configure the preferred domain controller:

    Set-ADServerSettings -PreferredServer mainsiteDC.contoso.com

    In addition, we should make sure DC replication between main site and remote site without any problems.

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Thursday, July 9, 2015 2:59 AM
    Moderator
  • Hi Mr. Jim,

    I checked all steps but does not problem and replication between Main site and DR site is working
    Issue when add new users mailbox from AD using the Existing user does not show this users AD account on main site.

    Regards,

    Magdy





    Sunday, July 12, 2015 8:45 AM
  • Hi Magdy,

    Where does it show then, or it doesn't show up anywhere.

    Have you tried using the PowerShell cmdlets for Enabling mailboxes for an Existing User.

    Enable-Mailbox john@contoso.com -Database "MyServer\Mailbox Database"
    

    Also can you update on the earlier get-user post results.


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Monday, July 13, 2015 6:39 AM
  • Hi Mr. Jim,

    I checked all steps but does not problem and replication between Main site and DR site is working
    Issue when add new users mailbox from AD using the Existing user does not show this users AD account on main site.

    Regards,

    Magdy





    Hi Magdy,

    When you run the command. Which DC get back? Remoter DC or local DC?

    Get-ADServerSettings | FL

    We could open EMC->Server Configuration->Modify configuration Domain Controller, then we could point to the specific DC to check if the issue persist.

    If not, we could refer to the following step to delete Window profile to check if the issue persist:

    https://technet.microsoft.com/en-us/library/cc775638%28v=ws.10%29.aspx

    If there are any questions regarding this issue, please be free to let me know.

    Best Regard,

    Jim



    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Jim Xu
    TechNet Community Support

    Tuesday, July 14, 2015 7:47 AM
    Moderator
  • Hi All ,

    Thanks for replay .. Exchange server on main site pointing to server on DR site so when create mailbox user from Exchange server user not be visible and i changed properties on Exchange pointer to correct server. go to with following: EMC --> MS Exchange on premise --> Organization configuration --> R click--> properties --> select Tab site and modify server  connect to correct server site. 

    Regards,

    Magdy






    Tuesday, July 14, 2015 9:06 AM
  • Hi Magdy,

    Have you tried this.

    Use the EMC to change the recipient scope  also please confirm if PowerShell Enable-Mailbox works or not.


    Regards,

    Satyajit

    Please “Vote As Helpful” if you find my contribution useful or “Mark As Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.

    Tuesday, July 14, 2015 11:58 AM