none
MS Project 2010 Auto Filter Error RRS feed

  • Question

  • Hi,

    I have switched lately from MS Project 2007 to MS Project 2010, and one of the features which I was looking for is the AutoFilter feature; but unfortunately I got disappointed later.

    When I use the auto filter feature in columns containing durations (like duration, total slack, ...etc.) and filter out a value which contains a fraction of a week (like for example 1.83 or 7.83 wks) the filter returns nothing, just an empty table, although there are many tasks which meets the filter criteria! I have tried different values in different columns with the same result (except if the fraction is 0.5)!

    In the beginning, I thought my file itself was somehow corrupted because of the switching from 2007 to 2010 version; accordingly, I have created a new file from scratch on 2010, but unfortunately the same behavior still exists. I have also tried altering all the possible options in the “Schedule” and “Advanced” options, but with no success also. On the other hand, when I use the normal custom filter it works fine with any value! I have taken one step further and tried my file on Project 2013, but surprisingly the same behavior shows up again!

    Is it a bug in the AutoFilter feature or I am missing something?

    Could you please guide me how to troubleshoot this problem as soon as possible?

    Thanks in advance for your appreciated prompt feedback.



    Thursday, April 23, 2015 6:30 AM

Answers

All replies

  • Hi Ahmad,

    I cannot reproduce your bug, autofilters work as expected for me. I'd suggest that you upgrade to the latest Project 2010 patch level.

    http://blogs.technet.com/b/projectsupport/p/msp10.aspx

    Try also to repair MS Project from the control panel.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, April 23, 2015 7:14 AM
    Moderator
  • Hi Guillaume,

    Thanks for your prompt response.

    I have done so already before posting my question; I have the latest updated version of Project 2010. I have also tried it on Project 2013, but the same behavior still exists.

    I tried to include some snapshots here, but I am receiving a message that my account must be verified first! I don't now what is that.

    Thursday, April 23, 2015 7:48 AM
  • Quite strange. You can send me your file at gDOTrouyreATcgiDOTcom (replace caps letter) so I can try to check on my machine.

    Which view are you using while trying to set the autofilter? Are we talking about the little Arrow in the columns headers?


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, April 23, 2015 7:53 AM
    Moderator
  • Thanks again; I have sent you the file to your email.

    I have tried the file on three machines; 2 with 2010 and 1 with 2013.

    This behavior takes place in all the views; and yes, I am talking about the little arrow in the column header.

    Thursday, April 23, 2015 7:59 AM
  • Didn't receive anything.

    g.rouyre@cgi.com


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, April 23, 2015 8:12 AM
    Moderator
  • Maybe because of the file size (7MB); I have zipped it and resent it again.

    Sincere thanks for your appreciated support.

    Thursday, April 23, 2015 8:17 AM
  • I think I got it. The auto-filter seems to work correctly. But if you filter for example on 0 week duration tasks, the summary tasks will be displayed also. For example the task 694 is 0 weeks so included in the filter, but all summary tasks (689, 688, 687, 21) will also be displayed evenif they are not 0 weekds duration.

    A workaround is to create a custom filter unchecking the "show related summary rows" option.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, April 23, 2015 8:27 AM
    Moderator
  • Try to filter the "Total Slack" field with -6.67wk for example; you will see that it is returning no entries, which is wrong.

    The auto filter works fine with integer values, and it misbehaves with fractional values; this is my problem.

    Thursday, April 23, 2015 8:33 AM
  • By the way, I have already made a custom filter from the beginning, and it is working fine; the problem exists only with the auto filter (in some fractional values only).
    Thursday, April 23, 2015 8:35 AM
  • Indeed you are right. It might be due to the regional settings which define the decimal separator. There is also the same unexpected behavior for the duration.

    I found that if you create a custom filter typing directly the number -6,67, it works well:

    That being said, I cannot reproduce this bug on a simple brand new file. Can you try to reproduce it on a new blank file? Also try to save the project as XML and import it back as a MPP. You can also try to change the duration unit for days to see if it helps.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Thursday, April 23, 2015 9:01 AM
    Moderator
  • 1. Changing regional settings: no success

    2. New blank file: no success

    3. XML save/import: no success

    I think I have taken much of your time already, and I don't want to consume the rest of your day :).

    If you came across a solution or an explanation, please let me know.

    Sincere thanks for your time and your appreciated cooperation.

    Thursday, April 23, 2015 9:32 AM
  • It may be to a rounding error. A duration may calculate as 2.666 but Project only displays 2 digits so it is rounded to 2.67. Internally the filter then looks for value 2.67, but teh stored value is 2.666 so it isn't found.

    Rod Gill
    Author of the one and only Project VBA Book
    www.project-systems.co.nz

    Saturday, April 25, 2015 1:33 AM
    Moderator
  • Thanks Rod.

    But if this is the case, how to solve it?

    Saturday, April 25, 2015 6:51 AM
  • You can't, unless you duplicate the duration in a text or number field using a formula to round the number. Then search the custom field.

    Rod Gill
    Author of the one and only Project VBA Book
    www.project-systems.co.nz

    Sunday, April 26, 2015 10:39 AM
    Moderator
  • Then it is a bug in the auto filter feature, because it is working fine with the custom filter.

    I believe Microsoft should issue a fix for this issue, for both 2010 and 2013 versions.

    Thanks Rod for your support.



    Monday, April 27, 2015 3:46 PM