locked
Disable Save to Desktop / Documents Folder RRS feed

  • Question

  • Hello,

    we are building some restricted Clients for a special room and we need to disable the save as dialoge

    When open a PDF-Document in InternetExplorer and then want to save it, the default path is set to My Documents (Instead of the default "Downloads" save location from IE) . We have already disabled the Libarys via Registry but in the "save as" dialoge they are still there.

    We want to achive that a User can only save files to a fileserver and nowhere else. Additionally we have seen this in the open dialog with the desktop as default path, which we want to disable also. Normally the User see anything in the Desktop (restricted via GPO), but unfortunately its possiable to save and open files there.

    I have looked at User- and ShellFolder Registry Keys to custimize the dialoges but it works, but possibly not the best solution. Also I know thats possiable to work with folder redirection, but then the libaries are still there.

    Is there a way to disable the "documents" and "desktop" save-as dialogs, so that its noted by the application and only show the share path?

    I hope its possiable to understand what I mean :-)

    Monday, May 26, 2014 4:06 PM

Answers

  • If you would like to restrict user from saving file on Desktop, you can remove Modify permission from their Desktop folder by Startup scripts. Group Policy cannot restrict add/remove item if they have modify permission.

    You can enable the following Policies to disable downloading.

    User Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page

    You can enable "Allow file downloads" policy and select Disable in Internet Zone and Intranet Zone.


    Mark as Answer if it's worked. Thanks. Balamurugan_Subramaniyan

    • Marked as answer by Karen Hu Monday, June 9, 2014 1:22 AM
    Monday, May 26, 2014 6:06 PM
  • Hi,

    In addition to the suggestions offered by Balamurugan_Subramaniyan, you may also have interests in the below thread:

    Prevent user to save in desktop

    Best regards


    Michael Shao
    TechNet Community Support

    • Marked as answer by Karen Hu Monday, June 9, 2014 1:22 AM
    Wednesday, May 28, 2014 7:05 AM

All replies

  • If you would like to restrict user from saving file on Desktop, you can remove Modify permission from their Desktop folder by Startup scripts. Group Policy cannot restrict add/remove item if they have modify permission.

    You can enable the following Policies to disable downloading.

    User Configuration > Administrative Templates > Windows Components > Internet Explorer > Internet Control Panel > Security Page

    You can enable "Allow file downloads" policy and select Disable in Internet Zone and Intranet Zone.


    Mark as Answer if it's worked. Thanks. Balamurugan_Subramaniyan

    • Marked as answer by Karen Hu Monday, June 9, 2014 1:22 AM
    Monday, May 26, 2014 6:06 PM
  • Hi,

    In addition to the suggestions offered by Balamurugan_Subramaniyan, you may also have interests in the below thread:

    Prevent user to save in desktop

    Best regards


    Michael Shao
    TechNet Community Support

    • Marked as answer by Karen Hu Monday, June 9, 2014 1:22 AM
    Wednesday, May 28, 2014 7:05 AM
  • Balamurugan, yu wrote " you can remove Modify permission from their Desktop folder by Startup scripts.", but how? howdo you do that by startup scripts?. This seems what I am looking for to avoid users saving to the desktop. Your feedback will be highly appreciated. Temp David
    Thursday, October 12, 2017 1:45 AM