locked
Drag and Drop permissions RRS feed

  • Question

  • Hi,

    I have a SharePoint 2013 foundation environment with FBA enabled. In this environment i have a document library with several folders, these folders have their own unique permissions. User A, has edit (standard permissions level) rights only on 1 of these folders.

    When user A wants to upload a file to this folder by using drag and drop, he receives the following error:

    User A is able to upload a document using, 'upload document' button on the files ribbon.

    Is this by design, and does the user need other permissions to be able to use the drag and drop funtion?

    Kind Regards,
    Dominique Dewilde 


    • Edited by dd106 Friday, May 31, 2013 8:58 AM grammar
    Friday, May 31, 2013 8:57 AM

Answers

All replies

  • I faced more or less the same problem, I think it's a by design behaviour, users need to have "Add Items" permission on the entire document library to use drag and drop.

    http://social.technet.microsoft.com/Forums/en-US/sharepointgeneral/thread/34ef4bb1-3fa5-4c12-98be-31d70cdc0ed8

    • Marked as answer by dd106 Monday, June 3, 2013 9:24 AM
    Friday, May 31, 2013 12:44 PM
  • Hi Maurizio,

    I've been facing kind of an odd version of this problem, where the solution works for the document library view but I'm still getting the permission error on list view webparts on homepage. I've tried clearing my cache and tested on Chrome and IE but I'm getting the same issue. I can upload documents by Drag and Drop from the default document library view but not from the webpart.

    My Site Owner though is able to do so.

    I even giving the test user full control on the site to test but still getting same error.

    Please refer to screenshots below:

    Drag and Drop on List View Web Part on HomePage:

    Drag and Drop on Document Library Default View:

    Grateful if you could help!

    Thanks and Regards,

    Rhyan.

    Monday, May 18, 2015 9:34 PM
  • In my mind, this is not a navigation problem.  If I log in under my name (as admin) with IE or Chrome, I do have access to drag/drop in a specific folder.  If I log in under another user on the same computer, same navigator, I do have the Permissions needed message...

    I also tried to give the maximum permission to my user 'x', this did not work.

    Tks.

    Louis.

    Thursday, November 3, 2016 3:57 PM